cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
515
Views
5
Helpful
5
Replies

Aggregate two WAN links using LACP on Cisco C9500-24Y4C switches

exams.deshan.net
Beginner
Beginner

As per the business requirement, we need to aggregate two WAN links that are connecting from the data center to a branch office. At both locations, we are having C9500-24Y4C switches and I have configured both the physical interfaces with LACP. Hove ever the EtherChannel is not forming. I have checked the LACP counter status and only the "Send" count is incrementing. Seems both devices are sending but not receiving the LACPDUs. Our WAN underlay network is a VPLS provided by a third-party WAN provider.

 

I have requested to enable LACPDUs over the VPLS network, and the WAN provider confirmed that they enabled the same from their end but still no luck.

 

Are there any additional configurations that need to be done from our end apart from the default LACP configs?

 

The current configuration in the DC end is below

================================================

 

interface TwentyFiveGigE1/0/5
channel-group 14 mode active
end




interface TwentyFiveGigE2/0/5
channel-group 14 mode active
end


================================================

1 Accepted Solution

Accepted Solutions

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Couple of things to check here :

 

1. VPLS from provider looks good, what kind oif Delivery Fibre or Ethernet ?

2. what kind of speed link ( 1G or 10GB ?)

3. these 25Gig port, so you using right Optic and ports come up as below mentioned.

4. Do you see on the port on Cat 9500 come up ? when you Plug VPLS connect to switch (both the sides)

5. have you enabled CDP neighbour, can you see each other switch both the sides ?

 

if all yes then  :

 

interface TwentyFiveGigE1/0/5

switchport

channel-group 14 mode active






interface TwentyFiveGigE2/0/5

switchport
channel-group 14 mode active
end


 

if you like to load-balance different options available once the LACP working :

 

port-channel load-balance  {  dst-ip  |  dst-mac  | dst-mixed-ip-port | dst-port  | extended [ dst-ip  |  dst-mac  |  dst-port  |  ipv6-label  |  l3-proto  |  src-ip  |  src-mac  |  src-port  ] |  src-dst-ip  |   src-dst-mac   src-dst-mixed-ip-port src-dst-portsrc-ip  |  src-mac  | src-mixed-ip-port |  src-port |   vlan-dst-ip |   vlan-dst-mixed-ip-port |   vlan-src-dst-ip |   vlan-src-dst-mixed-ip-port |   vlan-src-ip |   vlan-src-mixed-ip-port }  

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

5 Replies 5

pman
Enthusiast
Enthusiast

here is example for LACP configuration:

 

in this example we assigns two trunk ports in VLAN 10 to channel 2 with the LACP mode active:

Device# configure terminal
Device(config)# interface range TwentyFiveGigE 1/0/1-2
Device(config-if-range)# switchport mode trunk
Device(config-if-range)# switchport trunk allowed vlan add 10
Device(config-if-range)# channel-group 2 mode active
Device(config-if-range)# end




interface port-channel2

switchport mode trunk

switchport trunk allowed vlan add 10


By the way, in a similar case we had several months ago with the same C9500 a switchport trunk native vlan <x> command was missing 

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

For a layer two PC you way you have initially done this is correct,
Once the physical interfaces have been applied to the port -channel then the logical interface will be automatically created (meaning don't create this yourself), Then, in that PC interface you apply your trunking etc which will then be applied to the physical  interfaces automatically


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Couple of things to check here :

 

1. VPLS from provider looks good, what kind oif Delivery Fibre or Ethernet ?

2. what kind of speed link ( 1G or 10GB ?)

3. these 25Gig port, so you using right Optic and ports come up as below mentioned.

4. Do you see on the port on Cat 9500 come up ? when you Plug VPLS connect to switch (both the sides)

5. have you enabled CDP neighbour, can you see each other switch both the sides ?

 

if all yes then  :

 

interface TwentyFiveGigE1/0/5

switchport

channel-group 14 mode active






interface TwentyFiveGigE2/0/5

switchport
channel-group 14 mode active
end


 

if you like to load-balance different options available once the LACP working :

 

port-channel load-balance  {  dst-ip  |  dst-mac  | dst-mixed-ip-port | dst-port  | extended [ dst-ip  |  dst-mac  |  dst-port  |  ipv6-label  |  l3-proto  |  src-ip  |  src-mac  |  src-port  ] |  src-dst-ip  |   src-dst-mac   src-dst-mixed-ip-port src-dst-portsrc-ip  |  src-mac  | src-mixed-ip-port |  src-port |   vlan-dst-ip |   vlan-dst-mixed-ip-port |   vlan-src-dst-ip |   vlan-src-dst-mixed-ip-port |   vlan-src-ip |   vlan-src-mixed-ip-port }  

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi Balaji. I have checked and verified all the steps you have mentioned above and all are good. However, the issue was with the WAN provider. They did some changes at their end and after that port channel formed successfully. Thanks.

Hello,

 

just out of curiosity, what was the issue, and how did the WAN provider fix it ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers