cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
236
Views
0
Helpful
3
Replies
Highlighted
Beginner

ASR 1001x HA HSRP VS rii HELP IPSec and NAT

Hello All,

 

 

So I have two ASR 1001's.  I need these to be HA for NAT and IPsec and also for all the default gateways .

 

The question is how to implement.  I have HSRP set up an it works.  See below

 

R1
interface GigabitEthernet0/1/0.50
encapsulation dot1Q 50
ip address 192.168.0.2 255.255.255.0
standby 50 ip 192.168.0.1
standby 50 priority 150

standby 50 preempt delay reload 60

 

R2

interface GigabitEthernet0/1/0.50
encapsulation dot1Q 50
ip address 192.168.0.3 255.255.255.0
standby 50 ip 192.168.0.1
standby 50 priority 50

standby 50 preempt delay reload 60

 

Everything works fine.  When I go to set up HA for NAT I start to get confused the best setup for HA for the DG.  I see a cisco white paper (https://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/118768-config-asr-00.html) saying to do it like this...see below.

ASR-1#show run int GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
ip address 172.16.1.2 255.255.255.248
ip nat inside
negotiation auto
cdp enable
redundancy rii 100
redundancy group 1 ip 172.16.1.5
exclusive decrement 100

 

What is the difference in these two setups?  

 

 

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: ASR 1001x HA HSRP VS rii HELP IPSec and NAT

Hello,

 

HSRP works on a less granular level, that is, it will kick in when one of the interfaces is unreachable. Stateful Interchassis Failover, your second setup, works on an application level. They essentially do the same thing...

 

That said, the config snippets for both setups you posted are incomplete...

3 REPLIES 3
VIP Mentor

Re: ASR 1001x HA HSRP VS rii HELP IPSec and NAT

Hello,

 

HSRP works on a less granular level, that is, it will kick in when one of the interfaces is unreachable. Stateful Interchassis Failover, your second setup, works on an application level. They essentially do the same thing...

 

That said, the config snippets for both setups you posted are incomplete...

Beginner

Re: ASR 1001x HA HSRP VS rii HELP IPSec and NAT

Thanks!

Beginner

Re: ASR 1001x HA HSRP VS rii HELP IPSec and NAT

Check this out and let me know what you think!

 

https://community.cisco.com/t5/routing/ha-asr1001-rii/m-p/3714473#M302419

 

Thanks in advance :)

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards