cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
920
Views
0
Helpful
2
Replies

ASR1002X GRE tunnel policy in suspended

datacenter
Level 1
Level 1

Hello!

We are facing problems while applying shape policies in our GRE tunnels.

1st problem:

It lets you remove a policy from a interface, but when you try to reenter same line it accepts the command but doesn't apply:

E.g:

ASR1K_DG_RTR_I#sh run int tu211230
!
interface Tunnel211230
description *** Tunel VPN Principal 30 - Linhares ***
bandwidth 10000
ip vrf forwarding TUNEIS
ip address 10.254.112.29 255.255.255.252
ip mtu 1420
qos pre-classify
keepalive 20 6
cdp enable
tunnel source Loopback30
tunnel destination 10.2.112.30
tunnel vrf TUNEIS
end

ASR1K_DG_RTR_I#conf t
ASR1K_DG_RTR_I(config)#int tu211230
ASR1K_DG_RTR_I(config-if)#service-policy out SHAPE_10000
ASR1K_DG_RTR_I(config-if)#do sh run int tu211230
!
interface Tunnel211230
description *** Tunel VPN Principal 30 - Linhares ***
bandwidth 10000
ip vrf forwarding TUNEIS
ip address 10.254.112.29 255.255.255.252
ip mtu 1420
qos pre-classify
keepalive 20 6
cdp enable
tunnel source Loopback30
tunnel destination 10.2.112.30
tunnel vrf TUNEIS
????
end

ASR1K_DG_RTR_I#sh policy-map interface Tunnel211230
ASR1K_DG_RTR_I# ????

2nd problem:

In the interfaces that we already had the policy configured it shows the line, but the policy remains suspended

E.g:

interface Tunnel201230
description *** Tunel VPN Principal 30 - RIB_PRETO ***
bandwidth 920
ip vrf forwarding TUNEIS
ip address 10.254.12.29 255.255.255.252
ip mtu 1420
qos pre-classify
keepalive 20 6
cdp enable
tunnel source Loopback30
tunnel destination 10.2.12.30
tunnel vrf TUNEIS
service-policy output SHAPE_1000_VOZ_100
!

ASR1K_DG_RTR_I#sh policy-map interface Tunnel201230
Tunnel201230

Service-policy output: SHAPE_1000_VOZ_100

Service policy SHAPE_1000_VOZ_100 is in suspended mode

3rd problem:

Some interfaces are working!

E.g:

interface Tunnel205230
description *** Tunel VPN Principal 30 - Hisa-Escritorio ***
bandwidth 4096
ip vrf forwarding TUNEIS
ip address 10.254.52.29 255.255.255.252
ip mtu 1420
qos pre-classify
keepalive 20 6
cdp enable
tunnel source Loopback30
tunnel destination 10.2.52.30
tunnel vrf TUNEIS
service-policy output SHAPE_4000

ASR1K_DG_RTR_I#sh policy-map int Tunnel205230
Tunnel205230

Service-policy output: SHAPE_4000

Class-map: class-default (match-any)
9744 packets, 467712 bytes
!

Here are the policies configuration for further reference:

policy-map SHAPE_1000_VOZ_100
class class-default
shape average 920000
service-policy QOS_VOZ_100

policy-map QOS_VOZ_100
class CLASS_QOS_OURO
bandwidth remaining percent 40
class CLASS_QOS_PRATA
bandwidth remaining percent 30
class CLASS_QOS_BRONZE
bandwidth remaining percent 20
class class-default
fair-queue

policy-map SHAPE_4000
class class-default
shape average 3680000
service-policy QOS_PADRAO

policy-map SHAPE_10000
class class-default
shape average 9200000
service-policy QOS_PADRAO
policy-map QOS_PADRAO
class CLASS_QOS_OURO
bandwidth remaining percent 40
class CLASS_QOS_PRATA
bandwidth remaining percent 30
class CLASS_QOS_BRONZE
bandwidth remaining percent 20
class class-default
fair-queue

Router version:

Cisco IOS Software, ASR1000 Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.5(1)S1, RELEASE SOFTWARE (fc1)

cisco ASR1002-X (2RU-X) processor (revision 2KP) with 3743195K/6147K bytes of memory.

Thanks in advance!

Daniel

2 Replies 2

Hello.

Check which interface is egress per tunnel - show ip cef vrf TUNEIS <tunnel destination>

When service-policy is suspended - it means you are running unsupported configuration.

Diana Karolina Rojas
Cisco Employee
Cisco Employee

Hello!

 

Did you find the root cause of this problem? I have the exactly same issue.

 

Best Regards,

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card