cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1107
Views
0
Helpful
2
Replies

Assign 877 a public IP behind an 1841 using FA0 switchport as WAN int (transparent bridging?)

A brief background on why I need to do what I'm doing... We have two Corporate HQ, with two seperate IT departments, and neither one of us has much trust in the other. So, I have to configure two routers for every new branch. I provide the WAN interfaces and then the other IT department logs into their router and establishes a VPN to their HQ, taking a portion of the bandwidth with it.

I am establishing a new branch today. I have configured my 1841 with a T1 link and used Fa0/0 for my LAN. I want to connect their 877 router to Fa0/1 and pass a public IP to it. I have a block of 5 public IPs.

I think what I want to do is called "Transparent Bridging," but really, I have no idea. The 877 won't allow me to configure an IP address on the interface because it is a switchport. So what do I need to do??? If you need any more information or anything, just let me know. I need this up today or my boss is going to realize that I'm not as good as I say I am! Just kidding, but I would love to have this working today. Thank you in advance for any help you can offer.

I don't need to configure anything on the 877 except the WAN link with remote access.

Physically, it looks like this:

**INTERNET** x.x.x.137 /29 <--------> Serial0/0/0.1 p2p - 1841 - Fa0/1 <---------> Fa0 - 877

RUNNING CONFIG - 1841

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
multilink bundle-name authenticated
!
!
archive
log config
  hidekeys
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
description MICROS
encapsulation dot1Q 10
ip address 10.11.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.20
description CAMERAS
encapsulation dot1Q 20
ip address 10.11.2.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.30
description MANAGEMENT
encapsulation dot1Q 30
ip address 10.11.3.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
no ip address
ip nat inside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
ip address x.x.x.137 255.255.255.248
ip nat outside
ip virtual-reassembly
snmp trap link-status
frame-relay interface-dlci 500 IETF
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1
!
!
ip http server
ip nat inside source list 1 interface Serial0/0/0.1 overload
!
access-list 1 permit 10.11.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login local
transport input telnet
line vty 5 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end

2 Replies 2

paolo bevilacqua
Hall of Fame
Hall of Fame

First of all, the 877 is the wrong model for teh job, the right one would be the 871.

However it can be done anyway, and no bridging involved (fortunately).

On the 877, ccongiure vlan interface instead, the way you want. Then assing one or more phisical itnerface to the vlan, via "switchport access vlan xx".

For more than 2 vlan, you need and advanced ip services image.

Thanks for the fast reply.

Sounds easy enough, but what needs to be configured on the 1841's FA0/1 port though? Just the outside IP that I want to use?

And just an fyi... we order 871's, but Cisco has them on backorder until June!

UPDATE

I configured an interface vlan on the 877... assigned it to Fa0 and created a default route through Fa0. I'm not sure on what access lists or other configuration parameters may be needed to make this work. I haven't been able to find anything on this particular scenario on the web yet. Could I request that someone guide me on how they would have this configured?

The 1841 has a WAN ip of x.x.x.137 /29.

I want the 877 to have a WAN ip of x.x.x.138 /29.

I suppose the 1841 would just be acting like a "next hop" to the internet... I realize this isn't an ideal situation or configuration. And that it may seem odd that I am configuring these particular devices in this way, but, its what I have to work with for now. Please advise. Thank you.

Message was edited by: James Diroff II

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card