cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1626
Views
0
Helpful
4
Replies
p.maillot
Beginner

Bandwidth shared

Hello,

I receive from my ISP 2M of bandwidth on interface f0, I need share this bandwitch four customer with CIR 1:4.

The goal is that the four customer have minimum guaranteed of 512k but if there are no traffic they can have more until 2M.

Someone have an idea, which mechanism put in place?

Thank

4 REPLIES 4
Edison Ortiz
Hall of Fame Mentor

access-list 101 permit ip [customer_1] any

access-list 102 permit ip [customer_2] any

access-list 103 permit ip [customer_3] any

access-list 104 permit ip [customer_4] any

!

class-map customer_1

match access-group 101

class-map customer_2

match access-group 102

class-map customer_3

match access-group 103

class-map customer_4

match access-group 104

!

policy-map WAN_QOS

class customer_1

bandwidth percent 25

class customer_2

bandwidth percent 25

class customer_3

bandwidth percent 25

class customer_4

bandwidth percent 25

!

interface xxxxx

service-policy output WAN_QOS

Thank Edison for your answer.

Question with this conf, all customer have 25 percent of the bandwidth, but if there are bandwith not use, it will be redistributed to other clients ?

Hi,

   Edison provided you a good solution. It's called congestion management. QOS will get involved when interface get congestion. However,you're using Fastethenet interface facing wan. It's hard to get this interface congestion. However,you can do it by using a shaping mechanism, including a child policy to manage queues.

For example

!

policy-map shape-customer
 class class-default 
  shape average 2000000 
  service-policy WAN_QOS

!

HTH,

Toshi

Disclaimer

The Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind.  Usage of  this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever  (including, without limitation, damages for loss of use, data or profit)  arising out of the use or inability to use the posting's information  even if Author has been advised of the possibility of such damage.

Posting

p.maillot wrote:

Thank Edison for your answer.

Question with this conf, all customer have 25 percent of the bandwidth, but if there are bandwith not use, it will be redistributed to other clients ?

Yes it will, although some IOS versions will complain if you allocate more than 75% bandwidth without making another parameter change.  As long as all traffic falls within just the four classes, as long as the class weights are the same, each class will be guaranteed 25% of the bandwidth if they all want more.  I.e., setting all four classes to 1% would accomplish the same goal, 1:1:1:1 ratios.

As Thotsaphon noted, since you also mentioned 2 Mbps cap, what he shows would be how to limit the aggregate traffic to 2 Mbps but you could also limit each customer to 2 Mbps too.  I.e. you could guarantee both a minimum and maximum per customer.  This isn't too useful unless your "selling" bandwidth guarantees.