cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

602
Views
10
Helpful
12
Replies
Frequent Contributor

Bandwith allocation

Hi,

I have 2851 router & have 3 ISP's each having 10 Mbps. Below are my requirement

Having 2 Internal network

172.16.0.0/24(Network-A) &172.16.1.0/24 (Network-B)

I need to allocate Internet bandwith70% for Network-A &30% for Network-B.

Would that be possible based on the source LAN network for bandwith allocation in my Cisco 2851 or any other 3800 series router? ie. at any given point of time, 70-30 should be allocated for both the LAN subnet even if 1 ISP fails?

Anand

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Bandwith allocation

Hi Anand,

Hope you have a seperate Vlan's for Network-A and Network-B. If you have then it would be possible to allocate bandwidth under the vlan's

See the below two individual steps may help in your scenario.


STEP-1:

Apply rate-limit on each L3 vlan interface in your 2851
Example (for 1024kbits for vlan 2):

Router# conf t
Router(config)# int vlan 2
Router(config-if)#rate-limit input 1000000 187500 375000 conform-action transmit exceed-action drop
Router(config-if)#rate-limit output 1000000 187500 375000 conform-action transmit exceed-action drop


STEP-2:

Policy a specific VLAN number on VLAN interface.

class-map vlan5
match vlan 5
match class-map class-default

policy-map vlan5-limit
class vlan5
police 2000000 250000 exceed-action drop

int vlan5
service-policy input vlan5-limit


After you apply this configuration, the traffic with VLAN 5 coming from any will be policed at 2Mbps.


Hope this will help you.


Please rate the helpfull posts.
Regards,
Naidu.

View solution in original post

Re: Bandwith allocation

The Minimum i guess it is 1 Mb and max it is 8 Mb.

See the below config may help you to set max Mbps that would allow to exceed.


class-map vlan5
match vlan 5
match class-map class-default

policy-map vlan5-limit
class vlan5
police 8000 1500 1500 conform-action transmit exceed-action drop violate-action drop

int vlan5
service-policy input vlan5-limit

Please rate the helpfull posts.
Regards,
Naidu.

View solution in original post

12 REPLIES 12

Re: Bandwith allocation

Hi Anand,

Hope you have a seperate Vlan's for Network-A and Network-B. If you have then it would be possible to allocate bandwidth under the vlan's

See the below two individual steps may help in your scenario.


STEP-1:

Apply rate-limit on each L3 vlan interface in your 2851
Example (for 1024kbits for vlan 2):

Router# conf t
Router(config)# int vlan 2
Router(config-if)#rate-limit input 1000000 187500 375000 conform-action transmit exceed-action drop
Router(config-if)#rate-limit output 1000000 187500 375000 conform-action transmit exceed-action drop


STEP-2:

Policy a specific VLAN number on VLAN interface.

class-map vlan5
match vlan 5
match class-map class-default

policy-map vlan5-limit
class vlan5
police 2000000 250000 exceed-action drop

int vlan5
service-policy input vlan5-limit


After you apply this configuration, the traffic with VLAN 5 coming from any will be policed at 2Mbps.


Hope this will help you.


Please rate the helpfull posts.
Regards,
Naidu.

View solution in original post

Frequent Contributor

Re: Bandwith allocation

Hi Na

  YES 2 VLAN's for Network-A & Network-B will be created on Cisco 2851 (ISP Router). To add extra, my actual setup (like how i am planning) will be like ISP-1 on Router-1, ISP-2 on Router-2 & ISP-3 on Router-3, so all i will have the configuration set in my 3 routers as you mentioned. So using the load sharing device behind the router, the load sharing device decides on which ISP it routes.

Will that work or any suggestions?

Re: Bandwith allocation

Hi,

Does this mean you have seperate load sharing device?

If that is the case it should work as the device for that.

Regards,

Naidu.

Frequent Contributor

Re: Bandwith allocation

Hi,

  OK let me not include load balancer here. So with the configuration you have mentioned, it should be working without having any issue. I will try & let me know the results.

Frequent Contributor

Re: Bandwith allocation

Hi Naidu,

  My router does not support vlan. so i created sub-interface. Can you paste me the exact command in order?

Anand

Re: Bandwith allocation

Hi Anand,

As far i know the 2851 ISR will support to configure vlan's

below is the example config from 2851 working router...

========================================================================================================
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.90
encapsulation dot1Q 90
ip address 10.x.x.x x.x.x.x
!
interface GigabitEthernet0/0.91    *****SUBINTERFACE CREATED FOR TESTING PURPOSES*****
description Management
encapsulation dot1Q 91
ip address 10.x.x.x x.x.x
!
interface GigabitEthernet0/1
ip address 10.x.x.x x.x.x
duplex auto
speed auto
!
interface FastEthernet0/1/0     *****ACCESS PORT FOR THE VLAN*****
description Test port
switchport access vlan 91
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Vlan1
no ip address
!
interface Vlan91                     ****VLAN 91 CREATED****
description Testing Vlan
ip address 10.x.x.x x.x.x


HERE IS THE IP ROUTE TO MATCH
ip route 10.x.x.x x.x.x outgoing interface

========================================================================================================

No problem if still your router doesn't support for vlans you can create subinterface (hope you created) and confgirue vlan's like below example...


#interface fa0/0
#no ip address
#no shutdown

#interterface fa0/0.1 (were 1 stands for the vlan created)
#encap dot1q
ip address 192.168.1.1 255.255.255.0

Like the above you can create multiple sub interfaces for vlan's


Make sure you configure each subinterface with the encapsulation type (I assume dot1q) and the vlan id.

Hope that helps you.

Please rate all the helpfull posts.

Regards,
Naidu.

Frequent Contributor

Re: Bandwith allocation

STEP1 configuration which you have mentioned worked perfectly, thanks for that. The given configuration would not allow to exceed more than 2 Mbps. My requirement is, created 2 vlans (VLAN2 & VLAN3), applied that configuration for VLAN2 as 2 Mbps & 3Mbps for VLAN3. Now when VLAN3 is not utilizing more than 1Mbps, i wanted VLAN2 to use make of the free 2Mbps available in VLAN3. This makes VLAN2 users having 4Mbps & when VLAN3 doesn't uses itz entire 3Mbps allocated bandwith. Can we have this configuration? Also please let me know what is Minimum & Maximum burst.

Re: Bandwith allocation

The Minimum i guess it is 1 Mb and max it is 8 Mb.

See the below config may help you to set max Mbps that would allow to exceed.


class-map vlan5
match vlan 5
match class-map class-default

policy-map vlan5-limit
class vlan5
police 8000 1500 1500 conform-action transmit exceed-action drop violate-action drop

int vlan5
service-policy input vlan5-limit

Please rate the helpfull posts.
Regards,
Naidu.

View solution in original post

Highlighted
Frequent Contributor

Re: Bandwith allocation

This is perfect Naidu. I have reated as well.

Re: Bandwith allocation

I am glad that my suggestions and thoughts helped you.
But no idea how you rated as it is not counted. If you see the post there is no any points but still it marked as Answered.
Please rate once again perfectly.

Regards,
Naidu.

Frequent Contributor

Re: Bandwith allocation

Oops sorry about that Naidu. It was my IE Browser issue, it clicked but did not update the rating. So tried the same using firefox now & could notice it is rated now.

Re: Bandwith allocation

No problem Anand, it is now.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here