cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

244
Views
0
Helpful
8
Replies
Beginner

Basic BGP Configuration

I'm very new to BGP and have been using GNS3 to help me understand how to configure BGP on Cisco IOS. See below what my test network looks like and I've attached the configs from the 3 devices.

 

I'm seeing the 3 VLAN's on the LAN Core in the Gateway and CPE01 routing tables. I can ping the 3 VLAN interfaces from the Gateway device but not on the CPE01, when I do a trace route from the CPE01 device to the VLAN interfaces first hop is Gateway VLAN 600 address and then it fails.

 

Any help would be much appreciated?

 InkedScreenHunter 53 Aug. 20 09.55_LI.jpg

 

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: Basic BGP Configuration

Hello, 

 

The configs are correct. Which devices are you using in GNS3 ?

View solution in original post

8 REPLIES 8
VIP Mentor

Re: Basic BGP Configuration

I don't see the configs (sh run) attached...

Beginner

Re: Basic BGP Configuration

LAN Core

interface Loopback0
no ip address
!
interface Ethernet0/0
no switchport
ip address 10.170.94.2 255.255.255.252
duplex auto
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
--More--  !
interface Ethernet1/0
!
interface Ethernet1/1
!
interface Ethernet1/2
!
interface Ethernet1/3
!
interface Ethernet2/0
!
interface Ethernet2/1
!
interface Ethernet2/2
!
interface Ethernet2/3
!
interface Ethernet3/0
!
interface Ethernet3/1
switchport access vlan 103
!
interface Ethernet3/2
--More--   switchport access vlan 102
!
interface Ethernet3/3
switchport access vlan 101
!
interface Vlan1
no ip address
shutdown
!
interface Vlan101
ip address 10.170.0.1 255.255.252.0
!
interface Vlan102
ip address 10.170.4.1 255.255.252.0
!
interface Vlan103
ip address 10.170.8.1 255.255.252.0
!
router bgp 100
bgp log-neighbor-changes
network 10.170.0.0 mask 255.255.252.0
network 10.170.4.0 mask 255.255.252.0
network 10.170.8.0 mask 255.255.252.0
--More--   neighbor 10.170.94.1 remote-as 100
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server

 

Gateway

 

interface Ethernet0/0
no switchport
ip address 10.170.94.1 255.255.255.252
duplex auto
!
interface Ethernet0/1
!
interface Ethernet0/2
switchport access vlan 600
!
interface Ethernet0/3
switchport access vlan 600
!
--More--  interface Ethernet1/0
!
interface Ethernet1/1
!
interface Ethernet1/2
!
interface Ethernet1/3
!
interface Ethernet2/0
!
interface Ethernet2/1
!
interface Ethernet2/2
!
interface Ethernet2/3
!
interface Ethernet3/0
!
interface Ethernet3/1
!
interface Ethernet3/2
!
interface Ethernet3/3
--More--  !
interface Vlan1
no ip address
shutdown
!
interface Vlan600
ip address 10.170.39.1 255.255.255.240
!
router bgp 100
bgp log-neighbor-changes
neighbor 10.170.39.9 remote-as 65057
neighbor 10.170.94.2 remote-as 100
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server

 

CPE01

 

interface Ethernet0/0
!
interface Ethernet0/1
!
interface Ethernet0/2
no switchport
ip address 10.170.39.9 255.255.255.240
duplex auto
!
interface Ethernet0/3
!
interface Ethernet1/0
!
--More--  interface Ethernet1/1
!
interface Ethernet1/2
!
interface Ethernet1/3
!
interface Ethernet2/0
!
interface Ethernet2/1
!
interface Ethernet2/2
!
interface Ethernet2/3
!
interface Ethernet3/0
!
interface Ethernet3/1
!
interface Ethernet3/2
!
interface Ethernet3/3
!
interface Vlan1
--More--   no ip address
shutdown
!
router bgp 65057
bgp log-neighbor-changes
neighbor 10.170.39.1 remote-as 100
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server

 

VIP Mentor

Re: Basic BGP Configuration

Hello,

 

your LAN Core router does not have a route back to CPE01. You can add a static route on the LAN Core router:

 

ip route 0.0.0.0 0.0.0.0 10.170.94.1

 

Also, configure the neighbors in AS100 with next hop self:

 

LAN Core

 

neighbor 10.170.94.1 remote-as 100
neighbor 10.170.94.1 next-hop-self

 

Gateway

 

neighbor 10.170.94.2 remote-as 100
neighbor 10.170.94.2 next-hop-self

 

Beginner

Re: Basic BGP Configuration

Thanks for the info, I added what you recommended below but I still can't ping from CPE01 to any address on LAN Core

Highlighted
VIP Mentor

Re: Basic BGP Configuration

Hello,

 

post your running configs again with the changes...you might have misconfigured something...

Beginner

Re: Basic BGP Configuration

See below config with changes.



CPE



interface Ethernet0/0

!

interface Ethernet0/1

!

interface Ethernet0/2

no switchport

ip address 10.170.39.9 255.255.255.240

duplex auto

!

interface Ethernet0/3

!

interface Ethernet1/0

!

interface Ethernet1/1

!

interface Ethernet1/2

!

interface Ethernet1/3

!

interface Ethernet2/0

!

interface Ethernet2/1

!

interface Ethernet2/2

!

interface Ethernet2/3

!

interface Ethernet3/0

!

interface Ethernet3/1

!

interface Ethernet3/2

!

interface Ethernet3/3

!

interface Vlan1

no ip address

shutdown

!

router bgp 65057

bgp log-neighbor-changes

neighbor 10.170.39.1 remote-as 100

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login



Gateway



!

interface Ethernet0/0

no switchport

ip address 10.170.94.1 255.255.255.252

duplex auto

!

interface Ethernet0/1

!

interface Ethernet0/2

switchport access vlan 600

!

interface Ethernet0/3

switchport access vlan 600

!

interface Ethernet1/0

!

interface Ethernet1/1

!

interface Ethernet1/2

!

interface Ethernet1/3

!

interface Ethernet2/0

!

interface Ethernet2/1

!

interface Ethernet2/2

!

interface Ethernet2/3

!

interface Ethernet3/0

!

interface Ethernet3/1

!

interface Ethernet3/2

!

interface Ethernet3/3

!

interface Vlan1

no ip address

shutdown

!

interface Vlan600

ip address 10.170.39.1 255.255.255.240

!

router bgp 100

bgp log-neighbor-changes

neighbor 10.170.39.9 remote-as 65057

neighbor 10.170.94.2 remote-as 100

neighbor 10.170.94.2 next-hop-self

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!



LAN Core



!

interface Loopback0

no ip address

!

interface Ethernet0/0

no switchport

ip address 10.170.94.2 255.255.255.252

duplex auto

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet1/0

!

interface Ethernet1/1

!

interface Ethernet1/2

!

interface Ethernet1/3

!

interface Ethernet2/0

!

interface Ethernet2/1

!

interface Ethernet2/2

!

interface Ethernet2/3

!

interface Ethernet3/0

!

interface Ethernet3/1

switchport access vlan 103

!

interface Ethernet3/2

switchport access vlan 102

!

interface Ethernet3/3

switchport access vlan 101

!

interface Vlan1

no ip address

shutdown

!

interface Vlan101

ip address 10.170.0.1 255.255.252.0

!

interface Vlan102

ip address 10.170.4.1 255.255.252.0

!

interface Vlan103

ip address 10.170.8.1 255.255.252.0

!

router bgp 100

bgp log-neighbor-changes

network 10.170.0.0 mask 255.255.252.0

network 10.170.4.0 mask 255.255.252.0

network 10.170.8.0 mask 255.255.252.0

neighbor 10.170.94.1 remote-as 100

neighbor 10.170.94.1 next-hop-self

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip route 0.0.0.0 0.0.0.0 10.170.94.1

!

!



!




VIP Mentor

Re: Basic BGP Configuration

Hello, 

 

The configs are correct. Which devices are you using in GNS3 ?

View solution in original post

Beginner

Re: Basic BGP Configuration

I'm using switches running Cisco IOU L2 15.2d



Thanks


CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards