cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1219
Views
0
Helpful
2
Replies
Beginner

BGP ipv6 default route origination

Hi,

 

My colleague and i are struggling to originate a IPv6 BGP default route from one of our core switches to an eBGP peer.

 

This is the configuration (below) we have tried and does work within GNS3 running the same IOS but it doesn't seem to work on our live environment.

 

router bgp XXXX

bgp router-id 1.1.1.1

bgp log-neighbor-changes

neighbor x:x:6:11::1 remote-as 65003

!

address-family ipv6

  network ::/0

  neighbor x:x:6:11::1 activate

  neighbor x:x:6:11::1 prefix-list 65003-out out

exit-address-family

!

ipv6 route ::/0 Null0

!

ipv6 prefix-list 65003-out seq 5 permit ::/0

 

When we reverse the above configuration, so we send a IPv6 Default BGP route from the customer to the core the above configuration works, however, the core see's the route as ::/8 not ::/0 (very strange). Has anybody seen this before? This doesn't make sense as on the customer infrastructure we can see ::/0 in the BGP table but on the core we see ::/8. We are thinking because the core is seeing the route as::/8 this is having an affect when we are trying to originate ::/0 from the core to the customer.. 

 

Maybe this is a bug but we're not sure. Anybody seen this before?

 

Cheers,

 

 

Everyone's tags (2)
2 REPLIES 2
Highlighted
VIP Mentor

Hello conf t no ipv6 route ::

Hello

 

conf t

 

no ipv6 route ::/0 Null
no ipv6 prefix-list 65003-out seq 5 permit ::/0


router bgp XXXX

address-family ipv6

 no network ::/0
no neighbor x:x:6:11::1 prefix-list 65003-out out
neighbor x:x:6:11::1 default-originate

exit-address-family

clear bgp ipv6 unicast * soft
 

 

res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Hi Paul, thanks for the

Hi Paul, thanks for the response. We have tried that it doesn't work.

 

We have just found out the switch has a problem dealing with a bogus route ::/8 and the default route ::/0. If we drop ::/8 on the edge ::/0 appears in the routing table, if we permit ::/8 ::/0 drops out. We will be logging this with Cisco.

 

Thanks for your help anyway.

CreatePlease to create content