cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1783
Views
10
Helpful
5
Replies
satishmothukri
Beginner

BGP load sharing : CE to PE with two links

Hi Experts ,

I have below setup .

                                         2Mbps

( AS Number 20 )CE router ---------------   PE router (AS number 10)

                                         --------------    

                                             2Mbps

We have two links from CE to PE router and Sub inerfaces are created on CE router for data vlan and voice vlan's (router on a Stick).

Configured maximum-paths under router on CE router for load balancing the traffic.

Can I use ' bgp bestpath as-path multipath-relax "  command for load sharing as both links connecting to same AS on PE.

Below is the configuration of CE router :

interface FastEthernet0/2/0

ip address 10.10.10.4 255.255.255.248

load-interval 30

duplex full

speed 10

interface FastEthernet0/2/1

ip address 20.20.20.4 255.255.255.248

load-interval 30

duplex full

speed 10

service-policy output to-mpls

!

router bgp 20

bgp log-neighbor-changes

neighbor 10.10.10.5 remote-as 10

neighbor 20.20.20.5 remote-as 10

maximum-paths 2

!

address-family ipv4

  redistribute connected route-map CONNECTED-BGP

   neighbor 10.10.10.5 activate

  neighbor 10.10.10.5 soft-reconfiguration inbound

  neighbor 10.10.10.5 route-map PE-CE-GROUP1 in

  neighbor 10.10.10.5 route-map CE-PE-GROUP1 out

  neighbor 20.20.20.5 activate

  neighbor 20.20.20.5 soft-reconfiguration inbound

  neighbor 20.20.20.5 route-map PE-CE-GROUP1 in

  neighbor 20.20.20.5 route-map CE-PE-GROUP1 out

  maximum-paths 2

  no auto-summary

  no synchronization

exit-address-family

ip as-path access-list 500 permit ^$

ip access-list standard CONNECTED-FILTER-BGP

permit any

ip access-list standard DEFAULT-ROUTE

permit 0.0.0.0

route-map CE-PE-GROUP1 deny 10

match ip address DEFAULT-ROUTE

route-map CE-PE-GROUP1 permit 30

match as-path 500

route-map CE-PE-GROUP1 deny 40

route-map PE-CE-GROUP1 permit 10

match ip address DEFAULT-ROUTE

route-map PE-CE-GROUP1 deny 20

route-map CONNECTED-BGP permit 10

match ip address CONNECTED-FILTER-BGP

ip access-list standard CONNECTED-FILTER-BGP
permit any
ip access-list standard DEFAULT-ROUTE
permit 0.0.0.0

When I do trace route to destination ip's , traffic is taking 10.10.10.5 path only.

What else we can do for load balancing in  the above scenario.

Thanks ,
M S K       

Thanks , M S K
5 REPLIES 5
Giuseppe Larosa
Hall of Fame Master

Hello Satish,

>> Configured maximum-paths under router on CE router for load balancing the traffic.

configure it also on the PE node under router bgp address family ipv4 vrf (you can use maximum-paths eibgp 2 on PE side).

To check load balancing the first thing to do is to check the IP routing table.

On CE node:

show ip route 0.0.0.0

show ip bgp 0.0.0.0

you should see two entries one via 10.10.10.5 and one via 20.20.20.5

On PE side you can

show ip route vrf

to see if CE routes are installed on both paths

>> Can I use ' bgp bestpath as-path multipath-relax "  command for load sharing as both links connecting to same AS on PE.

This is not needed in your case, when the peering AS is the same maximum-paths command is enough

Edit:

load balancing is flow based and you need to use multiple flows with different IP source address and different IP destination address to see it in action.

Hope to help

Giuseppe

HI Giuseppe ,

Two links are going to different POP's of MPLS but PE end AS number is 10.Does it create any problem to load sharing..

Edit:

load balancing is flow based and you need to use multiple flows with different IP source address and different IP destination address to see it in action

>>  As per you comment , I need to create access-list for routing few subents through one link and remaning subents through other link.

Thanks ,
M S K

Thanks , M S K

Hello Satish,

>> Two links are going to different POP's of MPLS but PE end AS number is 10.Does it create any problem to load sharing

It can create issues as the maximum-paths will work if the two BGP advertisements have same parameters in most important attributes for BGP best path selection. The two BGP advertisements that your CE node receives may have different MED (BGP metriv) reflecting the fact that the two PE nodes are in different POPs and see a different IGP metric to BGP next-hop ( that of remote VPN site PE node). But, if my understanding is correct you are only receiving a default route from each BGP nexthop that is likely locally generated by each PE node on its own.

Post

show ip bgp 0.0.0.0

taken from CE node in order to see if the two BGP advertisements are comparable or not, and if not for what reasons.

The fact that the CE nodes connects to two different PE nodes belonging to different SP POPs has an effect also on how traffic returns to your VPN site. One of the two PE nodes may appear as a best path for remote PE nodes serving other VPN sites. (best IGP metric to iBGP next-hop)

From the information you have provided it is more likely that load balancing might not happen in the direction MPLS cloud to your VPN site.

>>

>>  As per you comment , I need to create access-list for routing few subents through one link and remaning subents through other link.

No, I didn't mean this just tried to explain how load balancing works ( not only in eBGP case) it is not a load balancing per packet but flow based, packets classified in the same flow use the same path.

Hope to help

Giuseppe

Hi Giuseppe ,

Most of the site are having phones ocnnecte on the LAN switches.QoS is configured to priortize voice traffic which traverses over WAN .

If we place CE to PE links in load balacing mode and if PE to CE links are not in load balancing then would it cause echo issues for users whoever using IP phones ?

Traffic whichever flows from CE to PE would utilize both the links but if you consider reverse traffic ie from PE to CE would take only one path. Does it creates any problem to user who access various applications present in Differnet locations ?

Thanks ,
M S K

Thanks , M S K

Hello Satish,

>> If we place CE to PE links in load balacing mode and if PE to CE links are not in load balancing then

would it cause echo issues for users whoever using IP phones ?

This should not happen. Simply if load balancing is configured and operational only in CE to PE direction, return traffic will use a single 2 Mbps link.

>> Traffic whichever flows from CE to PE would utilize both the links but if you consider reverse traffic ie from PE to CE would take only one path.

Interacting with SP tech people you might achieve load balancing in both directions, in any case there are no direct issues in having load balancing working only in one direction for user traffic

Hope to help

Giuseppe