cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2270
Views
0
Helpful
15
Replies

BGP not Advertising between Neighbors

haydavis
Beginner
Beginner

Routes in route table not sent to bgp peer at 10.0.79.70 but only two subnets sent. Need to send them all including default route.

 

<hostname removed>#sh ip bgp nei 10.0.79.70  adv
BGP table version is 1840, local router ID is 172.16.159.17
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.0.79.64/28    0.0.0.0                  0         32768 i
 *>  172.16.159.17/32 0.0.0.0                  0         32768 i

 

 

router bgp 64600
 bgp router-id 172.16.159.17
 bgp log-neighbor-changes
 network 10.0.17.0 mask 255.255.255.0
 network 10.0.79.64 mask 255.255.255.240
 network 172.16.159.17 mask 255.255.255.255
 network 172.16.159.20 mask 255.255.255.254
 neighbor 10.0.79.70 remote-as 65310
 neighbor 10.0.79.70 description <removed>
 neighbor 10.0.79.70 timers 10 30
 neighbor 10.0.79.70 soft-reconfiguration inbound
 neighbor 152.176.112.225 remote-as 65000
 neighbor 152.176.112.225 description CE to  PE RVDL9E01
 neighbor 152.176.112.225 timers 30 90
 neighbor 152.176.112.225 fall-over bfd
 neighbor 152.176.112.225 send-community
 neighbor 152.176.112.225 soft-reconfiguration inbound
 neighbor 152.176.112.225 route-map PIP-IN-PRIMARY in
 neighbor 152.176.112.225 route-map PIP-OUT-PRIMARY out

 

sh ip bgp nei
BGP neighbor is 10.0.79.70,  remote AS 65310, external link
 Description: <removed>
  BGP version 4, remote router ID 10.0.79.70
  BGP state = Established, up for 00:00:42
  Last read 00:00:02, last write 00:00:04, hold time is 30, keepalive interval is 10 seconds
  Configured hold time is 30, keepalive interval is 10 seconds
  Minimum holdtime from neighbor is 0 seconds
  Neighbor sessions:
    1 active, is not multisession capable (disabled)
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Enhanced Refresh Capability: advertised and received
    Multisession Capability:
    Stateful switchover support enabled: NO for session 1
  Message statistics:
    InQ depth is 0
    OutQ depth is 0

                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                2          2
    Keepalives:             6          6
    Route Refresh:          0          0
    Total:                  9          9
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  Session: 10.0.79.70
  BGP table version 1854, neighbor version 1854/0
  Output queue size : 0
  Index 18, Advertise bit 0
  18 update-group member
  Inbound soft reconfiguration allowed
  Outbound path policy configured
  Route map for outgoing advertisements is LOCAL-OUT-PRIMARY
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          3 (Consumes 240 bytes)
    Prefixes Total:                 2          3
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          2
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Other Policies:                    1790        n/a
    Total:                             1790          0
  Number of NLRIs in the update sent: max 286, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                                       Sent       Rcvd
        Refresh activity:              ----       ----
          Refresh Start-of-RIB          0          0
          Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 10.0.79.70
  Connections established 3; dropped 2
  Last reset 00:05:24, due to Active open failed
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled

 

ROUTING TABLE:

Gateway of last resort is 152.176.112.225 to network 0.0.0.0

B*    0.0.0.0/0 [20/0] via 152.176.112.225, 01:02:56
      10.0.0.0/8 is variably subnetted, 1456 subnets, 17 masks
B        10.0.0.0/24 [20/0] via 152.176.112.225, 01:02:56
B        10.0.10.0/24 [20/0] via 152.176.112.225, 01:02:56
B        10.0.11.0/24 [20/0] via 152.176.112.225, 01:02:56
B        10.0.14.0/23 [20/0] via 152.176.112.225, 01:02:56
B        10.0.17.0/24 [20/0] via 10.0.79.70, 00:01:30
B        10.0.19.0/24 [20/0] via 152.176.112.225, 01:02:56

 

IP routing table name is default (0x0)
IP routing table maximum-paths is 32
Route Source    Networks    Subnets     Replicates  Overhead    Memory (bytes)
connected       0           5           0           300         900
static          0           0           0           0           0
application     0           0           0           0           0
bgp 64600       1           1787        0           107280      321840
  External: 1788 Internal: 0 Local: 0
internal        19                                              73720
Total           20          1792        0           107580      396460

1 Accepted Solution

Accepted Solutions

sivam siva
Participant
Participant

Hi

" route-map PIP-IN-PRIMARY in"  Check this inbound route-map  whether the "no-export " community  command executed or not against the inbound traffic , may be that could be a reason .

View solution in original post

15 Replies 15

haydavis
Beginner
Beginner

Someon mentioned to me syncronization but this is disabled.

 

sh ip protocol
*** IP Routing is NSF aware ***

Routing Protocol is "application"
  Sending updates every 0 seconds
  Invalid after 0 seconds, hold down 0, flushed after 0
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Maximum path: 32
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 4)

Routing Protocol is "bgp 64600"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Neighbor(s):
    Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
    10.0.79.70
    152.176.112.225                                       PIP-IN-PRIMARY
  Maximum path: 1
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.0.79.70            20      00:17:30
    152.176.112.225       20      00:02:54
  Distance: external 20 internal 200 local 200

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

the only networks you are sending are:

 

network 10.0.17.0 mask 255.255.255.0
network 10.0.79.64 mask 255.255.255.240
network 172.16.159.17 mask 255.255.255.255

 

Are these networks in your routing table ? Post the full configs of both neighbors including the output of 'show ip route'.

 

The two advertised subnets are the Loopback and Gigabit0/1 interface. Nothing from the routing table is injected into the bgp peer 10.0.79.70.

 

#sh ip bgp nei 10.0.79.70  adv
BGP table version is 1868, local router ID is 172.16.159.17
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.0.79.64/28    0.0.0.0                  0         32768 i
 *>  172.16.159.17/32 0.0.0.0                  0         32768 i

Total number of prefixes 2

 

#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         10.0.17.1       YES manual administratively down down
GigabitEthernet0/1         10.0.79.65      YES manual up                    up
GigabitEthernet0/2         152.176.112.226 YES NVRAM  up                    up
Loopback0                  172.16.159.17   YES NVRAM  up                    up

 

Routing table has 1700 subnets.

Original post has bgp config.  Routing in/out with peer 152.176.112.225 works fine.  Only with peer 10.0.79.70  is not sending. However recieving subnets work fine. Its only outbound the route injection not working.  I dont have access to remote peer but it is confirmed no subnets recieved from my router.

 

pbserv-uschi300-re01#sh ip bgp  | i 10.0.79.70
 *>  10.0.17.0/24     10.0.79.70               0             0 65310 ?
 *>  10.0.76.144/29   10.0.79.70               0             0 65310 ?
 *   10.0.79.64/28    10.0.79.70               0             0 65310 ?

 

 

Interface configuration of peer.

 

interface GigabitEthernet0/1
 ip address 10.0.79.65 255.255.255.240
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip accounting output-packets
 ip flow ingress
 duplex auto
 speed auto
 no mop enabled
 service-policy input ingress-mark

Hello,

 

how is this interface involved in BGP ?

 

Interface configuration of peer.

 

interface GigabitEthernet0/1
ip address 10.0.79.65 255.255.255.240

 

The only peer you have configured is:

 

10.0.79.70

Thx for the replies.

Peers are:

10.0.79.70  Gi0/1  Working only inbound updates only.

152.176.112.225  Gi0/2 Working both in and outbound

 

router bgp 64600
 bgp router-id 172.16.159.17
 bgp log-neighbor-changes
 network 10.0.17.0 mask 255.255.255.0
 network 10.0.79.64 mask 255.255.255.240
 network 172.16.159.17 mask 255.255.255.255
 network 172.16.159.20 mask 255.255.255.254
 neighbor 10.0.79.70 remote-as 65310
 neighbor 10.0.79.70 description CE to <removed>
 neighbor 10.0.79.70 update-source Loopback0
 neighbor 10.0.79.70 timers 10 30
 neighbor 10.0.79.70 next-hop-self
 neighbor 10.0.79.70 soft-reconfiguration inbound
 neighbor 152.176.112.225 remote-as 65000
 neighbor 152.176.112.225 description CE to  PE <removed>
 neighbor 152.176.112.225 password <removed>
 neighbor 152.176.112.225 timers 30 90
 neighbor 152.176.112.225 fall-over bfd
 neighbor 152.176.112.225 send-community
 neighbor 152.176.112.225 soft-reconfiguration inbound
 neighbor 152.176.112.225 route-map PIP-IN-PRIMARY in
 neighbor 152.176.112.225 route-map PIP-OUT-PRIMARY out

Hello,

 

in your previous post you wrote:

 

--> Interface configuration of peer.

 

interface GigabitEthernet0/1
ip address 10.0.79.65 255.255.255.240

 

What is the purpose of this interface ? Where is this configured ? Either way, your routes are advertised but not received. We need to see the config of the peer router, as that is where the problem is likely located...

My router is receiving updates from layer 3 switch but only sending connected subnets and not any subnets from routing table. 

 

Gig0/1 is the port connected to layer 3 3850 switch

G0/2 is coneected to a MPLS PE router.

 

pbserv-uschi300-re01#sh ip bgp nei 10.0.79.70 adv
BGP table version is 1898, local router ID is 172.16.159.17
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  10.0.79.64/28    0.0.0.0                  0         32768 i
 *>  172.16.159.17/32 0.0.0.0                  0         32768 i

 

For example the update comes from the PE router but not readvertised to the connected layer 3 switch.

pbserv-uschi300-re01#sh ip route 10.0.24.0
Routing entry for 10.0.24.0/24
  Known via "bgp 64600", distance 20, metric 0
  Tag 65000, type external
  Last update from 152.176.112.225 02:04:58 ago
  Routing Descriptor Blocks:
  * 152.176.112.225, from 152.176.112.225, 02:04:58 ago
      Route metric is 0, traffic share count is 1
      AS Hops 2
      Route tag 65000
      MPLS label: none

 

 

 

Hello,

 

post the full configs of both peers and your PE router. 

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

--> Route map for outgoing advertisements is LOCAL-OUT-PRIMARY

 

Where is this route map applied, and what does it specify ?

jmperlewitz
Beginner
Beginner

Can you do a "sh ip bgp 10.0.10.0/24" and paste the results?  I wonder if the routes being received from 152.176.112.225 has the "no-export" community tagged.

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
Can you post the following:

sh ip bgp neighbors 10.0.79.70  advertised-routes | b N

Also request your bgp peer to post the output of
sh ip bgp neighbors 10.0.79.x  received-routes | b N

This wll confirm if the prefixes are being sent from your router and if they are being received but filtered or not.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Found the problem.  Route map inbound from PE had this:

 set community no-export additive

 

This command was telling BGP not to forward these subnets out another EBG process.

Removed no-export additive and works find.

 

Thanks all.

sivam siva
Participant
Participant

Hi

" route-map PIP-IN-PRIMARY in"  Check this inbound route-map  whether the "no-export " community  command executed or not against the inbound traffic , may be that could be a reason .

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: