cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
304
Views
5
Helpful
5
Replies

BGp not advertising on Peering routers

hfakoor222
Spotlight
Spotlight

I know it is redundant, I've rewritten the commands over and over so it is something I am missing, and I do not understand why BGP isn't advertising prefixes on these 2 Px  routers 

 

I used a static route for connectivity between the 2

 

 

2.png

 

2.png

 

3.png

 

 

 

P4  Router

 

P4#sh run
Building configuration...

Current configuration : 3803 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec localtime show-timezone year
service timestamps log datetime msec localtime show-timezone year
service password-encryption
!
hostname P4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
aaa new-model
!
!
!
!
aaa session-id common
no ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip domain name ws.nsrc.org
ipv6 unicast-routing
no ipv6 source-route
ipv6 cef
!
multilink bundle-name authenticated
!
!
key chain as40-key
key 1
key-string 7 130C0402070D06
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
ip tcp path-mtu-discovery
!
!
!
!
interface Loopback0
description Loopback on Border
ip address 100.68.4.3 255.255.255.255
ipv6 address 2001:DB8:4::3/128
!
interface Null0
no ip unreachables
no ipv6 unreachables
!
interface FastEthernet0/0
ip address 100.68.4.17 255.255.255.254
no ip redirects
no ip proxy-arp
duplex half
ipv6 address 2001:DB8:4:15::/127
ipv6 nd prefix default no-advertise
!
interface FastEthernet1/0
description BackBone link to Central
ip address 100.68.4.19 255.255.255.254
no ip redirects
no ip proxy-arp
ip router isis as40
duplex auto
speed auto
ipv6 address 2001:DB8:4:11::1/127
ipv6 nd prefix default no-advertise
ipv6 nd ra suppress
ipv6 router isis as40
isis network point-to-point
isis metric 2
isis ipv6 metric 2
!
interface FastEthernet1/1
description Link to AS 50 Peering Router
no ip address
no ip redirects
no ip proxy-arp
duplex auto
speed auto
ipv6 nd ra suppress
!
router isis as40
net 49.0001.0004.0003.00
is-type level-2-only
authentication mode md5 level-2
authentication key-chain as40-key level-2
metric-style wide
set-overload-bit on-startup wait-for-bgp
log-adjacency-changes all
metric 100000
passive-interface Loopback0
!
address-family ipv6
multi-topology
set-overload-bit on-startup wait-for-bgp
metric 100000
exit-address-family
!
router bgp 40
bgp log-neighbor-changes
bgp deterministic-med
neighbor ibgp-rr peer-group
neighbor ibgp-rr remote-as 40
neighbor ibgp-rr update-source Loopback0
neighbor ibgpv6-rr peer-group
neighbor ibgpv6-rr remote-as 40
neighbor ibgpv6-rr update-source Loopback0
neighbor 2001:DB8:4::2 peer-group ibgpv6-rr
neighbor 2001:DB8:5:15:: remote-as 50
neighbor 2001:DB8:5:15:: description eBGP with AS50
neighbor 100.68.4.2 remote-as 40
neighbor 100.68.4.2 peer-group ibgp-rr
neighbor 100.68.4.2 description iBGP with Core
neighbor 100.68.5.17 remote-as 50
neighbor 100.68.5.17 description eBGP with AS50
!
address-family ipv4
neighbor ibgp-rr send-community
neighbor ibgp-rr next-hop-self
neighbor 2001:DB8:4::2 activate
no neighbor 2001:DB8:5:15:: activate
neighbor 100.68.4.2 activate
neighbor 100.68.5.17 activate
distance bgp 200 200 200
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor ibgpv6-rr send-community
neighbor ibgpv6-rr next-hop-self
neighbor 2001:DB8:4::2 activate
neighbor 2001:DB8:5:15:: activate
neighbor 2001:DB8:5:15:: prefix-list AS50-v6block in
neighbor 2001:DB8:5:15:: prefix-list AS50-v6block out
distance bgp 200 200 200
exit-address-family
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Null0
ip route 100.68.5.17 255.255.255.255 FastEthernet0/0
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
ipv6 route ::/0 Null0
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
transport preferred none
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
transport preferred none
stopbits 1
line vty 0 4
transport preferred none
!
end

 

 

 

 

 

 

 

 

P5   Router 
P5#
P5#
P5#sh ip bgp summary
BGP router identifier 100.68.5.3, local AS number 50
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
100.68.4.17 4 40 0 0 0 0 0 never Idle
P5#
P5#
P5#sh run
Building configuration...

Current configuration : 2877 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
key chain as50-key
key 1
key-string isplab
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
description Loopback int
ip address 100.68.5.3 255.255.255.255
ipv6 address 2001:DB8:5::3/128
!
interface Null0
no ip unreachables
no ipv6 unreachables
!
interface FastEthernet0/0
description Link to Group Y Peering Router
ip address 100.68.5.17 255.255.255.254
no ip redirects
no ip proxy-arp
duplex half
ipv6 address 2001:DB8:5:15::/127
ipv6 nd prefix default no-advertise
!
interface FastEthernet1/0
description Link to Central Router
ip address 100.68.5.19 255.255.255.254
no ip redirects
no ip proxy-arp
ip router isis as50
duplex auto
speed auto
ipv6 address 2001:DB8:5:11::1/127
ipv6 nd prefix default no-advertise
ipv6 nd ra suppress
ipv6 router isis as50
isis network point-to-point
isis metric 2
isis ipv6 metric 2
!
interface FastEthernet1/1
description Link to AS 50 Peering Router
no ip address
no ip redirects
no ip proxy-arp
duplex auto
speed auto
ipv6 nd ra suppress
!
router isis as50
net 49.0001.0005.0003.00
is-type level-2-only
metric-style wide
set-overload-bit on-startup wait-for-bgp
log-adjacency-changes all
metric 100000
passive-interface Loopback0
!
router bgp 50
bgp log-neighbor-changes
neighbor 2001:DB8:4:15:: remote-as 40
neighbor 2001:DB8:4:15:: description eBGP with ASY0
neighbor 100.68.4.17 remote-as 40
neighbor 100.68.4.17 description eBGP with ASY0
!
address-family ipv4
no neighbor 2001:DB8:4:15:: activate
neighbor 100.68.4.17 activate
neighbor 100.68.4.17 prefix-list AS50-block out
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 2001:DB8:4:15:: activate
neighbor 2001:DB8:4:15:: prefix-list AS50-v6block out
exit-address-family
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Null0
ip route 100.68.4.17 255.255.255.255 FastEthernet0/0
no ip http server
no ip http secure-server
!
!
!
!
ip prefix-list AS50-block seq 5 permit 100.68.5.0/25
ip prefix-list AS50-block seq 10 permit 100.68.5.0/24
no cdp log mismatch duplex
ipv6 route ::/0 Null0
!
!
ipv6 prefix-list AS50-v6block seq 5 permit 2001:DB8:5::/48
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end

 

5 Replies 5

Hi

 We have some bgp problem here as they are in iddle.

 

Can you try without this prefix-list applied?

 

neighbor 100.68.4.17 prefix-list AS50-block out

 

As you have static routes, they should reach each other and form eBGP peering.

I took that out a while ago I might just keep playing with it

Enable bgp debug. Might see something. 

ip route 100.68.4.17 255.255.255.255 FastEthernet0/0<<- this Fastethernt is connect to other Peer BUT other peer using different subnet  100.68.5.17!!

The ip routes seem ok it is something else I am not doing correctly, but it is okay I am moving on in the lab at this point to exchange points so i will get more practice doing that.

Review Cisco Networking products for a $25 gift card