cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
1414
Views
10
Helpful
8
Replies

BGP problem

i can't ping from r1 to r6 or vice versa although this routes exist in the routing tables Screenshot (20).pngScreenshot (21).pngScreenshot (22).pngScreenshot (23).pngScreenshot (24).pngScreenshot (25).pngScreenshot (26).pngScreenshot (27).pngScreenshot (28).png

create pingable AS1
----------------------
conf t
hostname R1 
int s2/0 
no sh 
ip add 10.0.0.1 255.255.255.252
int s 2/1 
no sh 
ip add 10.0.0.5 255.255.255.252
int lo 0  
ip add 1.1.1.1 255.255.255.255
router ospf 1 
net 10.0.0.0 0.0.0.255 ar 0
net 1.1.1.1 0.0.0.0 ar 0
........................................................
conf t
hostname R2 
int s2/0 
no sh 
ip add 10.0.0.2 255.255.255.252
int s 2/1 
no sh 
ip add 12.0.0.1 255.255.255.252
int lo 0  
ip add 2.2.2.2 255.255.255.255
router ospf 1 
net 10.0.0.0 0.0.0.255 ar 0
net 2.2.2.2 0.0.0.0 ar 0
........................................................
conf t
hostname R3 
int s2/0 
no sh 
ip add 10.0.0.6 255.255.255.252
int s 2/1 
no sh 
ip add 12.0.0.5 255.255.255.252
int lo 0  
ip add 3.3.3.3 255.255.255.255
router ospf 1 
net 10.0.0.0 0.0.0.255 ar 0
net 3.3.3.3 0.0.0.0 ar 0
.......................................................
.......................................................
.......................................................
create pingable AS1
----------------------
conf t
hostname R4 
int s2/0 
no sh 
ip add 12.0.0.2 255.255.255.252
int s 2/1 
no sh 
ip add 11.0.0.1 255.255.255.252
int lo 0  
ip add 4.4.4.4 255.255.255.255
router ospf 1 
net 11.0.0.0 0.0.0.255 ar 0
net 4.4.4.4 0.0.0.0 ar 0
........................................................
conf t
hostname R5 
int s2/0 
no sh 
ip add 12.0.0.6 255.255.255.252
int s 2/1 
no sh 
ip add 11.0.0.5 255.255.255.252
int lo 0  
ip add 5.5.5.5 255.255.255.255
router ospf 1 
net 11.0.0.0 0.0.0.255 ar 0
net 5.5.5.5 0.0.0.0 ar 0
........................................................
conf t
hostname R6 
int s2/0 
no sh 
ip add 11.0.0.2 255.255.255.252
int s 2/1 
no sh 
ip add 11.0.0.6 255.255.255.252
int lo 0  
ip add 6.6.6.6 255.255.255.255
router ospf 1 
net 11.0.0.0 0.0.0.255 ar 0
net 6.6.6.6 0.0.0.0 ar 0
....................................................
clear ip ospf process 
y
......................................................
BGP configuration
----------------------
R1
---
router bgp 1
neighbor 2.2.2.2 remote-as 1 
neighbor 2.2.2.2 update-source lo 0 
neighbor 2.2.2.2 password cisco 
neighbor 3.3.3.3 remote-as 1 
neighbor 3.3.3.3 update-source lo 0 
neighbor 3.3.3.3 password cisco 
network 1.1.1.1 mask 255.255.255.255
-----------
R2
---
router bgp 1
neighbor 1.1.1.1 remote-as 1 
neighbor 1.1.1.1 update-source lo 0 
neighbor 1.1.1.1 password cisco 
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 1 
neighbor 3.3.3.3 update-source lo 0 
neighbor 3.3.3.3 password cisco 
neighbor 4.4.4.4 remote-as 2
neighbor 4.4.4.4 update-source lo 0 
neighbor 4.4.4.4 password cisco
neighbor 4.4.4.4 ebgp-multihop
ip route 4.4.4.4 255.255.255.255 12.0.0.2
-----------
R3
---
router bgp 1
neighbor 1.1.1.1 remote-as 1 
neighbor 1.1.1.1 update-source lo 0 
neighbor 1.1.1.1 password cisco 
neighbor 1.1.1.1 next-hop-self
neighbor 2.2.2.2 remote-as 1 
neighbor 2.2.2.2 update-source lo 0 
neighbor 2.2.2.2 password cisco 
neighbor 5.5.5.5 remote-as 2
neighbor 5.5.5.5 update-source lo 0 
neighbor 5.5.5.5 password cisco 
neighbor 5.5.5.5 ebgp-multihop
ip route 5.5.5.5 255.255.255.255 12.0.0.6

R4
---
router bgp 2
neighbor 6.6.6.6 remote-as 2 
neighbor 6.6.6.6 update-source lo 0 
neighbor 6.6.6.6 password cisco 
neighbor 6.6.6.6 next-hop-self
neighbor 5.5.5.5 remote-as 2
neighbor 5.5.5.5 update-source lo 0 
neighbor 5.5.5.5 password cisco 
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source lo 0 
neighbor 2.2.2.2 password cisco 
neighbor 2.2.2.2 ebgp-multihop
ip route 2.2.2.2 255.255.255.255 12.0.0.1

R5
---
router bgp 2
neighbor 6.6.6.6 remote-as 2 
neighbor 6.6.6.6 update-source lo 0 
neighbor 6.6.6.6 password cisco 
neighbor 6.6.6.6 next-hop-self
neighbor 4.4.4.4 remote-as 2
neighbor 4.4.4.4 update-source lo 0 
neighbor 4.4.4.4 password cisco 
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 update-source lo 0 
neighbor 3.3.3.3 password cisco 
neighbor 3.3.3.3 ebgp-multihop
ip route 3.3.3.3 255.255.255.255 12.0.0.5

R6
---
router bgp 2
neighbor 5.5.5.5 remote-as 2 
neighbor 5.5.5.5 update-source lo 0 
neighbor 5.5.5.5 password cisco 
neighbor 4.4.4.4 remote-as 2
neighbor 4.4.4.4 update-source lo 0 
neighbor 4.4.4.4 password cisco 
net 6.6.6.6 mask 255.255.255.255
------------------------------------

router bgp 
maximum-paths 2 
maximum-paths ibgp 2 

 

1 Accepted Solution

Accepted Solutions

Martin L
VIP
VIP

 

One of issues when pinging BGP is all networks (routes) along the patch must be advertised.  Solution is to do extended ping, ping 6.6.6.6 source 1.1.1.1

Another one is when peering BGP with loopbacks instead of directly connected routes, those loopbacks are not advertised.  Sort of "back hole" is created and traffic gets stuck.  Using Loopacks when Peering BGP is common inside organization (iBGP and ISPs) but outside of that I think we use directly connected links (eBGP). 

 

Regards, ML
**Please Rate All Helpful Responses **

View solution in original post

8 Replies 8

e.ciollaro
Level 4
Level 4

Hi

please post a sh ip route  and sh ip bgp for each router.

 

Bye

Enrico

thanks for your interest and your time 
R1.pngR2.pngR3.pngR4.pngR5.pngR6.png

Hi

the problem is due to the fact that you are using the Loopback as update source interface but their IP is not in the routing table. For example R4 opath to R1 has next-hop 2.2.2.2, but 2.2.2. is not in it's routing table. Use the connected interface over the eBGP session and I guss it will work

 

Bye

enrico

 

PS Rate if useful

 

Or redistribute connected in BGP maybe another solution to avoid this "back hole", right?

 

Regards, ML
**Please Rate All Helpful Responses **

R4 has 2.2.2.2 in its routing table

Martin L
VIP
VIP

 

One of issues when pinging BGP is all networks (routes) along the patch must be advertised.  Solution is to do extended ping, ping 6.6.6.6 source 1.1.1.1

Another one is when peering BGP with loopbacks instead of directly connected routes, those loopbacks are not advertised.  Sort of "back hole" is created and traffic gets stuck.  Using Loopacks when Peering BGP is common inside organization (iBGP and ISPs) but outside of that I think we use directly connected links (eBGP). 

 

Regards, ML
**Please Rate All Helpful Responses **

thanks when trying extended ping , i found it works
i guess i understood the problem
when using normal ping to the external destionation it uses the physical interface as a source ip but the another AS routers does not have any information about this ip ,they know only about the loopback interface so the ping reply doesn't come back ,it will be droped from the another AS routers because they don't know the destination to reply to it ,great thanks alot

for your second tip, iam already using loopback static advertising in ebgp, SPs uses loopback peering between ASs because it is common to use dual conection between the ASBRs
Review Cisco Networking products for a $25 gift card