cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10475
Views
5
Helpful
10
Replies

BGP route advertised but unable to ping

Ashwani Pande
Level 1
Level 1

Hi Everyone,

 

Can someone correct me on a BGP issue. It's not a real time environment. There are two customer's running BGP and in different AS. One location is using RIP and other is EIGRP. Peering between two routers using loopback IP addresses and static route is defined for them. BGP is showing "EST". When I am advertising one network which I have in my routing table to customer (B) using network and subnet command I can see that network on the otherside available but when I tried to ping from there I am unable to ping it? Why?

 

I know nexthop should be reachable but here BGP is running only on two routers and I am trying to ping from the router where I can see that advertised route. Any suggestions? No auto-summary is configured.

2 Accepted Solutions

Accepted Solutions

Hello,

 

you need to do at a minimum the below redistribution into RIP:

 

router rip
version 2
network 5.0.0.0
network 20.0.0.0

redistribute connected
no auto-summary

View solution in original post

Hi,

 

 

Basically the next-hop (20.1.1.1) towards the final destination was not present in the RIB on Router A.

So by redistributing connected on Router B advertised the next-hop interface in RIP.

 

HTH.

 

Regards,

 

Terence 

View solution in original post

10 Replies 10

Hello,

 

post the configs of both routers...

RouterB#

 

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 20.1.1.2 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 122.1.1.1 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 5.0.0.0
network 20.0.0.0
no auto-summary
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 10.1.1.0 mask 255.255.255.252
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 1.1.1.1 255.255.255.255 122.1.1.2

=================================================

RouterA#

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 122.1.1.2 255.255.255.252
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
router eigrp 1
network 192.168.1.0 0.0.0.3
no auto-summary
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 5.5.5.5 remote-as 200
neighbor 5.5.5.5 ebgp-multihop 2
neighbor 5.5.5.5 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 5.5.5.5 255.255.255.255 122.1.1.1

 

===============================================================

 

RouterA#

#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 192.168.1.2, 00:46:21, Serial0/0
168.1.0.0/30 is subnetted, 1 subnets
D 168.1.1.0 [90/3193856] via 192.168.1.2, 00:46:20, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2809856] via 192.168.1.2, 00:46:20, Serial0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/3321856] via 192.168.1.2, 00:46:20, Serial0/0
5.0.0.0/32 is subnetted, 1 subnets
S 5.5.5.5 [1/0] via 122.1.1.1
172.32.0.0/30 is subnetted, 1 subnets
D 172.32.1.0 [90/2681856] via 192.168.1.2, 00:46:23, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
B 10.1.1.0 [20/1] via 5.5.5.5, 00:45:26
122.0.0.0/30 is subnetted, 1 subnets
C 122.1.1.0 is directly connected, Serial0/1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0
#

 

RouterB advertising 10.0.0.0/30 to Router A and we can see above it is in the routing table.

Hello,

 

where is 10.1.10/30 configured ? It needs to be visible with 'show ip route' on Router B.

 

router bgp 200
no synchronization
bgp log-neighbor-changes
network 10.1.1.0 mask 255.255.255.252
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
no auto-summary

The below is a working sample config of network 10.10.10.10 being reachable from R1. For that to happen, it actually needs to exist on R2

 

R1

 

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.12.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 1
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 255
neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 192.168.12.2

 

R2

 

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
ip address 10.10.10.10 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.12.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router rip
version 2
network 10.0.0.0
!
router bgp 2
bgp router-id 2.2.2.2
bgp log-neighbor-changes
network 10.10.10.10 mask 255.255.255.255
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 255
neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 192.168.12.1

The only difference I can see here is in your topology network 10.10.10.10 is locally configured as well however in my case it is learned via IGP.  I believe both  conditions should be okay to advertise route until you can ping it and route exist.

Okay when I created another loopback 100.100.100.100/32 and first advertised it through RIP and then advertised to peer BGP I am able to ping it from there.

 

Now my question is why I am unable to ping the other advertised route? the only difference is 100.100.100.100/32 I have created it locally and 10.1.1.0/30 I have got through IGP.

Hi,

 

thanks for your help.

 

yes it is visible in the routing table and I am able to ping it from RouterB. Below is the output of sh ip route.

 

sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
S 1.1.1.1 [1/0] via 122.1.1.2
20.0.0.0/30 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Serial0/0
5.0.0.0/32 is subnetted, 1 subnets
C 5.5.5.5 is directly connected, Loopback0
7.0.0.0/32 is subnetted, 1 subnets
R 7.7.7.7 [120/2] via 20.1.1.1, 00:00:08, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
R 10.1.1.0 [120/1] via 20.1.1.1, 00:00:08, Serial0/0
122.0.0.0/30 is subnetted, 1 subnets
C 122.1.1.0 is directly connected, Serial0/1

 

It is learned via IGP(RIP.)

 

ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/16 ms

Hello,

 

you need to do at a minimum the below redistribution into RIP:

 

router rip
version 2
network 5.0.0.0
network 20.0.0.0

redistribute connected
no auto-summary

Okay yes. that worked and now able that ping  that 10/30 network as well however I would like to know what is the logic behind this as what I have heard that you can advertise any network that you have in your routing table and should be reachable via any IGP and these two conditions i have met here.

Hi,

 

 

Basically the next-hop (20.1.1.1) towards the final destination was not present in the RIB on Router A.

So by redistributing connected on Router B advertised the next-hop interface in RIP.

 

HTH.

 

Regards,

 

Terence 

Review Cisco Networking products for a $25 gift card