04-03-2006 06:26 AM - edited 03-03-2019 12:17 PM
Hi
we are going to be peering with an ISP, and they want us to take the Full BGP internet routing table,
I am going to be using two Cat6500 for this that also server other puroposes in routing in my private networks,
what is the best way to keep the bgp routes seperate from my own routes, f.e. should I run VRF lite to and put all my routes into an VRF and then have the internet routing table as the global table,
or what is generaly done in situationes like this ?
Regards
Arni
04-03-2006 08:36 AM
You can do the vrf-lite but then you would need to have a connection between Internet and your internal network.
If not using vrf-lite, you can use route-leaked vrf: point your vrf default route to global table.
You can also keep your internal routes in the same global table and have filters to limit what you advertise/receive.
Hope this helps.
04-03-2006 08:39 AM
Hello,
in principle it would be enough NOT to configure redistribution between BGP and IGP (which is never the best idea). IP routing protocols are like "ships in the night" - they don´t see each otherunless you configure redistribution.
In addition I would apply the proper inbound and outbound filters to be sure an ISP failure/error will not get you in trouble. An example configuration could look like this:
interface Ethernet0/1
description to ISP
ip address 1.4.5.2 255.255.255.252
router bgp 65000
network 1.1.0.0 mask 255.255.0.0
neighbor 1.4.5.1 remote-as 1 !replace with ISP AS
neighbor 1.4.5.1 prefix-list NoTrash in
neighbor 1.4.5.1 filter-list 1 out
neighbor 1.4.5.1 maximum-prefix 300000
no auto-summary
ip as-path access-list 1 permit ^$
ip prefix-list NoTrash deny 192.168.0.0/16 le 32
ip prefix-list NoTrash deny 172.16.0.0/12 le 32
ip prefix-list NoTrash deny 10.0.0.0/8 le 32
ip prefix-list NoTrash deny 1.1.0.0/16 le 32
ip prefix-list NoTrash permit 0.0.0.0/0 le 24
ip route 1.1.0.0 255.255.0.0 Null 0 250
This assumes you want to announce 1.1.0.0/16 to the ISP as your official IP addresses. You need of course to adjust interfaces, IP addresses ans AS numbers.
Hope this helps! PLease rate all posts.
Regards, Martin
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide