cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
389
Views
0
Helpful
1
Replies
Beginner

Bridged connection - no DHCP or UDP traffic

We have a small remote location a block away from our main building connected via bridged T1.  Here's the flow:

Main Building >> 2801 >> T1 << 2801 << Remote Building

This is currently operating as a bridged connection between the two locations.  We are having a problem with DHCP requests not working at the Remote Building as well as specific UDP(port 7700) traffic.  I tried working with ip-forward protocol commands but that didn't appear to help.

Is there any solution available to help in this situation - allow DHCP traffic and UDP traffic to flow between locations?

Here's the Remote Building config:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Remote

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip routing

no ip cef

!

!

interface FastEthernet0/0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

!

interface FastEthernet0/1

ip address 10.8.12.213 255.255.255.0

no ip route-cache

duplex auto

speed auto

!

interface Serial0/1/0

no ip address

encapsulation ppp

no ip route-cache

service-module t1 timeslots 1-24

bridge-group 1

!

ip classless

ip forward-protocol spanning-tree

ip forward-protocol turbo-flood

ip forward-protocol udp 7700

!

!

ip http server

no ip http secure-server

!

!

control-plane

!

bridge 1 protocol ieee

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login

!

end

Here's the Main Building 2801 config:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Main

!

boot-start-marker

boot-end-marker

!

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

no ip routing

no ip cef

!

!

no ftp-server write-enable

!

!

interface FastEthernet0/0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

!

interface FastEthernet0/1

ip address 10.8.12.214 255.255.255.0

no ip route-cache

duplex auto

speed auto

!

interface Serial0/1/0

no ip address

encapsulation ppp

no ip route-cache

service-module t1 clock source internal

service-module t1 timeslots 1-24

bridge-group 1

!

ip classless

ip forward-protocol spanning-tree

ip forward-protocol turbo-flood

ip forward-protocol udp 7700

ip http server

!

!

dialer-list 1 protocol ip permit

!

control-plane

!

bridge 1 protocol ieee

!

line con 0

line aux 0

line vty 0 4

login

!

end

Everyone's tags (5)
1 REPLY 1
Highlighted
Hall of Fame Master

Bridged connection - no DHCP or UDP traffic

Nick

The ip forward-protocol is used only with IP forwarding of traffic. And since you have configured no ip routing on both routers the ip forward-protocol statements you have configured are not doing any good and just complicate the configuration. I suggest that you remove them to clean up the config.

Is there a reason why you have not configured bridge-group 1 on the Ethernet interfaces that are configured with IP addresses? I suggest that you put bridge-group on these interfaces.

What is providing DHCP and how is it connected?

HTH

Rick

HTH

Rick
CreatePlease to create content