cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
511
Views
0
Helpful
11
Replies
Highlighted
Participant

c892 vlan interface cannot ping from PC

Dear All,

I am using cisco 800 series.i create int vlan in router and connect to switch with trunk port. i connect switch and create trunk port and allow all.and i create access port and create vlan.i plug my pc to switch and i ping to my gatwe vlan interface.

I cannot ping my PC  10.100.201.2 to VLAN interface 10.100.201.1.

my pc (10.100.201.2 255.255.255.0 10.100.201.1)---->switch --->trunk--->router

Router#sh run
Building configuration...

Current configuration : 3414 bytes
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
ip auth-proxy max-login-attempts 6
ip admission max-login-attempts 6

ip cef
no ipv6 cef

multilink bundle-name authenticated
!
license udi pid C892FSP-K9 sn FGL22369110

interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
switchport trunk allowed vlan 1,2,200-203,1001-1005
switchport mode trunk
no ip address
!
interface GigabitEthernet8
no ip address
duplex auto
speed auto
!
interface GigabitEthernet9
ip address 10.1.14.80 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan201
ip address 10.100.201.1 255.255.255.0
!
interface Vlan202
ip address 10.100.202.65 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 10.1.14.1
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh logging events
ip ssh version 2
!
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!

line con 0
no modem enable
line aux 0
line vty 0 4
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

11 REPLIES 11
Highlighted
VIP Expert

Hello,

 

post the output of 'sh vlan' from the router. Also, post the config of the switch...

Highlighted

Have you configured the Vlan on the 892 ?

 

Router(config)#vlan 201

 

?

Highlighted
Rising star

Hi, If I correctly understood

you can ping the IP 10.100.201.1 (int vlan 201) from your PC

but you cannot ping your PC 10.100.201.2 from the router?

 

Can you try to specify the IP source of the ping int the router?

Do you have a software firewall on your PC?

 

Regards.

Highlighted
VIP Mentor

Hello

Makes sure  the vlans are created on the switch and the access ports are assigned to either vlan 201 or 202 vlans

 

con t

vlan 200 -203

exit

 

int x/x
description access port to pc
switchport host
switchport access vlan 201




kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Hi,

i cannot ping PC to router and i cannot ping router to PC also 

Sh ip interface is already in below vlan interface down because i unplug cable when i goback home and now remote from my home. Please see switch configuration .

Router# sh ip int bri
Interface IP-Address OK? Method Status Prot ocol

Vlan1 unassigned YES unset down down
Vlan201 10.100.201.1 YES NVRAM down down
Vlan202 10.100.202.65 YES NVRAM down down

 

SW#sh run
Building configuration...

Current configuration : 6393 bytes
!
! Last configuration change at 00:06:45 UTC Mon Mar 1 1993
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service unsupported-transceiver
!
hostname SW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3821327872
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3821327872
revocation-check none
rsakeypair TP-self-signed-3821327872
!
!
crypto pki certificate chain TP-self-signed-3821327872
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33383231 33323738 3732301E 170D3933 30333031 30303031
30375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38323133
32373837 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100BEAC CAA0A3E7 1D5457B1 DBB5FA50 F8FF53AD 81B39409 65E664A6 5DAE3608
183B59AF B34B093D 3A4D676D 14FBA214 D4671F2C 2C7FC4E0 6939341A 54001E6B
2DD538C4 A7278901 229AEE1E 2EBBC392 73C13A97 CE01BD1A 5D888294 4408C323
20C39393 0D4DD3C8 1116F593 79F13D25 0BA8D300 BB3B042A 24DF7BB1 16D3A19F
12E50203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14941DC0 59B449AA F5DB4D19 947FAA29 99CEACEA DA301D06
03551D0E 04160414 941DC059 B449AAF5 DB4D1994 7FAA2999 CEACEADA 300D0609
2A864886 F70D0101 05050003 81810033 60EA689E 48E91284 395DC10F 46D28FDB
8A4C8646 8125F625 68F3EEA3 AFBB7097 3CC6B129 2E28A124 45A25D0B F15CD25A
CE5F5ACA FE5F2F2E EEAA7C5B B956C759 82F5C7DD 10B0C9C1 70C64B1B C7CA16E7
9AA28BCC DEB4993E BDA5341F 11509448 995E8560 AFC01B71 48825B38 DF505F4A
7B0FCD13 69142DC6 608D7835 E36D57
quit
no errdisable detect cause gbic-invalid
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
interface FastEthernet0/1
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 201
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 202
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 202
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 202
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 202
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 202
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 202
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 203
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 203
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 203
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 203
switchport mode access
!
interface GigabitEthernet0/1
switchport trunk allowed vlan 1,200-204,1005,2002
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk allowed vlan 1,200-204,1005,2002
switchport mode trunk
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
ip http server
ip http secure-server
!
no vstack

!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end

SW#sh vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2
200 Management active Fa0/19, Fa0/20
201 IT active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
202 admin active Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18
203 User active Fa0/21, Fa0/22, Fa0/23, Fa0/24
204 guest active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
200 enet 100200 1500 - - - - - 0 0
201 enet 100201 1500 - - - - - 0 0
202 enet 100202 1500 - - - - - 0 0
203 enet 100203 1500 - - - - - 0 0
204 enet 100204 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0

Highlighted

You need to manually create the VLANs on the router as well. What is the output of:

 

Router# vlan database

Router(vlan)# show

Highlighted

HI,
Router#vlan database
% Warning: It is recommended to configure VLAN from config mode,
as VLAN database mode is being deprecated. Please consult user
documentation for configuring VTP/VLAN in config mode.

Router(vlan)#show
VLAN ISL Id: 1
Name: default
Media Type: Ethernet
VLAN 802.10 Id: 100001
State: Operational
MTU: 1500
Translational Bridged VLAN: 1002
Translational Bridged VLAN: 1003

VLAN ISL Id: 200
Name: Management
Media Type: Ethernet
VLAN 802.10 Id: 100200
State: Operational
MTU: 1500

VLAN ISL Id: 201
Name: IT
Media Type: Ethernet
VLAN 802.10 Id: 100201
State: Operational
MTU: 1500

VLAN ISL Id: 202
Name: admin
Media Type: Ethernet
VLAN 802.10 Id: 100202
State: Operational
MTU: 1500

VLAN ISL Id: 203
Name: user
Media Type: Ethernet
VLAN 802.10 Id: 100203
State: Operational
MTU: 1500

VLAN ISL Id: 204
Name: guest
Media Type: Ethernet
VLAN 802.10 Id: 100204
State: Operational
MTU: 1500
VLAN ISL Id: 1002
Name: fddi-default
Media Type: FDDI
VLAN 802.10 Id: 101002
State: Operational
MTU: 1500
Bridge Type: SRB
Translational Bridged VLAN: 1
Translational Bridged VLAN: 1003

VLAN ISL Id: 1003
Name: token-ring-default
Media Type: Token Ring
VLAN 802.10 Id: 101003
State: Operational
MTU: 1500
Bridge Type: SRB
Ring Number: 0
Bridge Number: 1
Parent VLAN: 1005
Maximum ARE Hop Count: 7
Maximum STE Hop Count: 7
Backup CRF Mode: Disabled
Translational Bridged VLAN: 1
Translational Bridged VLAN: 1002

VLAN ISL Id: 1004
Name: fddinet-default
Media Type: FDDI Net
VLAN 802.10 Id: 101004
State: Operational
MTU: 1500
Bridge Type: SRB
Bridge Number: 1
STP Type: IBM

VLAN ISL Id: 1005
Name: trnet-default
Media Type: Token Ring Net
VLAN 802.10 Id: 101005
State: Operational
MTU: 1500
Bridge Type: SRB
Bridge Number: 1
STP Type: IBM

Router(vlan)#
Highlighted

Hello,

 

your running config doesn't show the VLANs, not sure why that is. It should show lines like below:

 

vlan 200
name Management
!
vlan 201
name IT

Highlighted

You can also try router on a stick:

 

interface GigabitEthernet7
no ip address
!
interface GigabitEthernet7.201
encapsulation dot1q 201
ip address 10.100.201.1 255.255.255.0
!
interface GigabitEthernet7.202
encapsulation dot1q 202
ip address 10.100.202.1 255.255.255.0

Highlighted

Hi,
Before testing,If I will use lease line network,which scenario is more
effective (1.router on the stick and 2. trunk network)
I thought trunk with vlan interface is less delay ? Or router on a stick is
more effencient?
Highlighted

Do you have created vlan on the router?

 

conf t

vlan 201

 

check with command show vlan-switch

 

Can you post also show spanning-tree summary from switch and router?

 

Regards.