cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
289
Views
0
Helpful
4
Replies
Support ACME
Beginner

C93180YC-FX vpc setting

Dear ALL,

 

I 'm the newbie in Nexus switch, i have 2 x C93180YC-FX for core switch, i had completed the VPC setting, now the switch are still running on independ mode, how to set it up to be one logical switch? It is because i have to run the BGP.

 

Support




switch 1

----------------------------------------------------------------------------------------------------------------------------------
# sh run

!Command: show running-config
!Running configuration last done at: Fri Apr 29 16:22:12 2022
!Time: Fri Apr 29 16:27:02 2022

version 9.3(2) Bios:version 05.43
hostname Active
vdc Active id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8

cfs eth distribute
feature bgp
feature port-security
feature udld
feature interface-vlan
feature lacp
feature dhcp
feature vpc
feature lldp

no password strength-check
username admin password 5 $5$m9MlJLZi$n.VUtREE0kvUwbxLePH12l6X/KPEfVCgXLdIqjSdFj
1 role network-admin
ip domain-lookup
copp profile strict
snmp-server user admin network-admin auth md5 0x5f7e26d8eccc3ec53bc3667a5a0982ad
priv 0x5f7e26d8eccc3ec53bc3667a5a0982ad localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO

vlan 1-2,1400
vlan 2
name keepalive

service dhcp
ip dhcp relay
ipv6 dhcp relay
vrf context keepalive
vrf context management
vpc domain 1
role priority 100
peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf keepalive
delay restore 150


interface Vlan1

interface port-channel1
switchport
switchport access vlan 1400
speed 1000

interface port-channel100
description *** VPC PEER LINKS ***
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface Ethernet1/1
description *** VPC PEER LINKS ***
switchport
switchport mode trunk
channel-group 100 mode active
no shutdown

interface Ethernet1/2
description *** VPC PEER LINKS ***
switchport
switchport mode trunk
channel-group 100 mode active
no shutdown

interface Ethernet1/3
switchport
switchport access vlan 1400
speed 1000
channel-group 1 mode active
no shutdown

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29

interface Ethernet1/30

interface Ethernet1/31

interface Ethernet1/32

interface Ethernet1/33

interface Ethernet1/34

interface Ethernet1/35

interface Ethernet1/36

interface Ethernet1/37

interface Ethernet1/38

interface Ethernet1/39

interface Ethernet1/40

interface Ethernet1/41

interface Ethernet1/42

interface Ethernet1/43

interface Ethernet1/44

interface Ethernet1/45

interface Ethernet1/46

interface Ethernet1/47

interface Ethernet1/48
speed 10000
duplex full
vrf member keepalive
ip address 1.1.1.1/30
no shutdown

interface Ethernet1/49

interface Ethernet1/50

interface Ethernet1/51

interface Ethernet1/52

interface Ethernet1/53

interface Ethernet1/54

interface mgmt0
vrf member management
line console
line vty
boot nxos bootflash:/nxos.9.3.2.bin
router bgp 65532


Active# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : primary
Number of vPCs configured : 0
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 150s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po100 up 1-2,1400

----------------------------------------------------------------------------------------------------------------------------------

switch 2
----------------------------------------------------------------------------------------------------------------------------------
Standby# sh run

!Command: show running-config
!Running configuration last done at: Fri Apr 29 15:51:06 2022
!Time: Fri Apr 29 16:31:23 2022

version 9.3(2) Bios:version 05.43
hostname Standby
vdc Standby id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8

cfs eth distribute
feature bgp
feature pim
feature port-security
feature udld
feature interface-vlan
feature netflow
feature hsrp
feature lacp
feature dhcp
feature vpc
feature lldp

no password strength-check
username admin password 5 $5$aJmYTHB5$srIPBOrhIRpzBD5LCjqXAnTuvaZV6lxldGCmm5L8uZ
2 role network-admin
ip domain-lookup
copp profile strict
snmp-server user admin network-admin auth md5 0xbe686049cb8c117cac0653d6e0aab8c5
priv 0xbe686049cb8c117cac0653d6e0aab8c5 localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO

vlan 1-2,1400
vlan 2
name keepalive

service dhcp
ip dhcp relay
ipv6 dhcp relay
vrf context keepalive
vrf context management
vpc domain 1
role priority 150
peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf keepalive
delay restore 150


interface Vlan1

interface Vlan1400
ip address 10.194.0.2/24

interface port-channel1
switchport
switchport access vlan 1400
speed 1000
vpc 1

interface port-channel100
description *** VPC PEER LINKS ***
switchport
switchport mode trunk
spanning-tree port type network
vpc peer-link

interface Ethernet1/1
description *** VPC PEER LINKS ***
switchport
switchport mode trunk
channel-group 100 mode active
no shutdown

interface Ethernet1/2
description *** VPC PEER LINKS ***
switchport
switchport mode trunk
channel-group 100 mode active
no shutdown

interface Ethernet1/3
switchport
switchport access vlan 1400
speed 1000
channel-group 1 mode active
no shutdown

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29

interface Ethernet1/30

interface Ethernet1/31

interface Ethernet1/32

interface Ethernet1/33

interface Ethernet1/34

interface Ethernet1/35

interface Ethernet1/36

interface Ethernet1/37

interface Ethernet1/38

interface Ethernet1/39

interface Ethernet1/40

interface Ethernet1/41

interface Ethernet1/42

interface Ethernet1/43

interface Ethernet1/44

interface Ethernet1/45

interface Ethernet1/46

interface Ethernet1/47

interface Ethernet1/48
speed 10000
duplex full
vrf member keepalive
ip address 1.1.1.2/30
no shutdown

interface Ethernet1/49

interface Ethernet1/50

interface Ethernet1/51

interface Ethernet1/52

interface Ethernet1/53

interface Ethernet1/54

interface mgmt0
vrf member management
line console
line vty
boot nxos bootflash:/nxos.9.3.2.bin




Standby# show vpc
Legend:
(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id : 1
Peer status : peer adjacency formed ok
vPC keep-alive status : peer is alive
Configuration consistency status : success
Per-vlan consistency status : success
Type-2 consistency status : success
vPC role : secondary
Number of vPCs configured : 1
Peer Gateway : Disabled
Dual-active excluded VLANs : -
Graceful Consistency Check : Enabled
Auto-recovery status : Disabled
Delay-restore status : Timer is off.(timeout = 150s)
Delay-restore SVI status : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router : Disabled
Virtual-peerlink mode : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id Port Status Active vlans
-- ---- ------ -------------------------------------------------
1 Po100 up 1-2,1400


vPC status
----------------------------------------------------------------------------
Id Port Status Consistency Reason Active vlans
-- ------------ ------ ----------- ------ ---------------
1 Po1 down* failed Peer does not have -

corresponding vPC


Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

Standby#
2 ACCEPTED SOLUTIONS

Accepted Solutions
MHM Cisco World
Advisor

You must config VPC number under ether channel connect to third SW to make vPC work otherwise the vPC never work.

View solution in original post

4 REPLIES 4
MHM Cisco World
Advisor

first SW 

interface port-channel1
switchport
switchport access vlan 1400
speed 1000

vpc 1 <- missing 



second SW
interface port-channel1

switchport
switchport access vlan 1400
speed 1000
vpc 1


Support ACME
Beginner

Dear Sir,

 

Is it impossible like one logical switch to manage the switch?

 

Support 

MHM Cisco World
Advisor

You must config VPC number under ether channel connect to third SW to make vPC work otherwise the vPC never work.