cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5651
Views
0
Helpful
7
Replies
Beginner

Cannot access internet using 887va sec and plusnet (BT) VDSL service

Hi All,

Trying to get my 887va setup for VDSL but can't get to anything on the net -

Controller VDSL 0
vpdn enable
vpdn-group 1

interface ethernet0

no ip address

ip tcp adjust-mss 1452

shutdown

interface ethernet0.101

encapsulation dot1q 101

ip virtual-reassembly in

ip tcp adjust-mss 1452

pppoe enable group global

pppoe-client dial-pool number 1
exit

interface fa1

switchport access vlan 1

no ip address

interface fa2

switchport access vlan 1

no ip address

interface fa3

swithcport access vlan 1

no ip address

interface atm0

no ip address

shutdown

interface d0

no ip address

interface d1

description PlusNet Fibre

ip address negotiated

no ip unreachables

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname myusername

ppp chap password 0 route

ppp pap sent-username myusername password 0 route

ppp ipcp dns request

no cdp enable

interface vlan1

ip address 10.10.5.1 255.255.255.128

ip nat inside

ip virtual-reassembly in

ip nat inside source list 101 interface d1 overload

access-list 101 permit ip 10.10.5.0 0.0.0.127 any

ALTHOUGH i'm synching (at least, i think i am) -

sh controller vdsl 0

Controller VDSL 0 is UP

Daemon Status: Up

XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xA39D
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' ' '
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0x0000
Serial Number Near: FCZ1616C1LH 887VA-SE 15.2(1)T
Serial Number Far:
Modem Version Near: 15.2(1)T
Modem Version Far: 0xa39d

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.993.2 (VDSL2) Profile 17a
TC Mode: PTM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
SRA: disabled disabled
SRA count: 0 0
Bit swap: enabled enabled
Bit swap count: 160 115
Line Attenuation: 0.0 dB 0.0 dB
Signal Attenuation: 0.0 dB 0.0 dB
Noise Margin: 6.2 dB 6.0 dB
Attainable Rate: 49152 kbits/s 17794 kbits/s
Actual Power: 13.9 dBm 6.9 dBm
Per Band Status: D1 D2 D3 U0 U1 U2 U3
Line Attenuation(dB): 13.1 40.0 49.5 4.9 28.3 40.4 N/A
Signal Attenuation(dB): 13.1 40.0 49.5 4.9 27.5 39.4 N/A
Noise Margin(dB): 6.1 6.3 6.1 5.9 6.0 6.0 N/A
Total FECS: 0 5
Total ES: 11 0
Total SES: 2 0
Total LOSS: 0 0
Total UAS: 0 0
Total LPRS: 0 0
Total LOFS: 0 0
Total LOLS: 0 0

Full inits: 1
Failed full inits: 0
Short inits: 0
Failed short inits: 0

Firmware Source File Name (version)
-------- ------ -------------------
VDSL embedded VDSL_LINUX_DEV_01212008 (1)

Modem FW Version: 110331_1212-4.02L.03.A2pv6C032b.d23f
Modem PHY Version: A2pv6C032b.d23f


DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 48487 0 17779
SRA Previous Speed: 0 0 0 0
Previous Speed: 0 0 0 0
Reed-Solomon EC: 0 0 0 5
CRC Errors: 0 482 0 0
Header Errors: 0 45 0 0
Interleave (ms): 0.00 0.00 0.00 0.00
Actual INP: 0.00 0.00 0.00 0.00

Do you have any idea what might be wrong?

I've just changed from ADSL where the config was working perfectly.  I've still got to re-add my remote and P2P vpn config and EIGRP configs back in but can't as i can't even get this right :-(

Your help is much needed and appreciated (in advance)

Thanks

J

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Cannot access internet using 887va sec and plusnet (BT) VDSL

Hello,

Your config seems okay, But can you try and tweek it a little to this below?

interface ethernet0

no ip address

no shut

interface ethernet0.101

encapsulation dot1q 101

pppoe enable

pppoe-client dial-pool number 1

interface dialer 1
description PlusNet Fibre
ip address negotiated
no ip unreachables
ip mtu 1492
ip tcp adjust-mss 1452
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxx
ppp chap password xxxx
no cdp enable

sh ip int bri | in up
deb ppp authentication

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
7 REPLIES 7
Enthusiast

Cannot access internet using 887va sec and plusnet (BT) VDSL ser

you default route is missing

ip route 0.0.0.0 0.0.0.0 dialer 1

also configure

ip routing

*** Do Rate all Helpful Posts***

Jawad
Beginner

Cannot access internet using 887va sec and plusnet (BT) VDSL ser

Hi,


Thanks for your response

I did have the ip route 0.0.0.0/0 d1 command applied but did not show it, apologies.

Here are the current errors that i see -

1 - Initial Error -

Mar 17 17:33:19.395:  Sending PADI: Interface = Ethernet0.101
Mar 17 17:33:19.415: PPPoE 0: I PADO  R:0030.8800.0005 L:a44c.1102.2e2c 101 Et0.101
Mar 17 17:33:21.443:  PPPOE: we've got our pado and the pado timer went off
Mar 17 17:33:21.443: OUT PADR from PPPoE Session
Mar 17 17:33:21.487: PPPoE 1743: I PADS  R:0030.8800.0005 L:a44c.1102.2e2c 101 Et0.101
Mar 17 17:33:21.487: IN PADS from PPPoE Session
Mar 17 17:33:21.487: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
Mar 17 17:33:21.487: PPPoE: Virtual Access interface obtained.
Mar 17 17:33:21.491: PPPoE : encap string prepared
Mar 17 17:33:21.491: [0]PPPoE 1743: data path set to PPPoE Client
Mar 17 17:33:21.495: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
Mar 17 17:33:24.255: PPPoE 1743: I PADT  R:0030.8800.0005 L:a44c.1102.2e2c 101 Et0.101
Mar 17 17:33:24.255:  PPPoE : Shutting down client session
Mar 17 17:33:24.255: [0]PPPoE 1743: O PADT  R:0030.8800.0005 L:a44c.1102.2e2c Et0.101
Mar 17 17:33:24.255: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
Mar 17 17:33:24.259: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

2 - Plusnet said the password was incorrect so after changing it (adding in the actual password rather than 0 as above) -

Router#debug pppoe even
PPPoE protocol events debugging is on
Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
..
Mar 17 17:51:50.307:  padi timer expired
Mar 17 17:51:50.307:  Sending PADI: Interface = Ethernet0.101...
Success rate is 0 percent (0/5)

Router#
Mar 17 18:11:43.995:  padi timer expired
Mar 17 18:11:43.995:  Sending PADI: Interface = Ethernet0.101

Router#sh pppoe sess
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st      Type
    N/A   4058  0030.8800.0005  Et0.101                 Di1 N/A        PADISNT
                a44c.1102.2e2c  VLAN: 101

Thanks for your help

VIP Advisor

Re: Cannot access internet using 887va sec and plusnet (BT) VDSL

Hello,

Your config seems okay, But can you try and tweek it a little to this below?

interface ethernet0

no ip address

no shut

interface ethernet0.101

encapsulation dot1q 101

pppoe enable

pppoe-client dial-pool number 1

interface dialer 1
description PlusNet Fibre
ip address negotiated
no ip unreachables
ip mtu 1492
ip tcp adjust-mss 1452
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxx
ppp chap password xxxx
no cdp enable

sh ip int bri | in up
deb ppp authentication

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cannot access internet using 887va sec and plusnet (BT) VDSL

Paul,

I'm going through the differences now betwen your config and mine to decipher what the difference is.  But in the meant time, whatever the difference, it's WORKING

I'm adding a sh run of my config which takes account of the changes you asked me to make and i was wondering what you think the problem might be.

Router#sh run

Building configuration...

Current configuration : 1670 bytes

!

! Last configuration change at 19:42:01 UTC Mon Mar 18 2013

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group 1

!

license udi pid CISCO887VA-SEC-K9 sn FCZ1616C1LH

!

!

vtp domain test.local

vtp mode transparent

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

!

interface Ethernet0.101

encapsulation dot1Q 101

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

ip address 10.10.5.1 255.255.255.128

ip nat inside

ip virtual-reassembly in

!

interface Dialer1

ip address negotiated

no ip unreachables

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname test@test.com

ppp chap password 0 test

no cdp enable

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat inside source list 101 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 101 permit ip any any

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

end

Router#

I'm now going to add the rest of my config (inter vlan routing and remote and PTP VPN so imight come back to you if i run into any more issues.

With much delight, I thank you :-)

VIP Advisor

Re:Cannot access internet using 887va sec and plusnet (BT) VDSL

hello
glad to hear its working.

The two things i could see was:
1) the main eth0 interface was shutdown

2) your ppp authentication

res
Paul

Sent from Cisco Technical Support Android App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re:Cannot access internet using 887va sec and plusnet (BT) VDSL

BT Infinity supports RFC4638 (MTU greater than 1492 over PPPoE) so you may not require these lines:

ip mtu 1492
ip tcp adjust-mss 1452

I have successfully configured both a Cisco 867VAE and a 1921/EHWIC-VA-DSL with a default MTU of 1500 on BT Infinity so it may also work on the 887VA.

Rising star

Cannot access internet using 887va sec and plusnet (BT) VDSL ser

BT do support RFC4638 however you need to configure your side to negotiate a bigger MRU.  You can then remove the 'ip mtu 1492' and 'ip tcp adjust-mss 1452' commands:

interface Ethernet0

mtu 1508

no ip address

!

interface Ethernet0.101

encapsulation dot1Q 101

ip virtual-reassembly in

pppoe enable group global

pppoe-client dial-pool-number 1

pppoe-client ppp-max-payload 1500

!

cisco-887va#sho ppp interface virtual-Access 4
PPP Serial Context Info
-------------------
Interface        : Vi4
PPP Serial Handle: 0x63000001
PPP Handle       : 0xCA000001
SSS Handle       : 0xD8000002
AAA ID           : 13
Access IE        : 0x8B000001
SHDB Handle      : 0x0
State            : Up
Last State       : Binding
Last Event       : LocalTerm

PPP Session Info
----------------
Interface        : Vi4
PPP ID           : 0xCA000001
Phase            : UP
Stage            : Local Termination
Peer Name        : bras-red11.pe
Peer Address     : 217.32.145.10
Control Protocols: LCP[Open] IPCP[Open]
Session ID       : 1
AAA Unique ID    : 13
SSS Manager ID   : 0xD8000002
SIP ID           : 0x63000001
PPP_IN_USE       : 0x11

Vi4 LCP: [Open]
Our Negotiated Options
Vi4 LCP:    MagicNumber 0x4C145BF4 (0x05064C145BF4)
Peer's Negotiated Options
Vi4 LCP:    MRU 1500 (0x010405DC)
Vi4 LCP:    AuthProto CHAP (0x0305C22305)
Vi4 LCP:    MagicNumber 0x0D2B90C7 (0x05060D2B90C7)

Vi4 IPCP: [Open]
Our Negotiated Options
Vi4 IPCP:    Address x.x.x.x (0xxxxxxx)
Vi4 IPCP:    PrimaryDNS 213.120.234.74 (0x8106D578EA4A)
Vi4 IPCP:    SecondaryDNS 213.120.234.66 (0x8306D578EA42)
Peer's Negotiated Options
Vi4 IPCP:    Address 217.32.145.10 (0x0306D920910A)

Cheers

Andy

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards