cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1108
Views
0
Helpful
4
Replies

Cannot Connect Between Routers

ps8812959
Level 1
Level 1

I am using packet tracer tool to create two simple networks. In topology, I have two routers connected together with network 192.168.3.0. The problem is that when I change the IP addresses of routers to "192.168.3.1/8" and "192.168.3.2/8", everything works. When I change the IP addresses to "192.168.3.1/24" and "192.168.3.2/24", ping doesn't work between hosts from network 1 to network 2.

 

I attached the topology file below.

 

4 Replies 4

Hello,

 

you have no routing protocol or static routing configured on your routers. When you use 192.168.3.1/8 and 192.168.3.2/8, the interfaces effectvely are in the same subnet as the other router interfaces.

 

I have added router rip v2 to your routers and advertised the subnets...see the revised attached file ( you need version 7.3.0)...

 

If you don't have version 7.3.0, here are the relevant router configs:

 

Router0

 

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto

!

interface Serial2/0
ip address 192.168.3.1 255.255.255.0
clock rate 1200
!
router rip
version 2
network 192.168.1.0
network 192.168.3.0

Router 1

 

interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 192.168.3.2 255.255.255.0
!
router rip
version 2
network 192.168.2.0
network 192.168.3.0

Thanks. Can you explain what line "the interfaces effectvely are in the same subnet as the other router interfaces" means? I am a bit new to this. Am I using sub-netting here when I say '/8'? What other router interfaces are in same subnet?

Hello,

 

192.x.x.x/8 means everything with 192 in the first octet will be able to talk to anything with 192 in the first octet. So if you give the interfaces an IP address with an /8 mask, from the perspective of that interface, everything else is in the same subnet.

 

If you draw this out, it looks like below. If you give your router interface IP address 192.168.3.1 or 2, with an /8 mask, these IP addresses belong to the same address space as 192.168.1.0/24 and 192.168.2.0/24

 

192.0.0.0/8

Host range: 192.0.0.1 - 192.255.255.254

 

Does that make sense ?

Yes, that makes sense now. It seems I need to do some practice with subnets to understand the concept. Thank you.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card