cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
6970
Views
10
Helpful
16
Replies
cobobobo88
Beginner

Cannot forward broadcast packet to another PC through router

Hi, i am a student who currently doing my last subject called " Final year project" in my universitiy. I am facing 1 problem now which made me cant proceed to next step of my project. My project title is "Investigating Quality of service (QOS) Requirements for Online Game Applications over IP Switched Network". The experiment pad for this project have 3 pc and 2 router with some other software

The problem i facing is "when Pc1 host a warcraft 3 game, Pc2 cant see any host game from the list in LAN network when they are connected".

The network topology is like that:

Pc1 - [interface 1] Cisco Router [interface 2] - Pc2

IP address:
Pc1          - 192.168.0.18

Interface 1 - 192.168.0.17

Interface 2 - 192.168.2.2

Pc2          - 192.168.2.3

Pc1 can ping to Pc2, so they are connected.

So i keep on doing some accesslist command and other to test whether PC2 can see any game from the LAN list, but cant. End up I open a software call "Wireshark" to see the flow packet for both PC. And i found out something, When PC1 has host/create the game, the wireshark constantly show some udp broadcast packet.

Source: 192.168.0.18 ; Destination: 255.255.255.255 ; protocol : UDP ; source port : 6112 ; destination port : 6112

PC1 keep constantly sending but PC2 cant receive any, and i know the router default blocking any broadcast packet to forward. When i plug them to a cisco switch, PC2 can receive the broadcast packet from PC1.

So my current goal is to let my router forward the broadcast packet to PC2, but i even have try some commandline like

ip forward-protocol udp 6112

ip helper-address

ip directed-broadcast

and others....

and PC2 still cant receive any broadcast packet from PC1.

Is anyone know how to help me solve this situation?

Regards

cobo

16 REPLIES 16
Talha Ansari
Beginner

Hi,

While using the "ip helper address" the router will not forward broadcast packets. Router will convert the broadcast into unicast and then forward the packet to the ip address mentioned in combination with helper address command.

So if broadcast is the only critieria for the game to run then the router need to be configured in bridge mode. Or try this command "ip forward-protocol udp" in the config mode and in combination with ip helper address on the interface and do not mention any port number.

Talha

Message was edited by: Talha Ansari

Hi Talha,

I have tried ur combination commandline but still cant work. But i havent try any bridge mode yet. I will study and test it in tomorrow.

Is anyone know my network got any problem that PC2 cant receive any broadcast packet (port : 6112) from PC1 through router?

Regards

cobo

Peter Paluch
Hall of Fame Cisco Employee

Hello,

Can you post the current configuration of your router so that we have a basic starting point? Thanks!

Best regards,

Peter

Hi peter, this is the current configuration.

Router>ena

Password:

Router#show run

Building configuration...

Current configuration : 3297 bytes

!

! Last configuration change at 06:53:58 UTC Mon Sep 26 2011

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash0:c2900-universalk9-mz.SPA.151-4.M.bin

boot-end-marker

!

!

enable secret 5 $1$pd4Y$9jsggO916Vaj.XMhL.7l7/

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2102879060

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2102879060

revocation-check none

rsakeypair TP-self-signed-2102879060

!

!

crypto pki certificate chain TP-self-signed-2102879060

certificate self-signed 01

  3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32313032 38373930 3630301E 170D3131 30363233 30373432

  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31303238

  37393036 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  810097C4 1931E19B 7015BB4D BC7E2101 2C5C252F 18FD8573 5CBBE0B5 186753E3

  4B39BB6D C29BEEBB C97BCC54 B0788587 B47223A6 17D8C65B C17A3C50 0B8FD768

  FC265B2E 78991BD2 6C29FDF6 C3794009 70878DA6 062D6219 71D5F9C5 E8D08DE3

  22A98CAF 428D1E44 7E7C6184 EA2EE560 D7A4DD59 B838A337 EDC324D8 D4BAA899

  15570203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603

  551D1104 0A300882 06526F75 74657230 1F060355 1D230418 30168014 517B6070

  9A3351BD 323B30AA 3B0032D0 E4ECF886 301D0603 551D0E04 16041451 7B60709A

  3351BD32 3B30AA3B 0032D0E4 ECF88630 0D06092A 864886F7 0D010104 05000381

  81004E72 5AE3C8E8 A1EBB0A8 922A1BDE 1F3D3826 7B2914C3 794167D3 C97BAE13

  800B2BF6 A8BEFD14 D88681C6 32AAC72B 827A404C 406D5516 2C31FD12 1CC82C9C

  A5858656 81305DAC D8BA00B6 D1F5261A 4ED2DA79 3475DA54 37D575BA BF69D63E

  BE1E1824 51380A9F D1AA1DF0 A5AB3836 71681F78 954D66C6 0A2A9020 BFAFE65E AE49

        quit

license udi pid CISCO2901/K9 sn FGL15042220

!

!

username cisco

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description $ES_LAN$

ip address 192.168.0.17 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.2.2 255.255.255.0

ip broadcast-address 192.168.2.3

ip helper-address 192.168.2.3

ip directed-broadcast

duplex auto

speed auto

bridge-group 1

!

interface GigabitEthernet0/0/0

no ip address

!

interface GigabitEthernet0/0/1

no ip address

!

interface GigabitEthernet0/0/2

no ip address

!

interface GigabitEthernet0/0/3

no ip address

!

interface Vlan1

no ip address

!

router rip

version 2

network 192.168.0.0

network 192.168.1.0

network 192.168.2.0

!

ip forward-protocol nd

ip forward-protocol udp 6112

!

ip http server

ip http secure-server

!

!

!

!

!

control-plane

!

!

!

line con 0

password cisco

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

'

this picture is capture from wireshark, you can see the PC1 is keep broadcasting the udp packet (port : 6112) after it create game. But Pc2 cannot capture any this udp packet (port: 6112)

Regards

cobo

Hi Cobo,

ip helper-address should face the source, not the receiver as in your configuration.

I would also check TTL value for those datagrams.

HTH,

Ivan.

Peter Paluch
Hall of Fame Cisco Employee

Hi Cobo,

Ivan is correct. If the broadcast sender is on the Gi0/0 interface then the ip helper-address command should also be placed on the Gi0/0. In addition, using the ip helper-address with a particular unicast destination IP address should work, however, if you want to forward the broadcast traffic onto Gi0/1 and still forward it as broadcast, you should use the ip helper-address with the broadcast address of the destination network, i.e. ip helper-address 192.168.2.255

The comment about the source TTL of the broadcast stream is a very important and neglected point - Ivan, thank you very much for pointing that out!

Best regards,

Peter

cobobobo88
Beginner

Hi Ivan and Peter,

thanks for pointing me the problem, my case is solved!

I clear all the commandline again and give back the same ip address to 2 interface of router.

then i type the following commandline

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#ip forw

Router(config)#ip forward-protocol udp 6112

Router(config)#int g0/0

Router(config-if)#ip help

Router(config-if)#ip helper-address 192.168.2.255

Router(config-if)#interface g0/1

Router(config-if)#ip direct

Router(config-if)#ip directed-broadcast

Router(config-if)#exit

Router(config)#

and now its work, the pc2 is able to receive udp broadcast packet (port: 6112) from pc1 through router

thanks everyone !!

regards

cobo

Sounds good, Tan, good luck with your studies!

You see Peter, the TTL seemed to be sufficient to traverse over the box, only configuration mattered ;)

Cheers,

Ivan.

Peter Paluch
Hall of Fame Cisco Employee

Ivan,

You see Peter, the TTL seemed to be sufficient to traverse over the box, only configuration mattered 

Yes, obviously it did! But the TTL in these situations is such an obscure thing. I remember making myself an idiot during a basic IP multicast lab - I eloquently explained the basic multicast routing to students, then we configured everything, started the VLC, began streaming some video, and - nothing happened For half an hour I was debugging that pesky thing until I've found out that the VLC was streaming the video using TTL=1 and moreover, that it ignores the TTL setting in the configuration dialog and you have to write it into the output plugin settings manually. Needless to say, students had a perfect time watching me shrink at the console with every failed attempt to get the stream working. Even now I feel my pressure rising ...

Best regards,

Peter

Hey Peter, that's why I always used the ping approach to present multicast working, rather being messed up with 3d party peculiarities. Of course it is less visional(and even just more confusing) but it works!

uh, I had so many pressure conditions when something was not working fine after the perfect theoretical part, so I would rather skip them to be named here ;)

Hi Peter / Ivan,

I wish to know one thing... can we use PBR to forward broadcasts?

Like in this case if I configure PBR in the following way :

access-list 111 permit ip any host 255.255.255.255

route-map B_FW permit 10

match ip addr 111

set ip next-hop 192.168.2.2 or 192.168.2.255

int gig 0/0

ip policy route-map B_FW

So will this forward the broadcast to the destination ?

Regards,

Talha

Peter Paluch
Hall of Fame Cisco Employee

Hi Talha,

I have tested but it seems that the PBR does not apply to broadcast packets - which is basically a good thing.

Best regards,

Peter

Well as I know this normally done using at least two hops routers to covert broadcast to multicast then back to broadcast to the recover using one router I think it's tricky using the helper command

As long as this lab setup try the bellow method

The receiving interface will convert the broadcast to a multicast address let's say 239.1.1.1

Use pbr to redirect this traffic based on the port number to a loopback address

In the loopback address convert this multicast to broadcast again and send out the desired outbound interface toward the receiver as per bellow config

Ip forward-protocol udp 6112

Ip access-list extended game

Permit udp any any eq 6112

Route-map map1

Match ip address game

Set interface loopback0

Ip multicast routing

Inbound interface:

Interface gig0/0

Ip multicast helper-map broadcast 239.1.1.1 game

Policy-map map1

Interface loopback0

Ip address 1.1.1.1 255.255.255.0

Ip pim dense-mode

Ip multicast helper-map 239.1.1.1 192.168.2.255 game

Outbound interface

Interface gig0/0

Ip directed-broadcast

Ip broadcast-address 192.168.2.255

Make sure you remove the old condign

The on,y concern I have is that the pbr conflict with helper multicast map order

Good luck

 

Outbound interface

Peter Paluch
Hall of Fame Cisco Employee

Hi Marwan,

I am aware of the multicast helper feature. I was simply testing whether a broadcast could in fact be rerouted using PBR. Of course, rerouting via PBR would not change the IP addressing information in the broadcast's IP header. IP helper and IP multicast helper are about converting the header of the broadcast packet: the IP helper replaces the link-local broadcast address 255.255.255.255 with a predefined IP address (which may be unicast or directed broadcast). The IP multicast helper replaces it with a predefined multicast IP address and reconverted into broadcast on another router in the network. You obviously have to run multicast routing for this to work.

Best regards,

Peter