Showing results for 
Search instead for 
Did you mean: 

Cant get 2500 Router to go to ROMMON

Level 1
Level 1

Hi Guys,

Im having a little trouble with a router I have got my hands on to practice for my CCNA.

Im connected via serial>USB adapter and via XP HT on Win7.

Router boots and I then break the boot sequence with ctrl-break. But then it does not go into ROMMON mode. It simply says this:


System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE

Copyright (c) 1986-1995 by cisco Systems

2500 processor with 2048 Kbytes of main memory

Abort at 0x10E9862 (PC)



Anyone know how I get it into ROMMON please to reset the password on it.



7 Replies 7

Reza Sharifi
Hall of Fame
Hall of Fame

Hi Joe,

Does it boot all the way, if you don't try to use ctrl-break?

Another word, turn it off wait for about 30 seconds then turn it on .  How far does it boot?



Thanks for the fast response,

Yes it boots fully, ie "press return to get started"

Then MOTD and then enter password.


Hello Joe,

The ">" prompt that appears after the break sequence: is it just a character or is it a prompt of a command line? The 2500 series routers have had very limited ROMMON and used mostly cryptic commands to perform the necessary tasks. For example, if you actually arrived to the ROMMON in 2500, the commands to ignore the stored config would be

o/r 0x2142


Can you please try this? Also, try sending the Break sequence every 5 seconds or so during the entire root bootup from the power on. Some routers were "sensitive" to the Break sequence only in a certain time frame.

Best regards,


Thanks peter,

It seems to have let me straight in now. No password or anything? I know it doesnt start the running-config but why no passwords still?

I had tried the 0x2142 before but that never worked until I put the o/r infront. What does that mean?



Since it boot all the way, that is good news.  This means your flash card is good. 

I agree with Peter that some times you have to try the break sequence multiple time and not just once. (I know it should work in the first 30 seconds), but that is not always the case.  If that does not work, try just the break key by itself and see if you can get to Rommon.


Level 1
Level 1

Once in 0x2142, how would I go about changing the password?

As ROMMON still wont boot I cant recover so will need to change I guess?

Sorry, can you tell im new? haha

Review Cisco Networking for a $25 gift card