11-27-2015
09:54 PM
- last edited on
08-17-2022
11:44 PM
by
Translator
Hey all,
Trying to setup a cisco router to work with 5 sub-interface vlans. Issue i am currently having is that a device on one network (192.168.10.100) cant ping the gateway IP of 192.168.10.1. The sub-interface is up as i can ping it from the router itself. I noticed in the router ARP table its showing as an imcomplete MAC address. Right now all im concerned with is pinging within the VLANs and accross other sub interfaces on the router. Eventually ill hook this network to others and expand but one step at a time. I have verified the gateway/subnet are set correctly on the computer.
Info from the router is below. Any and all help is greatly appreciated!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.248
ip route-cache flow
duplex full
speed 100
!
interface FastEthernet0/1
description LINK 192.168.10.6
no ip address
ip route-cache flow
duplex full
speed 100
!
interface FastEthernet0/1.101
description WHA1992
encapsulation dot1Q 101
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.0.43
!
interface FastEthernet0/1.102
description WHA1992-WL
encapsulation dot1Q 102
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.0.43
!
interface FastEthernet0/1.103
description PARENT
encapsulation dot1Q 103
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.0.43
!
interface FastEthernet0/1.104
description PARENT-WL
encapsulation dot1Q 104
ip address 192.168.4.1 255.255.255.0
ip helper-address 192.168.0.43
!
interface FastEthernet0/1.105
description SECURITY
encapsulation dot1Q 105
ip address 192.168.5.1 255.255.255.0
ip helper-address 192.168.0.43
!
interface FastEthernet0/1.110
description MANAGEMENT
encapsulation dot1Q 110
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.0.43
!
ip default-gateway 192.168.0.9
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 192.168.10.0 255.255.255.0 FastEthernet0/1
!
Solved! Go to Solution.
11-28-2015 08:34 AM
Please change the configuration of the switch interface connecting to the router to trunk mode.
int fa0/1
no sw mode access
sw trunk encap dot
sw mode trunk
sw trunk allowed vlan 110
Please let me know if that resolves your problem.
Regards
Vinit
11-27-2015
10:02 PM
- last edited on
08-18-2022
02:02 AM
by
Translator
Could you please explain the reason for having the static route
ip route 192.168.10.0 255.255.255.0 FastEthernet0/1
Since you already have the network as part of local network, you do not require this static route.
Could you please remove the same and see if that helps.
Also, please share the topology (how the router is connected to the host from where the ping is initiated)
Regards
Vinit
11-27-2015 10:14 PM
That static route i added when i was testing random things. I removed it now with no luck.
The 192.168.0.0/24 network is the parent network. Then the new router connects to that network with the IP 192.168.0.2. On that new router are the sub-interfaces 192.168.1-10.0/24s. The pings are started from the 192.168.10.1 interface on the new router and go through a managed switch on VLAN 110 to the device on IP 192.168.10.100. I appologize for not having a Vizio diagram to better explain it. Hopefully that helps.
Thanks
11-27-2015
10:40 PM
- last edited on
08-18-2022
02:03 AM
by
Translator
So, if i understand correctly, you have the below topology:
Internet / Internal network----192.168.0.2(RTR)192.168.10.1-----SW-----192.168.10.100(host)
And you are unable to ping from 192.168.10.100 to 192.168.10.1. Is that the correct problem statement?
If thats the case, Could you please share the switch configuration from the interfaces connecting the router as well as the host along with
show vlan id 100
output.
Could you please perform debug ip icmp on the router and then perform the ping test from the host. Also, please share the below output from the router along with debug output
show ip arp
show ip route
Regards
Vinit
11-28-2015
08:15 AM
- last edited on
08-18-2022
02:04 AM
by
Translator
Yes that is the correct layout and the correct problem.
Switch interface connecting to router:
interface FastEthernet0/1
description MGMT TESTING UPLNK
switchport access vlan 110
switchport mode access
speed 100
duplex full
Switch interface connecting to host:
description MGMT AP 2 TEST
switchport access vlan 110
switchport mode access
Show VLAN110 output:
WHA1992-168.0.6#show vlan id 110
VLAN Name Status Ports
---- -------------------------------- --------- ------------------------------
110 MANAGEMENT active Fa0/1, Fa0/2, Fa0/47
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
110 enet 100110 1500 - - - - - 0 0
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
I ran the debug with ICMP but the output didnt change. What should it show?
Show IP ARP:
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.10.100 0 Incomplete ARPA
Internet 192.168.0.43 0 94de.80bb.bc1b ARPA FastEthernet0/0
Internet 192.168.0.9 13 2076.0013.91a8 ARPA FastEthernet0/0
Internet 192.168.10.1 - 0017.e051.d429 ARPA FastEthernet0/1.110
Internet 192.168.1.1 - 0017.e051.d429 ARPA FastEthernet0/1.101
Internet 192.168.0.2 - 0017.e051.d428 ARPA FastEthernet0/0
Internet 192.168.3.1 - 0017.e051.d429 ARPA FastEthernet0/1.103
Internet 192.168.2.1 - 0017.e051.d429 ARPA FastEthernet0/1.102
Internet 192.168.5.1 - 0017.e051.d429 ARPA FastEthernet0/1.105
Internet 192.168.4.1 - 0017.e051.d429 ARPA FastEthernet0/1.104
Internet 192.168.0.181 13 94de.80bb.bc1b ARPA FastEthernet0/0
Show IP Route:
WHA1992-R1#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
C 192.168.10.0/24 is directly connected, FastEthernet0/1.110
C 192.168.4.0/24 is directly connected, FastEthernet0/1.104
C 192.168.5.0/24 is directly connected, FastEthernet0/1.105
192.168.0.0/29 is subnetted, 1 subnets
C 192.168.0.0 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/1.101
C 192.168.2.0/24 is directly connected, FastEthernet0/1.102
C 192.168.3.0/24 is directly connected, FastEthernet0/1.103
S* 0.0.0.0/0 is directly connected, FastEthernet0/0
Thanks,
Brent
11-28-2015 08:34 AM
Please change the configuration of the switch interface connecting to the router to trunk mode.
int fa0/1
no sw mode access
sw trunk encap dot
sw mode trunk
sw trunk allowed vlan 110
Please let me know if that resolves your problem.
Regards
Vinit
11-28-2015 08:40 AM
The reason for doing this is you have router on a stick configuration and thus, multiple vlans are being terminated on it.
If you have a sub-interface configuration, then you cannot use access mode on the switch. You will have to use trunk mode.
Hope this clarifies.
Regards
Vinit
PS: Please mark the question as answered, if your query has been resolved.
11-28-2015 09:41 AM
That did the trick and makes sense why you need to set it as trunk. But here is a follow up question. After i changed the port then i was able to ping 192.168.10.100 from any interface. To be sure things were working i changed the host IP to 192.168.10.102 but now i cant ping it from any other interface besides the gatway 192.168.10.1. The ARP table shows the updated IP but i cant ping it from other subnets. Thoughts?
Thanks for your help answering the main question!
11-28-2015 10:06 AM
I am not sure how you confirmed that the ping was working from other interfaces. I dont think it is supposed to work. You can only reach the subnet within single broadcast domain unless you have routing enabled between subnets.
R3(config)#int e0/1.101
R3(config-subif)#encap dot 102
R3(config-subif)#ip add 10.2.1.1 255.255.255.0
R3(config-subif)#int e0/1.102
R3(config-subif)#encap dot 101
R3(config-subif)#ip add 10.101.1.1 255.255.255.0
R3(config-subif)#end
R3#ping 10.1.1.100 so 10.101.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
Packet sent with a source address of 10.101.1.1
.....
Success rate is 0 percent (0/5)
R3#ping 10.1.1.100 so 10.2.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
Packet sent with a source address of 10.2.1.1
.....
Success rate is 0 percent (0/5)
Hope this helps.
Regards
Vinit
11-27-2015 10:39 PM
Brent,
just to confirm, do you have the router connected to a switch which has got vlan's created in it and to which the hosts are connected to the switch ? pls confirm.
11-28-2015 08:16 AM
Yes the router is connected to a 2960 switch with VLANS 100-110 created on it.
Thanks,
Brent
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide