cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
231
Views
0
Helpful
4
Replies
Highlighted
Beginner

Cant ping to/from server from premise switch.

Hello,

I have a strange issue.  We have some servers in Azure tenants via a S2S VPN tunnel.  I can ping the server (10.211.20.100) from our main switch 10.1.1.1 no problem, but from our 2nd floor switch that is connected to the main switch I cant?  Is there something I am missing why I cant ping from the 2nd floor switch?

 

These are 2960' switches.

 

Thanks in advance.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Cant ping to/from server from premise switch.

Hi there,

 

Actually figured this out.  I was missing the static route on our GW to the Azure Tenant. Once I added that it was all good.

4 REPLIES 4
Hall of Fame Guru

Re: Cant ping to/from server from premise switch.

 

It depends on the IP you are pinging from. 

 

Can you ping from the main switch using an IP from the same subnet as the second floor switch ? 

 

Jon

Beginner

Re: Cant ping to/from server from premise switch.

Hi John,

 

Our setup goes like this. 

So if I ping from my GW switch 10.1.1.1--> to the Azure Tenant Device 10.211.20.100 I can reach it fine.

CSW01>ping 10.211.20.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.211.20.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 25/30/34 ms

-------------------------------------------------

CSW01>traceroute 10.211.20.100

Type escape sequence to abort.
Tracing the route to 10.211.20.100

1 10.211.1.7 34 msec
10.211.1.8 25 msec 33 msec

-------------------------------------------------

 

If I try to ping or trace from my 2nd floor switch I cant:

So if I ping from my GW switch 10.1.64.18--> to the Azure Tenant Device 10.211.20.100 it fails.

 

GW1#ping 10.211.20.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.211.20.100, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

--------------------------------

GW1#traceroute 10.211.20.100
Type escape sequence to abort.
Tracing the route to 10.211.20.100
VRF info: (vrf in name/id, vrf out name/id)
1 209.13.153.174 0 msec 0 msec 0 msec
2 * * *

Beginner

Re: Cant ping to/from server from premise switch.

Hi John,

 

I suspect I am missing something with a route. I can  ping/trace as per the below it works fine from our core switch device. for example: 

10.1.1.1 ---> 10.211.20.100

CSW01#ping 10.211.20.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.211.20.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 25/35/50 ms

 

Tracing the route to 10.211.20.100

1 10.211.1.8 42 msec 34 msec 25 msec

-----------------------------------------------------

 

Now if I try from our Gateway switch it doesnt work. Example:

10.1.64.18----> 10.211.20.100

GW1#ping 10.211.20.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.211.20.100, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

GW1#traceroute 10.211.20.100
Type escape sequence to abort.
Tracing the route to 10.211.20.100
VRF info: (vrf in name/id, vrf out name/id)
1 209.11.125.184 0 msec 0 msec 0 msec
2 * * *

 

Everyone's tags (3)
Beginner

Re: Cant ping to/from server from premise switch.

Hi there,

 

Actually figured this out.  I was missing the static route on our GW to the Azure Tenant. Once I added that it was all good.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards