cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

285
Views
0
Helpful
7
Replies
Beginner

Changing EIGRP VRF config to OSPF

Hello,

 

I have an example VRF config below I want to change to OSPF for area 0, can someone give me an example of what it might look like?  The one below is working fine with EIGRP over a sub interface:

 

ip vrf Customer-A
!
ip vrf Customer-B
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 5
 ip vrf forwarding Customer-A
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 10
 ip vrf forwarding Customer-B
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding Customer-A
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 ip vrf forwarding Customer-B
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 duplex auto
 speed auto
!
router eigrp 1
 !
 address-family ipv4 vrf Customer-A
 network 10.0.0.0
 autonomous-system 100
 exit-address-family
 !
 address-family ipv4 vrf Customer-B
 network 10.0.0.0
 autonomous-system 100
 exit-address-family

 

Thanks

7 REPLIES 7
Highlighted

Re: Changing EIGRP VRF config to OSPF

Hi @Andrew White 

 

The vrf aware OSPF config is pretty straight forward like below

 

router ospf 1 vrf Customer-A
  network 10.0.0.0 0.255.255.255 area 0 ----->> If you want to enable ospf on all 10.0.00/8 interfaces in that VRF

router ospf 1 vrf Customer-B
  network 10.0.0.0 0.255.255.255 area 0 

 

 


But you might want to keep in mind various differences that vrf aware OSPF presents to area 0 in a VRF context. There is another hierarchy of super-backbone area that gets added when OSPF is run with vrf context.

 

You should also use below command to relax the effects of the super-backbone area.

"capability vrf lite"

 

****** Please mark this post helpful if it contributed to your learning ******

 

-

Sebastian

 

Beginner

Re: Changing EIGRP VRF config to OSPF

Strange, I've removed the EIGRP config and proceeded with adding the OSPF config for area 1 and I can't add the second VFR:

 

router ospf 1 vrf Customer-A
network 10.0.0.0 0.255.255.255 area 0
!
ip forward-protocol nd
!

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router ospf 1 vrf Customer-B
%VRF specified does not match existing router
R1(config)#

 

Any idea what I've done wrong?

Beginner

Re: Changing EIGRP VRF config to OSPF

Seems using a 2nd OSPF PID helped, is this normal?

 

router ospf 1 vrf Customer-A
capability vrf-lite
network 10.0.0.0 0.255.255.255 area 0
!
router ospf 2 vrf Customer-B
capability vrf-lite
network 10.0.0.0 0.255.255.255 area 0

 

I see on some example configs some use route distinguishers, what is this?

Beginner

Re: Changing EIGRP VRF config to OSPF

Well I proceeded with having 2 OSPF instances, but only OSPF 1 forms a neighbour relationship using VRF Customer-A.

I can ping the neighbours on VRF Customer-B:

 

R2#ping vrf Customer-B 10.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/10 ms
R2#
R2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.12.12.1 1 FULL/BDR 00:00:39 10.12.12.1 GigabitEthernet0/0.1
R2#

R1 config

 

ip vrf Customer-A
!
ip vrf Customer-B
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/0.1
 description Customer-A
 encapsulation dot1Q 5
 ip vrf forwarding Customer-A
 ip address 10.12.12.1 255.255.255.0
!
interface GigabitEthernet0/0.2
 description Customer-B
 encapsulation dot1Q 10
 ip address 10.12.12.1 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding Customer-A
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 ip vrf forwarding Customer-B
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1 vrf Customer-A
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0
!
router ospf 2 vrf Customer-B
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0

R2 config

 

ip vrf Customer-A
!
ip vrf Customer-B
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 5
 ip vrf forwarding Customer-A
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 10
 ip vrf forwarding Customer-B
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding Customer-A
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 ip vrf forwarding Customer-B
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1 vrf Customer-A
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0
!
router ospf 2 vrf Customer-B
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0

ospf-vrf.PNG

 

 

 

 

Re: Changing EIGRP VRF config to OSPF

Hi @Andrew White 

 

Yes the PID needs to be different as you're required to run two distinct process of OSPF. You should configure different RD value for each VRF. Route-distinguisher is what makes the overlapping route unique by appending a unique RD for that VRF. 

 

I think in your case, its the OSPF Router ID that is causing the issue. Because both VRFs have the same highest IP (10.12.12.1). Try changing the manual router ID for each OSPF PID. 

 

Also if this does not solve the issue.  Please share below output

 

- show ip ospf 1 interface 

- show ip ospf 2 interface

 

 

***** Please don't forget to mark post helpful *****

Sebastian

 

Beginner

Re: Changing EIGRP VRF config to OSPF

Hi, before I try this can you help configure the RD’s as I’m not sure of what values to use? I’ve seen some values others have used but I’m not sure how they decided on those they chose.

Thanks
Beginner

Re: Changing EIGRP VRF config to OSPF

Still no luck with OSPF 1 or 2 coming up.

 

I've added loop backs on on R1 (1.1.1.1/32) and R2 (2.2.2.2/32) for the router IDs too to distinguish both locally.

 

From R1

 

ip vrf Customer-A
!
ip vrf Customer-B
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/0.1
description Customer-A
encapsulation dot1Q 5
ip vrf forwarding Customer-A
!
interface GigabitEthernet0/0.2
description Customer-B
encapsulation dot1Q 10
ip vrf forwarding Customer-B
!
interface GigabitEthernet0/1
ip vrf forwarding Customer-A
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/2
ip vrf forwarding Customer-B
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/3
no ip address
duplex auto
speed auto
media-type rj45
!
router ospf 1 vrf Customer-A
router-id 1.1.1.1
capability vrf-lite
network 10.0.0.0 0.255.255.255 area 0
!
router ospf 2 vrf Customer-B
router-id 1.1.1.2
capability vrf-lite
network 10.0.0.0 0.255.255.255 area 0


R1#sh ip ospf interface
GigabitEthernet0/2 is up, line protocol is up
Internet Address 10.10.10.1/24, Area 0, Attached via Network Statement
Process ID 2, Router ID 1.1.1.2, Network Type BROADCAST, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.2, Interface address 10.10.10.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1/1, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/1 is up, line protocol is up
Internet Address 10.10.10.1/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, Interface address 10.10.10.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/2/2, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 1 msec, maximum is 1 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
R1#




 R2

 

interface Loopback0
 ip address 1.1.1.2 255.255.255.255
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 5
 ip vrf forwarding Customer-A
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 10
 ip vrf forwarding Customer-B
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding Customer-A
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 ip vrf forwarding Customer-B
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1 vrf Customer-A
Router-is 2.2.2.1 capability vrf-lite network 10.0.0.0 0.255.255.255 area 0 ! router ospf 2 vrf Customer-B
Router-id 2.2.2.2 capability vrf-lite network 10.0.0.0 0.255.255.255 area 0 R2#sh ip ospf int GigabitEthernet0/2 is up, line protocol is up Internet Address 10.20.20.2/24, Area 0, Attached via Network Statement Process ID 2, Router ID 10.20.20.2, Network Type BROADCAST, Cost: 1 Topology-MTID Cost Disabled Shutdown Topology Name 0 1 no no Base Transmit Delay is 1 sec, State DR, Priority 1 Designated Router (ID) 10.20.20.2, Interface address 10.20.20.2 No backup designated router on this network Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 oob-resync timeout 40 Hello due in 00:00:07 Supports Link-local Signaling (LLS) Cisco NSF helper support enabled IETF NSF helper support enabled Index 1/2/2, flood queue length 0 Next 0x0(0)/0x0(0)/0x0(0) Last flood scan length is 0, maximum is 0 Last flood scan time is 1 msec, maximum is 1 msec Neighbor Count is 0, Adjacent neighbor count is 0 Suppress hello for 0 neighbor(s) GigabitEthernet0/0.2 is up, line protocol is up Internet Address 10.12.12.2/24, Area 0, Attached via Network Statement Process ID 2, Router ID 10.20.20.2, Network Type BROADCAST, Cost: 1 Topology-MTID Cost Disabled Shutdown Topology Name 0 1 no no Base Transmit Delay is 1 sec, State DR, Priority 1 Designated Router (ID) 10.20.20.2, Interface address 10.12.12.2 No backup designated router on this network Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 oob-resync timeout 40 Hello due in 00:00:01 Supports Link-local Signaling (LLS) Cisco NSF helper support enabled IETF NSF helper support enabled Index 1/1/1, flood queue length 0 Next 0x0(0)/0x0(0)/0x0(0) Last flood scan length is 0, maximum is 0 Last flood scan time is 0 msec, maximum is 0 msec Neighbor Count is 0, Adjacent neighbor count is 0 Suppress hello for 0 neighbor(s) GigabitEthernet0/1 is up, line protocol is up Internet Address 10.20.20.2/24, Area 0, Attached via Network Statement Process ID 1, Router ID 10.12.12.2, Network Type BROADCAST, Cost: 1 Topology-MTID Cost Disabled Shutdown Topology Name 0 1 no no Base Transmit Delay is 1 sec, State DR, Priority 1 Designated Router (ID) 10.12.12.2, Interface address 10.20.20.2 No backup designated router on this network Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 oob-resync timeout 40 Hello due in 00:00:03 Supports Link-local Signaling (LLS) Cisco NSF helper support enabled IETF NSF helper support enabled Index 1/2/2, flood queue length 0 Next 0x0(0)/0x0(0)/0x0(0) Last flood scan length is 0, maximum is 0 Last flood scan time is 1 msec, maximum is 1 msec Neighbor Count is 0, Adjacent neighbor count is 0 Suppress hello for 0 neighbor(s) GigabitEthernet0/0.1 is up, line protocol is up Internet Address 10.12.12.2/24, Area 0, Attached via Network Statement Process ID 1, Router ID 10.12.12.2, Network Type BROADCAST, Cost: 1 Topology-MTID Cost Disabled Shutdown Topology Name 0 1 no no Base Transmit Delay is 1 sec, State DR, Priority 1 Designated Router (ID) 10.12.12.2, Interface address 10.12.12.2 No backup designated router on this network Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 oob-resync timeout 40 Hello due in 00:00:09 Supports Link-local Signaling (LLS) Cisco NSF helper support enabled IETF NSF helper support enabled Index 1/1/1, flood queue length 0 Next 0x0(0)/0x0(0)/0x0(0) Last flood scan length is 0, maximum is 2 Last flood scan time is 0 msec, maximum is 3 msec Neighbor Count is 0, Adjacent neighbor count is 0 Suppress hello for 0 neighbor(s)

Neighbour relationships are down since the changes

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here