cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
530
Views
4
Helpful
4
Replies
Beginner

Cisco 1760 QoS setup

I currently have a pair of Adtran Netvanta 1224R units that I want to replacce with Cisco 1760 routers. How can I translate the existing QoS (relevant sections below) on the Adtrans to work on the Cisco routers:

!

no ip firewall alg msn

no ip firewall alg h323

!

qos map Qos1 20

  match dscp 46

  match precedence 5

  priority 1024

qos map QoS1 21

  match list QoSACL

  set dscp 46

qos queue-type wrr 25 25 25 expedite

!

interface ppp 1

  qos-policy out QoS1

!

ip access-list extended QoSACL

  permit tcp any  any eq 1720

  permit udp any  any eq 1718

  permit udp any  any eq 1719

Thanks

Everyone's tags (4)
4 REPLIES 4
Highlighted
VIP Expert

Re: Cisco 1760 QoS setup

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

What's the IOS version, serial port type, available bandwidth?

Highlighted
Beginner

Re: Cisco 1760 QoS setup

Three of the routers are 'C1700 Software (C1700-IPBASE-M), Version 12.3(2)T8' and one is 'C1700 Software (C1700-Y-M), Version 12.2(15)T10'. The serial port is a WIC-1DSU-T1 on all with the full 1.544Mbps bandwidth available. I'm not positive on the specific settings for the serial link yet.

What's the difference between the 'IPBASE-M' and 'Y-M' IOS versions?

Highlighted
VIP Expert

Re: Cisco 1760 QoS setup

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

What's the difference between the 'IPBASE-M' and 'Y-M' IOS versions?

Probably close to the same - but as different versions, packing names often differ.  Older IOS has special IOS versions per new software feature or new hardware feature.

Not 100% sure of what the Adtran QoS does, or why gatekeeper traffic being set to DSCP EF, but you might try:

class-map match-any LLQ

match precedence 5

policy-map Sample

class LLQ

priority 1024

class class-default

fair-queue

interface serial #

service-policy output Sample

Highlighted
Beginner

Re: Cisco 1760 QoS setup

Thanks Joseph. From your answer, I was able to get a little more info. I think you were missing the Access list that would tell the router what should be given priority. It seems that without an ACL, nothing would match so nothing would be given priority.

I came up with the following:

**************

class-map match-any voice-traffic
  match access-group 101
  match  precedence 5

policy-map voice-policy
  class voice-traffic
   priority 1024
  class class-default
   fair-queue

interface Serial0/0
service-policy output voice-policy

access-list 101 permit tcp any any eq 1720
access-list 101 permit udp any any eq 1718
access-list 101 permit udp any any eq 1719

**************

If I read the Adtran config right, they are using the 'qos map QoS1 21' to set TCP/1720, UDP/1718 & UDP/1719 packets with a DCSP codepoint value of 46, then using 'qos map Qos1 20' to apply critical precidence to all packets with the DCSP copdepoint 46 value and have that map applied to the serial interface.

The way I have the Cisco configured, the same thing should be done without retagging any packets. Or am I off base?

Is there any command that I can run on the router to see if LLQ is actually doing anything?