cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
5113
Views
4
Helpful
15
Replies
Boris Simunko
Beginner

Cisco 1812 usb IOS boot

is it possible to boot the image from a usb stick on a 1812? if so, what are the requirements?

15 REPLIES 15
Latchum Naidu
Engager

Hi Boris,

Looks like it is possible, you can do that.
http://www.cisco.com/en/US/prod/collateral/modules/ps6247/product_data_sheet0900aecd80232473.html

Please rate the helpful posts.
Regards,
Naidu.

well, it only seems that it's possible, but... when i plug a usb stick, the router recognizes it, i can copy from/to the usb stick, but when i try to perform the boot system usbflashX: command, it does not work, actually the router does not offer me the option usbflashX:, just the regular options (flash, tftp....)

i am currently running c181x-adventerprisek9-mz.124-15.T3

Ivan Krimmel
Rising star

Privet Boris,

a few things to be aware of:

1. you need to run the supported rommon version for that, see the link http://www.cisco.com/en/US/prod/collateral/modules/ps6247/prod_qas0900aecd80232483.html

2. the usb token should be one of the suported types, i.e. from Cisco; though 3d party gadgets might work as well;

3. you might want to use this statement to let the IOS run off the token:

boot system flash usbflash0:c181x-adventerprisek9-mz.124-15.T3

4. you might try to start the image from rommon:

rommon1>dev

rommon2>dir usbflash0:

rommon2>boot usbflash0:c181x-adventerprisek9-mz.124-15.T3

the feature itself is supported, so let's eliminate all these four points at the begining.

Best regards,

Ivan.

Hi Leo,

Is Kingston USB available .......

Leo Laohoo
VIP Community Legend

This is do-able.  I've been doing it for years.

1.  Upgrade your ROMmon to 12.4(13r)T or later.  Download from the Cisco website and use the command "upgrade rom file tftp:///filename".

2.  Not all USB sticks are supported.  So try some before buying alot.

3.  Maximum size I've tried is 2Gb but some swear you can use 4Gb.

4.  Format using FAT16 or use the 1800 to format the stick.

5.  The command "boot system usbflash0:", particularly the "usbflash0:" bit is a hidden command.  So you need to enter the full word.

thanks for all the advice!

i can not use the boot system usbflash command because it does not exist, but i'll try to update the rommon and see what happens...

i just now noticed

5.  The command "boot system usbflash0:", particularly the "usbflash0:" bit is a hidden command.  So you need to enter the full word.

i'll try that!

Hey Boris,

were you able to get this thingy working? would be interested to learn your feedback on whether the issue has been solved or not.

Cheers,

Ivan.

hello!

unfortunately, no...

i did update rommon, and entered all of the commands, but still nothing...it seems to me that, even though the boot system usbflashx:xxxxxx.bin is applied, the router still boots from flash because it does not manage to boot up the usb stick fast enough and just goes straight to flash! i am not a 100% sure this is the reason, maybe the usb stick itself is the problem...

have you tried to jump into rommon first and boot up off it then?

what about the usb type - is it of supported type?

could you please paste 'sh bootvar' in here.

Cheers,

Ivan.

Boris,

Eject the CF and try again to boot from USB.

hi!

tried booting with the ejected CF, but nothing...the router says that the usb type is not supported...

only thing i can do is to try again with different usb sticks, maybe i'll find one that works

the router says that the usb type is not supported...

Unfortunately, not all USB sticks are supported.

Hi Leo,

Is Kingston USB available .......