cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
3937
Views
5
Helpful
11
Replies
GREGORY JACKSON
Beginner

Cisco 2511 Terminal Server

I am having some dificulties with my terminal server:

1#sho ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-I-L), Version 12.1(27b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Tue 16-Aug-05 22:38 by pwade
Image text-base: 0x03041FDC, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTLDR: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)

T1 uptime is 43 minutes
System returned to ROM by power-on
System image file is "flash:c2500-i-l.121-27b.bin"

cisco 2511 (68030) processor (revision M) with 14336K/2048K bytes of memory.
Processor board ID 12023738, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
16 terminal line(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)
         
Configuration register is 0x2102

I know it's old code and I will upgrade it soon but right now I just want to get my reverse telnet working.

Here what I have so far:

Building configuration...

Current configuration : 664 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname T1
!
!
!
!
ip subnet-zero
ip host r1 2001 1.1.1.1
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
line con 0
exec-timeout 0 0
line 1 16
no exec
transport input all
stopbits 1
line aux 0
line vty 0 4
login
!
end

I'm using Sevure CRT 6.7.

Wehn I type in "r1" I get the following message "Trying r1 (1.1.1.1, 2001)... Open" and that it I get no further.  I use the break squence to get back to the terminal server prompt and I run "sho session" and get the following output:

"

T1#sho session

Conn Host                Address             Byte  Idle Conn Name

*  1 r1                  1.1.1.1                0     0 r1

T1#r1

Trying r1 (1.1.1.1, 2001)... Open

It appears that my session is connected i just get no response my screen just stay locked on the "T1#r1
Trying r1 (1.1.1.1, 2001)... Open

Any suggestions...

Thanks,

g

11 REPLIES 11
mbilgrav
Participant

it doesnt make sense to me why you want to connect to the router that you allready are connected to ...

anyway - : Did you try and hit "enter" ?

also I think you need to provide a password.

what does your SecureCRT say when you telnet ?

are you connecting and line combo-cables ?

I am not sure that the router will start a listner on port 2001 just because you give it an "ip host" command.

Regards

Martin

Thanks for the response -- I am using a asynchronous 8 octal cable connect to the router. The router is connected to the octal cable 1 which translates to 2001 when I configure the reverse telnet. I'm consoled into my terminal server and from my # prompt I type "r1" or telnet 1.1.1.1 2001.

Sent from Cisco Technical Support iPad App

Hi Gregory,

what does 'sh line' tells you?

also, make sure you have the octal cable inserted into the right slot, I think 2001 will respond on slot 0's first cable etc.

Did you try to telnet 1.1.1.1 2001 from a remote pc?

Martin,

have a look - http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml

Regards,

Ivan.

Thanks for your response. I cannot telnet to the device from a pc I have not configured the LAN yet. I have tried to telnet from the terminal server directly and got same results. Just seem to hang at the ".... Open" state. I would like to know of a good cable matrix showing what cable is 1 to 8 on the octal cable. They are labeled but I'd like to validate. Also are there any good debug commands that can help other than the debug asynchronous packet.

Sent from Cisco Technical Support iPad App

Gregory,

normally if the cable is labeled it should correspond to the right pins on the connector, a big doubt if there's a way to check this. Is that box, r1, powered up? Have you tried to console to it directly? any non-default settings on its console? Did you check as per my previous suggestion if the module is in the appropriate slot?

Cheers,

Ivan.

R1 is powered and I can console to it directly using secureCRT and the cisco provided cables, nothing on the device preventing connectivity. Can't do a show line as I'm away from the equipment. I can do that later this evening. I have looked at the supporting documentation and that along with a few others I referenced when I did the original configuration.

Sent from Cisco Technical Support iPad App

I have access to my terminal server I have connected to it via console cable. I ran the "show line" command after trying to attach to the router and I also added a sw1 on 2009. See output below:

T1#sho line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*    0 CTY              -    -      -    -    -      0       0     0/0       -
     1 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     2 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     3 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     4 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     5 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     6 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     7 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     8 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     9 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    10 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    11 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    12 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    13 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    14 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    15 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    16 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    17 AUX   9600/9600  -    -      -    -    -      0       0     0/0       -
    18 VTY              -    -      -    -    -      0       0     0/0       -
    19 VTY              -    -      -    -    -      0       0     0/0       -
    20 VTY              -    -      -    -    -      0       0     0/0       -
    21 VTY              -    -      -    -    -      0       0     0/0       -
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int

    22 VTY              -    -      -    -    -      0       0     0/0       -

T1#sho run
Building configuration...

Current configuration : 664 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname T1
!
!
!
!
ip subnet-zero
ip host r1 2001 1.1.1.1
!
!
!
!        
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip classless
ip http server
!
!
line con 0
exec-timeout 0 0
line 1 16
no exec 
transport input all
stopbits 1
line aux 0
line vty 0 4
login
!
end

T1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
T1(config)#ip host sw1 2009 1.1.1.1
T1(config)#^Z
T1#
00:02:45: %SYS-5-CONFIG_I: Configured from console by consolesw1
Trying sw1 (1.1.1.1, 2009)... Open

T1#r1
Trying r1 (1.1.1.1, 2001)... Open

T1#sho line
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
*    0 CTY              -    -      -    -    -      2       0     0/0       -
*    1 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
     2 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     3 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     4 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     5 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     6 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     7 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
     8 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
*    9 TTY   9600/9600  -    -      -    -    -      1       0     0/0       -
    10 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    11 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    12 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    13 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    14 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    15 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    16 TTY   9600/9600  -    -      -    -    -      0       0     0/0       -
    17 AUX   9600/9600  -    -      -    -    -      0       0     0/0       -
    18 VTY              -    -      -    -    -      0       0     0/0       -
    19 VTY              -    -      -    -    -      0       0     0/0       -
    20 VTY              -    -      -    -    -      0       0     0/0       -
    21 VTY              -    -      -    -    -      0       0     0/0       -
   Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int

    22 VTY              -    -      -    -    -      0       0     0/0       -

T1#

Still no sucess to eitehr sw1 or r1?

Found the problem needed to have flow control dtr/dsr selected in the session options in secureCRT

Sent from Cisco Technical Support iPad App

Gregory

Thanks for posting back to the forum indicating that you have solved the problem and what the solution is. I have seen quite a few questions about problems with terminal servers but very few bring up the issue of flow control in the emulator. So this is very helpful.

HTH

Rick

HTH

Rick

I have a problem with my terminal server . line 1-8 connects sucessfully, but 9-16 does not connect, but stays open. Can someone help please 

 

2500series#R9
Trying R9 (192.168.30.1, 2009)... Open

 NOTHING HAPPENS AFTER THIS 

2500series#show lin
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
0 CTY - - - - - 0 0 0/0 -
1 TTY 9600/9600 - - - - - 0 0 0/0 -
2 TTY 9600/9600 - - - - - 0 0 0/0 -
3 TTY 9600/9600 - - - - - 0 0 0/0 -
4 TTY 9600/9600 - - - - - 0 0 0/0 -
5 TTY 9600/9600 - - - - - 0 0 0/0 -
6 TTY 9600/9600 - - - - - 0 0 0/0 -
7 TTY 9600/9600 - - - - - 0 1 0/0 -
8 TTY 9600/9600 - - - - - 7 0 0/0 -
* 9 TTY 9600/9600 - - - - - 3 0 0/0 -
* 10 TTY 9600/9600 - - - - - 1 0 0/0 -
11 TTY 9600/9600 - - - - - 0 0 0/0 -
12 TTY 9600/9600 - - - - - 0 0 0/0 -
13 TTY 9600/9600 - - - - - 0 0 0/0 -
14 TTY 9600/9600 - - - - - 0 2 0/0 -
15 TTY 9600/9600 - - - - - 0 1 1/0 -
16 TTY 9600/9600 - - - - - 0 0 0/0 -
17 AUX 38400/38400 - - - - - 0 0 0/0 -
* 18 VTY - - - - - 13 0 0/0 -
19 VTY - - - - - 0 0 0/0 -
20 VTY - - - - - 0 0 0/0 -
21 VTY - - - - - 0 0 0/0 -
--More--