cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
775
Views
0
Helpful
4
Replies

Cisco 2911 Voice and Data Vlans

j44mistry
Beginner
Beginner

Hello,

I have an remote office with a flat /24 network.

Users / Servers connect to 2 x 3560 Cisco switches which are uplinked to 2 x Cisco 3925 routers for Internet connectivity and VPN.

We are planning to install VoIP in the office and would like to know how best to configure the Cisco 2911.

The Cisco 2911 will connect directly to the Cisco 3560 switch.     I need to create 2 vlans 1 x Voice and 1 x Data. 

What is the best way to configure 2911 ?

Ideally I would like to have resiliency from the Voice Gateway so would like to have it connect to both Cisco 3560 switches.

What is the best way to route both vlans ?

Analog Phones --->Cisco 2911 (VG)---->Cisco 3560------Cisco 3925 -----> Internet  

4 Replies 4

antonio.guirado
Participant
Participant

Hello,

STP could be a good solution. The problem is the time converge (it can be 30-50 seconds), so better
RSTP (rapid STP). I have checked if your router can support this feature and it can not. But there is

another (Cisco propietary) solution to speed up convergence time on (slow) STP enviroment Uplink port fast.

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a0080094641.shtml

Basically, is the same idea as RSTP, 2911 negotiates an alternative root port and uses it if the main port fails.

If you send me the exact IOS version I can check if you have this feature supported.

Regards

IOS Version :-

c2900-universalk9-mz.SPA.152-4.M2.bin

Does one of the interfaces have to be configured as backup ?

If I have trunk ports can I route same vlans across both trunks ?

Regards,

Hello,

thist is a configuration example:

bridge irb

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

bridge-group 10

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

bridge-group 20

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

bridge-group 10

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

bridge-group 20

!

interface BVI10

ip address 10.10.10.1 255.255.255.0

!

interface BVI20

ip address 20.10.10.1 255.255.255.0

!

bridge 1 protocol ieee

bridge 10 protocol ieee

bridge 20 protocol ieee

The idea is that both FastEthernet port works as a brigde and then run STP with your switches. A link

will be blocked. I can not tell you the commands in the 2911 to configure portfast uplink but your IOS version

support it. With the configuration everythink should wrok fine but you converge time will be 30-50 second (STP).

Regards

Hi Antonio,

Is it possible to have a point to point link with a backup interface using same network and would that be better ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: