I'm not hugely experienced with Cisco routers but I've managed to configure a Cisco 2921 with BT Infinity which works fine. I can access the web/browse etc.
The only thing I'm struggerling with, is my BT package has static IPs currently the BT Home hub dials with PPOE and the static IPs on the hub appear to be a virtual interface. Does anyone know how to configure this similar style setup on a Cisco router?
Conf below;
Current configuration : 3570 bytes
!
! Last configuration change at 11:27:34 UTC Sun Apr 8 2018 by mroot
! NVRAM config last updated at 11:17:34 UTC Sun Apr 8 2018 by mroot
! NVRAM config last updated at 11:17:34 UTC Sun Apr 8 2018 by mroot
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
no logging console
enable secret 4 bKeS4xiYXaJxSPFOy2jnfzOvVRFm80AdocXk.8g4BYE
!
no aaa new-model
memory-size iomem 25
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name domain.com
ip name-server 8.8.8.8
ip name-server 8.8.4.4
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FCZ170595H6
!
!
username mroot privilege 15 secret 4 mOA83nec.Q62OjRrUlRfSx3EZxHay2wbwsJ8jRpOd5c
!
!
ip ssh version 2
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
no ip route-cache
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 101
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
ip address 10.1.10.50 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1350
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip access-group 101 in
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
ppp chap hostname login@btconnect.com
ppp chap password 7 14071E1E01063F38302D2164
ppp pap sent-username login@btconnect.com password 7 044B07130223595D1D1C1746
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.1.0.0 255.255.0.0 GigabitEthernet0/1
!
access-list 1 remark INTERNET-ACCESS
access-list 1 permit 10.1.0.0 0.0.255.255
access-list 101 deny ip 192.168.0.0 0.0.255.255 any
access-list 101 deny ip 172.16.0.0 0.15.255.255 any
access-list 101 deny ip 10.0.0.0 0.255.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 deny ip 255.0.0.0 0.255.255.255 any
access-list 101 deny ip 224.0.0.0 7.255.255.255 any
access-list 101 deny ip host 0.0.0.0 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny udp any any range 33400 34400
access-list 101 permit icmp any any net-unreachable
access-list 101 permit icmp any any host-unreachable
access-list 101 permit icmp any any port-unreachable
access-list 101 permit icmp any any packet-too-big
access-list 101 permit icmp any any administratively-prohibited
access-list 101 permit icmp any any source-quench
access-list 101 permit icmp any any echo-reply
access-list 101 permit tcp any any established
access-list 101 permit udp any any
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
login local
line aux 0
logging synchronous
login local
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
logging synchronous
login local
transport input ssh
line vty 5 1370
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
end