cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
374
Views
0
Helpful
7
Replies
Highlighted
Beginner

Cisco 2921 IPTV Multicast

Hi Folks!

Need your help for multicast, if possible.

I have ISP router connected to my Cisco 2921 router, and this connected to two switches Cisco 2960.

Everything works fine on all vlans, except TV. What I want is the ISP Set Top Box to work to see ISP TV. So, what happens: When I turn on Set Top Box, after a few seconds the image freezes.

ISP works with IGMP version 3.

 

Parts of configuration:

ISP Router – 10.1.1.1 / 255.255.255.252

 

Cisco 2921 (IPBase License)

!

ip dhcp excluded-address 10.105.105.2

!

ip dhcp pool IPTV

 network 10.105.105.0 255.255.255.252

 dns-server 10.1.1.1

 default-router 10.105.105.2

!

ip multicast-routing

!

bridge irb

!

interface GigabitEthernet0/0

 description *** WAN ***

 ip address dhcp

 ip pim sparse-dense-mode

 ip nat outside

 ip virtual-reassembly in

 ip igmp version 3

 duplex auto

 speed auto

!

interface GigabitEthernet0/1

 description *** To SW1 ***

 no ip address

 duplex auto

 speed auto

 media-type rj45

!

interface GigabitEthernet0/1.105

 encapsulation dot1Q 105

 bridge-group 105

!

interface GigabitEthernet0/2

 description *** To SW2 ***

 no ip address

 duplex auto

 speed auto

!

interface GigabitEthernet0/2.105

 encapsulation dot1Q 105

 bridge-group 105

!

interface BVI105

 ip address 10.105.105.2 255.255.255.252

 ip pim sparse-dense-mode

 ip nat inside

 ip virtual-reassembly in

 ip igmp version 3

!

ip pim bidir-enable

ip nat inside source list 100 interface GigabitEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 10.1.1.1

!

bridge 105 protocol ieee

bridge 105 route ip

!

 

Thanks in advance for any kind of solution!!!! 😊

Everyone's tags (3)
7 REPLIES 7
Highlighted
Hall of Fame Master

Re: Cisco 2921 IPTV Multicast

Hello @jmmgrodrigues ,

if I have correctly understood your configuration Vlan 105 is dedicated to the Set TOP box with a /30 IP subnet and a BVI configured to be the L3 interface to the SET TOP box.

I would suggest to configure ip pim sparse-mode on the WAN interface and BVI105 because IGMPv3 leads to source specific multicast SSM that is actually an optmization of PIM sparse mode.

Then you should verify the state of the (S,G) source group pair using

show ip mroute G

 

show ip mroute active

In addition to all this you must be aware that by default PIM SSM uses for groups IP addresses in the range 232.0.0.0/8.

if this is not the case, if the ISP is using an IP address out of the default SSM range your router config needs to be updated

ip pim ssm  <standard-ACL-number>

 

example:

access-list 44 remark all multicast groups as SSM

access-list 44 permit 224.0.0.0 240.0.0.0

 

ip pim ssm 44

( verify the exact syntax of the command above it may require a keyword before the ACL number like group)

 

Hope to help

Giuseppe

 

 

Highlighted
Collaborator

Re: Cisco 2921 IPTV Multicast

Hi,

 

    I see a mixture of SSM (as you seem to run IGMP v3, if so no RP needed) and bidirectional PIM (which requires RP, but no RP config), but none of he configs are complete. So first question is, what os your deployment, dense or sparse, if it's sparse do you run SSM (no RP) or ASM(RP required), if ASM who is the RP and how do you learn about it?

    Run these debugs: "debug ip fmib pak z.z.z.z (mcast group)", "debug ip igmp z.z.z.z (mcast group)" and "debug ip pim z.z.z.z (mcast group)", attach the client and leave the debugs turned on till the freeze shows up; post the debug outputs and the output of "show ip mroute z.z.z.z" when traffic works and when it stopped working.

 

Regards,

Cristian Matei.

Highlighted
Beginner

Re: Cisco 2921 IPTV Multicast

Hi, Good evenning to all!

Thank you all for your answers! I followed the suggestion of Giuseppe Larosa and created the access-list and the ip pim ssm 44 command. The problem persists. Then I debugged as Cristian Matei said and removed the ip pim bidir-enable command. I don’t know what kind of deployment ISP have. The results:

 

Before turn on Set Top Box

 

HomeRouter#sh ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group,

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,

       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,

       Q - Received BGP S-A Route, q - Sent BGP S-A Route,

       V - RD & Vector, v - Vector, p - PIM Joins on route,

       x - VxLAN group

Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 239.195.1.168), 00:05:36/00:02:06, RP 0.0.0.0, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 239.255.255.250), 00:09:12/00:02:06, RP 0.0.0.0, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 239.195.7.2), 00:09:12/00:02:06, RP 0.0.0.0, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 224.0.1.40), 00:59:35/00:02:52, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/0, Forward/Sparse, 00:59:35/00:02:52

 

 

Debugging

002717: .Mar 25 23:48:18.695 UTC: IGMP(0): Inconsistent setting of Query Interval on GigabitEthernet0/0 with 10.1.1.1 (60 != 20)

002718: .Mar 25 23:48:18.695 UTC: IGMP(0): Received v3 Query on GigabitEthernet0/0 from 10.1.1.1

002719: .Mar 25 23:48:18.695 UTC: IGMP(0): Set report delay to 0.4 seconds to respond to General Query on GigabitEthernet0/0

002720: .Mar 25 23:48:19.115 UTC: IGMP(0): Building v3 Report on GigabitEthernet0/0

002721: .Mar 25 23:48:19.115 UTC: IGMP(0): Add Group Record for 224.0.1.40, type 2

002722: .Mar 25 23:48:19.115 UTC: IGMP(0): Send v3 Report with 1 group records on GigabitEthernet0/0

002723: .Mar 25 23:48:19.115 UTC: IGMP(0): Received v3 Report for 1 group on GigabitEthernet0/0 from 10.1.1.3

002724: .Mar 25 23:48:19.115 UTC: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.1.3 for 0 sources

002725: .Mar 25 23:48:19.115 UTC: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

002726: .Mar 25 23:48:19.115 UTC: IGMP(0): MRT Add/Update GigabitEthernet0/0 for (*,224.0.1.40) by 0

002727: .Mar 25 23:48:38.795 UTC: IGMP(0): Inconsistent setting of Query Interval on GigabitEthernet0/0 with 10.1.1.1 (60 != 20)

002728: .Mar 25 23:48:38.795 UTC: IGMP(0): Received v3 Query on GigabitEthernet0/0 from 10.1.1.1

002729: .Mar 25 23:48:38.795 UTC: IGMP(0): Set report delay to 2.3 seconds to respond to General Query on GigabitEthernet0/0

002730: .Mar 25 23:48:41.115 UTC: IGMP(0): Building v3 Report on GigabitEthernet0/0

002731: .Mar 25 23:48:41.115 UTC: IGMP(0): Add Group Record for 224.0.1.40, type 2

002732: .Mar 25 23:48:41.115 UTC: IGMP(0): Send v3 Report with 1 group records on GigabitEthernet0/0

002733: .Mar 25 23:48:41.115 UTC: IGMP(0): Received v3 Report for 1 group on GigabitEthernet0/0 from 10.1.1.3

002734: .Mar 25 23:48:41.115 UTC: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.1.3 for 0 sources

002735: .Mar 25 23:48:41.115 UTC: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

002736: .Mar 25 23:48:41.115 UTC: IGMP(0): MRT Add/Update GigabitEthernet0/0 for (*,224.0.1.40) by 0

002737: .Mar 25 23:48:58.795 UTC: IGMP(0): Inconsistent setting of Query Interval on GigabitEthernet0/0 with 10.1.1.1 (60 != 20)

002738: .Mar 25 23:48:58.795 UTC: IGMP(0): Received v3 Query on GigabitEthernet0/0 from 10.1.1.1

002739: .Mar 25 23:48:58.795 UTC: IGMP(0): Set report delay to 1.6 seconds to respond to General Query on GigabitEthernet0/0

002740: .Mar 25 23:49:00.415 UTC: IGMP(0): Building v3 Report on GigabitEthernet0/0

002741: .Mar 25 23:49:00.415 UTC: IGMP(0): Add Group Record for 224.0.1.40, type 2

002742: .Mar 25 23:49:00.415 UTC: IGMP(0): Send v3 Report with 1 group records on GigabitEthernet0/0

002743: .Mar 25 23:49:00.415 UTC: IGMP(0): Received v3 Report for 1 group on GigabitEthernet0/0 from 10.1.1.3

002744: .Mar 25 23:49:00.415 UTC: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.1.3 for 0 sources

002745: .Mar 25 23:49:00.415 UTC: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

002746: .Mar 25 23:49:00.415 UTC: IGMP(0): MRT Add/Update GigabitEthernet0/0 for (*,224.0.1.40) by 0

002747: .Mar 25 23:49:06.199 UTC: IGMP(0): Send v3 general Query on BVI105

002748: .Mar 25 23:49:16.207 UTC: IGMP(0): Received Leave from 10.7.7.12 (BVI105) for 239.195.7.2

002749: .Mar 25 23:49:16.207 UTC: IGMP(0): Received Leave from 10.7.7.12 (BVI105) for 239.255.255.250

002750: .Mar 25 23:49:18.795 UTC: IGMP(0): Inconsistent setting of Query Interval on GigabitEthernet0/0 with 10.1.1.1 (60 != 20)

002751: .Mar 25 23:49:18.795 UTC: IGMP(0): Received v3 Query on GigabitEthernet0/0 from 10.1.1.1

002752: .Mar 25 23:49:18.795 UTC: IGMP(0): Set report delay to 1.7 seconds to respond to General Query on GigabitEthernet0/0

002753: .Mar 25 23:49:20.515 UTC: IGMP(0): Building v3 Report on GigabitEthernet0/0

002754: .Mar 25 23:49:20.515 UTC: IGMP(0): Add Group Record for 224.0.1.40, type 2

002755: .Mar 25 23:49:20.515 UTC: IGMP(0): Send v3 Report with 1 group records on GigabitEthernet0/0

002756: .Mar 25 23:49:20.515 UTC: IGMP(0): Received v3 Report for 1 group on GigabitEthernet0/0 from 10.1.1.3

002757: .Mar 25 23:49:20.515 UTC: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.1.3 for 0 sources

002758: .Mar 25 23:49:20.515 UTC: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

002759: .Mar 25 23:49:20.515 UTC: IGMP(0): MRT Add/Update GigabitEthernet0/0 for (*,224.0.1.40) by 0

002760: .Mar 25 23:49:22.683 UTC: IGMP(0): Received v3 Report for 1 group on BVI105 from 10.105.105.1

002761: .Mar 25 23:49:22.683 UTC: IGMP(0): Received Group record for group 239.255.255.250, mode 4 from 10.105.105.1 for 0 sources

002762: .Mar 25 23:49:22.683 UTC: IGMP(0): WAVL Insert group: 239.255.255.250 interface: BVI105Successful

002763: .Mar 25 23:49:22.683 UTC: IGMP(0): Switching to EXCLUDE mode for 239.255.255.250 on BVI105

002764: .Mar 25 23:49:22.683 UTC: IGMP(0): Updating EXCLUDE group timer for 239.255.255.250

002765: .Mar 25 23:49:22.683 UTC: IGMP(0): MRT Add/Update BVI105 for (*,239.255.255.250) by 0

002766: .Mar 25 23:49:22.683 UTC: PIM(0): Building Triggered (*,G) Join / (S,G,RP-bit) Prune message for 239.255.255.250

002767: .Mar 25 23:49:22.887 UTC: IGMP(0): Received v3 Report for 1 group on BVI105 from 10.105.105.1

002768: .Mar 25 23:49:22.887 UTC: IGMP(0): Received Group record for group 239.195.7.2, mode 4 from 10.105.105.1 for 0 sources

002769: .Mar 25 23:49:22.887 UTC: IGMP(0): WAVL Insert group: 239.195.7.2 interface: BVI105Successful

002770: .Mar 25 23:49:22.887 UTC: IGMP(0): Switching to EXCLUDE mode for 239.195.7.2 on BVI105

002771: .Mar 25 23:49:22.887 UTC: IGMP(0): Updating EXCLUDE group timer for 239.195.7.2

002772: .Mar 25 23:49:22.887 UTC: IGMP(0): MRT Add/Update BVI105 for (*,239.195.7.2) by 0

002773: .Mar 25 23:49:22.887 UTC: PIM(0): Building Triggered (*,G) Join / (S,G,RP-bit) Prune message for 239.195.7.2

002774: .Mar 25 23:49:23.559 UTC: IGMP(0): Received v3 Report for 2 groups on BVI105 from 10.105.105.1

002775: .Mar 25 23:49:23.559 UTC: IGMP(0): Received Group record for group 239.195.7.2, mode 4 from 10.105.105.1 for 0 sources

002776: .Mar 25 23:49:23.559 UTC: IGMP(0): Updating EXCLUDE group timer for 239.195.7.2

002777: .Mar 25 23:49:23.559 UTC: IGMP(0): MRT Add/Update BVI105 for (*,239.195.7.2) by 0

002778: .Mar 25 23:49:23.559 UTC: IGMP(0): Received Group record for group 239.255.255.250, mode 4 from 10.105.105.1 for 0 sources

002779: .Mar 25 23:49:23.559 UTC: IGMP(0): Updating EXCLUDE group timer for 239.255.255.250

002780: .Mar 25 23:49:23.559 UTC: IGMP(0): MRT Add/Update BVI105 for (*,239.255.255.250) by 0

002781: .Mar 25 23:49:38.795 UTC: IGMP(0): Inconsistent setting of Query Interval on GigabitEthernet0/0 with 10.1.1.1 (60 != 20)

002782: .Mar 25 23:49:38.795 UTC: IGMP(0): Received v3 Query on GigabitEthernet0/0 from 10.1.1.1

002783: .Mar 25 23:49:38.795 UTC: IGMP(0): Set report delay to 0.8 seconds to respond to General Query on GigabitEthernet0/0

002784: .Mar 25 23:49:39.615 UTC: IGMP(0): Building v3 Report on GigabitEthernet0/0

002785: .Mar 25 23:49:39.615 UTC: IGMP(0): Add Group Record for 224.0.1.40, type 2

002786: .Mar 25 23:49:39.615 UTC: IGMP(0): Send v3 Report with 1 group records on GigabitEthernet0/0

002787: .Mar 25 23:49:39.615 UTC: IGMP(0): Received v3 Report for 1 group on GigabitEthernet0/0 from 10.1.1.3

002788: .Mar 25 23:49:39.615 UTC: IGMP(0): Received Group record for group 224.0.1.40, mode 2 from 10.1.1.3 for 0 sources

002789: .Mar 25 23:49:39.615 UTC: IGMP(0): Updating EXCLUDE group timer for 224.0.1.40

002790: .Mar 25 23:49:39.615 UTC: IGMP(0): MRT Add/Update GigabitEthernet0/0 for (*,224.0.1.40) by 0

 

 

Broadcasting

 

HomeRouter#sh ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group,

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,

       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,

       Q - Received BGP S-A Route, q - Sent BGP S-A Route,

       V - RD & Vector, v - Vector, p - PIM Joins on route,

       x - VxLAN group

Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 239.195.1.168), 00:09:17/00:00:54, RP 0.0.0.0, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 239.195.1.135), 00:01:44/00:01:16, RP 0.0.0.0, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 239.255.255.250), 00:12:53/00:02:36, RP 0.0.0.0, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    BVI105, Forward/Sparse, 00:00:24/00:02:36

 

(*, 239.195.7.2), 00:12:53/00:02:36, RP 0.0.0.0, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    BVI105, Forward/Sparse, 00:00:24/00:02:36

 

(*, 224.0.1.40), 01:03:16/00:02:52, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    GigabitEthernet0/0, Forward/Sparse, 01:03:16/00:02:52

 

 

Freeze

HomeRouter#sh ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group,

       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,

       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,

       Q - Received BGP S-A Route, q - Sent BGP S-A Route,

       V - RD & Vector, v - Vector, p - PIM Joins on route,

       x - VxLAN group

Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 239.195.1.168), 00:09:28/00:00:43, RP 0.0.0.0, flags: SP

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list: Null

 

(*, 239.195.1.135), 00:01:54/00:02:50, RP 0.0.0.0, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    BVI105, Forward/Sparse, 00:00:10/00:02:50

 

(*, 239.255.255.250), 00:13:03/00:02:25, RP 0.0.0.0, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    BVI105, Forward/Sparse, 00:00:35/00:02:25

 

(*, 239.195.7.2), 00:13:04/00:02:25, RP 0.0.0.0, flags: SJC

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    BVI105, Forward/Sparse, 00:00:34/00:02:25

 

(*, 224.0.1.40), 01:03:27/00:02:41, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

Highlighted
Collaborator

Re: Cisco 2921 IPTV Multicast

Hi,

 

     From the logs, you get IGMP v3 Report from the multicast receiver which is 10.105.105.1 for 2 multicast groups (

239.255.255.250 and 239.195.7.2), but with no source specified, so you can't use SSM, you're using ASM and for this to work you need an RP, which most probably you don't, so the router prunes the mcast tree:

 

002760: .Mar 25 23:49:22.683 UTC: IGMP(0): Received v3 Report for 1 group on BVI105 from 10.105.105.1

002761: .Mar 25 23:49:22.683 UTC: IGMP(0): Received Group record for group 239.255.255.250, mode 4 from 10.105.105.1 for 0 sources

002765: .Mar 25 23:49:22.683 UTC: IGMP(0): MRT Add/Update BVI105 for (*,239.255.255.250) by 0

002766: .Mar 25 23:49:22.683 UTC: PIM(0): Building Triggered (*,G) Join / (S,G,RP-bit) Prune message for 239.255.255.250

 

 

 

002767: .Mar 25 23:49:22.887 UTC: IGMP(0): Received v3 Report for 1 group on BVI105 from 10.105.105.1

002768: .Mar 25 23:49:22.887 UTC: IGMP(0): Received Group record for group 239.195.7.2, mode 4 from 10.105.105.1 for 0 sources

002769: .Mar 25 23:49:22.887 UTC: IGMP(0): WAVL Insert group: 239.195.7.2 interface: BVI105Successful

002773: .Mar 25 23:49:22.887 UTC: PIM(0): Building Triggered (*,G) Join / (S,G,RP-bit) Prune message for 239.195.7.2

 

  Can you post the output of the following commands: "show ip pim rp mapping", "show ip pim autoarp", "show ip igmp membership"?

  Can you configure the multicast receiver for SSM, to request traffic from a specific source, so that (S,G) trees are built? But in order to run SSM, also your upstream provider needs to run SSM. If not, for ASM, he needs to give you RP information for the (*,G) tree to be build up to the RP.

  

Regards,

Cristian Matei.

Highlighted
Beginner

Re: Cisco 2921 IPTV Multicast

Hi,

Thanks for your reply.

Once my Cisco Router is connected to ISP Router, the RP is the LAN IP of ISP Router right? (or wrong?)

I've removed the SSM configuration (but saved in file just in case :)) and now it is in ASM (I think).

I attached entire configuration file for your analysis.

The output I have with this (file) configuration is:

 

HomeRouter#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s): 224.0.0.0/4, Static
RP: 10.1.1.1 (?)
HomeRouter#sh ip pim aur
HomeRouter#sh ip pim aut
HomeRouter#sh ip pim autorp
AutoRP Information:
AutoRP is enabled.
RP Discovery packet MTU is 0.
224.0.1.40 is joined on BVI105.
AutoRP groups over sparse mode interface is enabled

PIM AutoRP Statistics: Sent/Received
RP Announce: 0/0, RP Discovery: 0/0
HomeRouter#sh ip igmp
HomeRouter#sh ip igmp mem
HomeRouter#sh ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude

Channel/Group Reporter Uptime Exp. Flags Interface
*,239.195.1.187 10.105.105.1 00:04:21 00:40 3A BV105
*,239.255.255.250 10.105.105.1 00:18:45 00:40 3A BV105
*,239.195.7.2 10.105.105.1 00:18:45 00:52 3A BV105
*,224.0.1.40 10.105.105.2 00:45:29 00:59 3LA BV105

 

Please, if there's any help I will aprecciate. I'm looking for a solution for a long time.... Thanks in advance!

Highlighted
Collaborator

Re: Cisco 2921 IPTV Multicast

Hi,

 

    You need to know who the RP is, as otherwise, when the (*,G) tree is being build, if two PIM neighbours have different RP for the same group, the (*,G) tree is pruned to avoid loops. So you need to know from your provider how is this supposed to work, via ASM (what is the RP), via SSM (who is the sender).

   Unplug the receiver, enable the following debugs, reconnect the receiver, and post the output (ensure to catch the complete output, otherwise is irrelevant).

 

debug ip pim 239.195.7.2

debug ip pim 239.255.255.250

debug ip mfib pak 239.195.7.2

debug ip mfib pak 239.255.255.250

debug ip igmp 239.195.7.2

debug ip igmp 239.255.255.250

 

Regards,

Cristian Matei.

Highlighted
VIP Mentor

Re: Cisco 2921 IPTV Multicast

Hello

You show a pim rp address of 10.1.1.1 and tha RP host looks like it residing via your egress wan interface, You also show to  have NAT enabled but no nat statements applied so if nat isnt working then your upstream rtr needs to know how to reach your lan subnet and that means via either static or dyanmic routing but so first of all can you reach the RP 10.1.1.1.


Does the upstream rtrs have Multicast enabled?

ping 10.1.1.1
sh ip pimt interface count
sh ip pim interface
sh ip pim niegbour


Lasty try applying sparse-dense mode pim on your interface instead.

int x/x
ip pim sparse-dense-mode



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future