cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1094
Views
0
Helpful
2
Replies

Cisco 7600 cannot get bgp keepalives

akgun.ozsoy
Beginner
Beginner

I am trying to establish a BGP session between a Cisco 7600 and Juniper MX960, but this always stucks in OpenConfirm state.

access-4#show ip bgp v v VRF1 neighbors 166.63.168.197
BGP neighbor is 166.63.168.197,  vrf VRF1,  remote AS 5555,  local AS 65533, external link
  BGP version 4, remote router ID 195.2.1.21
  BGP state = OpenConfirm
  Last read 00:02:27, last write 00:02:27, hold time is 180, keepalive interval is 60 seconds
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  4          4
    Notifications:          2          1
    Updates:                0          0
    Keepalives:             4          0
    Route Refresh:          0          0
    Total:                 10          5
  Default minimum time between advertisement runs is 30 seconds

debugging tcp packets

May 12 13:58:07.531 bst:     TCP src=54912, dst=179, seq=1766275951, ack=1681278050, win=17520 ACK PSH
May 12 13:58:07.535 bst: IP: tableid=2, s=166.63.168.198 (local), d=166.63.168.197 (Vlan20), routed via FIB
May 12 13:58:53.883 bst: IP: tableid=2, s=166.63.168.198 (local), d=166.63.168.197 (Vlan20), routed via FIB
May 12 13:58:59.359 bst: IP: s=166.63.168.197 (Vlan20), d=166.63.168.198, len 61, rcvd 2
May 12 13:58:59.359 bst:     TCP src=54912, dst=179, seq=1766276010, ack=1681278050, win=17520 ACK PSH FIN
May 12 13:58:59.359 bst: IP: tableid=2, s=166.63.168.198 (local), d=166.63.168.197 (Vlan20), routed via FIB
May 12 13:58:59.359 bst: %BGP-3-NOTIFICATION: received from neighbor 166.63.168.197 4/0 (hold time expired) 0 bytes

ICMP works fine.

It is same on JUniper end. Sending keepalives but cannot receive

###interface config
interface Vlan20
ip vrf forwarding VRF1
ip address 166.63.168.198 255.255.255.252
no ip redirects
no ip proxy-arp
load-interval 30
end

###bgp config

neighbor 166.63.168.197 remote-as 5555
neighbor 166.63.168.197 local-as 65533
neighbor 166.63.168.197 ebgp-multihop 5
neighbor 166.63.168.197 update-source Vlan20
neighbor 166.63.168.197 activate
neighbor 166.63.168.197 soft-reconfiguration inbound

2 Replies 2

hbruyere
Cisco Employee
Cisco Employee

Hello,

Maybe a mtu issue causing updates to be dropped?

For a quick check disable bgp path mtu discovery so that the bgp mss falls back to 536 bytes:

router bgp x

no bgp transport path-mtu-discovery

Regards,

Herve

ssheorai
Beginner
Beginner

Hi ,

 

I faced a similar issue. My ISP upgraded their Junos router OS and the bgp peering was not coming up. They did shut -unshut and session clearing but to no avail. But when we re-configured BGP on our Cisco 7609 for the VRF neighbor peering came up. So want to know what could be the reason for this.

 

Any help or suggestion welcome.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers