cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
772
Views
0
Helpful
5
Replies

Cisco 800 behind Providers Router

silvakizir
Level 1
Level 1

Hi.

I have a Providers Router and a Cisco 886 Router.

I want for some reason to have the RJ11 DSL Cable connected with the Providers Router and then I want to connect an RJ45 cable from the Providers Router to my Cisco 886 Router.

I've set the Providers Router to be pass through and I want the Cisco 886 to negotiate the public IP with the provider and have the VDSL connection on it through the FastEthernet3 port and the RJ45 Cable.

 

I have the below configuration done.

Can anyone confirm if this will work. If not what should I change?

 

 

controller VDSL 0

!

interface FastEthernet0
description *** LAN ***
no ip address
!
interface FastEthernet1
description *** LAN ***
no ip address
!
interface FastEthernet2
description *** LAN ***
no ip address
!
interface FastEthernet3
description *** PPPOE interface ***
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1

!

interface Vlan1
ip address 10.0.0.0 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer1
description *** VDSL Connection ***
mtu 1492
ip address negotiated
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname xxx@xxx
ppp chap password 0 yyyy
ppp pap sent-username xxx@xxx password 0 yyyy
crypto map CMAP

!

ip nat inside source list xxxxxx interface Dialer1 overload

5 Replies 5

Hello,

 

if the ISP modem is in bridge mode, this should work. Is this the full configiuration (I see a crypto map on the dialer, you might want to remove that) ? Make sure the lines marked in bold are in your config:

 

controller VDSL 0

!

interface FastEthernet0
description *** LAN ***
no ip address
!
interface FastEthernet1
description *** LAN ***
no ip address
!
interface FastEthernet2
description *** LAN ***
no ip address
!
interface FastEthernet3
description *** PPPOE interface ***
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1

!

interface Vlan1
ip address 10.0.0.0 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer1
description *** VDSL Connection ***
mtu 1492
ip address negotiated
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname xxx@xxx
ppp chap password 0 yyyy
ppp pap sent-username xxx@xxx password 0 yyyy
--> no crypto map CMAP

!

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 10.0.0.0 0.0.0.255

!

ip route 0.0.0.0 0.0.0.0 Dialer 1

Thanks for your time.

Yes I also have the lines in bold.

I've also configured a site to site vpn, that is why you see a CMAP under Dialer1.

I just wanted to concentrate to the DSL part and I put only the specific commands.

 

Hello,

 

so does your dialer get a public IP address ?

I will install it and I will inform you.

Hello

Could possibly append a default route to the dialer interlace aprt from that looks okay.

ip route 0.0.0.0 0.0.0.0 Dialer1


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco