cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
102632
Views
7
Helpful
29
Replies
Beginner

Cisco 800 series router configuration for beginners

I have just bought my first non-domestic router, a CISCO 887VA-K9 which needs basic configuration to get it working.  I have a copy of the configuration guide (334 pages) and CP Express user's guide (94 pages) and have spent an hour reading but either they are missing something or my brain is too small to figure out step 1.  Would some kind soul please just give me a clue how to get started.  Perhaps from where to download a CP Express installation kit for Windows.

Is the only way via a terminal emulator connected via a serial port ?  Is there a graphical interface I can use ?  Are there any basic tutorials for beginners ?  This is probably the only non-domestic routrer I shall work on so I don't want to invest in a full training course.  I just need enough to plug in the ISP credentials and set up DHCP.

29 REPLIES 29
Hall of Fame Community Legend

Cisco 800 series router configuration for beginners

Contact your DSL provider and ask for a copy of their configuration.  All ISPs support Cisco routers so there's a significant chance the ISP have recommended configuration settings that you can use. 

Beginner

Cisco 800 series router configuration for beginners

Oh please.  I am well aware of what to enter in terms of the ISP credentials and settings having set up scores of domestic routers.  My problem is in how to run the application (presumably CPE) that allows me to enter the details.  I need an installation program to run or an IP address to point my browser at.

Advisor

Cisco 800 series router configuration for beginners

Hi,

Is this a new device or a used one ?  if it's new I reckon it must have dhcp service enabled and if you connect a PC with

a terminal like Putty and choose telnet and enter the IP of the router you should access the CLI and start entering commands. to find out the address of the router it should be in the guides you've got otherwise do ipconfig to see the IP your PC got and then ping the broadcast address and you should have a reply from the router.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Cisco 800 series router configuration for beginners

Thanks for tha Alain.  This is a new device.  I have not tried to connect with a terminal server as I thought there must be an easier way.  I suspect DHCP is not enabled as I have connected it to a Windows PC with Ethernet and IPCONFIG does not yield any IP addrress. I have not seen a note of the device's IP address anywhere on it or the documentation - although I have not read it cover to cover.

Advisor

Cisco 800 series router configuration for beginners

Hi,

ok then use the console cable provided( the blue one) and connect to PC either to COM port if you've got serial port or with a USB-serial converter to USB port.fire up hyperterminal or putty( raw connection) with following settings:

Bits per second    :  9600

Data bits       :     8

Parity          :  none

Stop bits       :     1

Flow control    :  none

if you're asked for username/password try cisco/cisco

type show run and paste output here

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

Cisco 800 series router configuration for beginners

Thanks again.  I have hooked up the the blue cable to the COM1 port of a PC on which Putty is installed.  All settings mentioned above were set but when I hit the 'open' button my only reward was a beep.  No error message or other indication what the issue is.  In case others come here later, I had to set the connection type to serial in the session settings. 

Now I have been able to get CLI access to the router.  At least I can now work through the extensive documentation but I am really in over my head here.  I was hoping for a nice GUI that let me put in the basic credentials, just like domestic routers.

Contributor

Re: Cisco 800 series router configuration for beginners

Hi Eugene,

open your browser and type the ip address that you have configured below your FastEthernet interface:

enable

conf t

int fa0/1

ip address 1.1.1.1 255.255.255.0

no sh

end

wr

!

conf t

ip http server

ip http authentication local

user admin password mypassw0rd

end

wr

!

open internet explorer or firefox and on the address bar type:

http://1.1.1.1

Hope you enjoy this GUI

Alessio

Beginner

Cisco 800 series router configuration for beginners

Thanks Eugene and Alain....

Now, I have been able to use the Putty to enter the CLI interface of my router. After running the initial configuration setup, what is the next step?

My router cannot dispense IP address to a computer connected to it. Please can anyone help me so that my CISCO 887 router would work as a DHCP server.

Rising star

Cisco 800 series router configuration for beginners

Hi

Here is config with nice explanation of configuration of DHCP server on cisco.

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/812-cisco-router-dhcp-config.html

Best Regards

Please rate helpful posts

Best Regards Please rate all helpful posts and close solved questions
Beginner

Re: Cisco 800 series router configuration for beginners

Thanks Blau

I have gone through that process (although i was made to understand that cisco 887 has dhcp activated by default), connected a computer to the router's FE interface but was unable to obtain an IP. how can I complete the configuration of the router from a web browser since my computer was unable to obtain an Ip address from my new router.

Rising star

Re: Cisco 800 series router configuration for beginners

Can you post dhcp configuration on your router?

Also attach configuration of port where you connected PC, if that port is L2 port then attach configuration of respective VLAN interface.

Best Regards

Please rate helpful posts

Best Regards Please rate all helpful posts and close solved questions
Beginner

Cisco 800 series router configuration for beginners

Router#shpw running-config

         ^

% Invalid input detected at '^' marker.

Router#show running-config

Building configuration...

Current configuration : 896 bytes

!

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

memory-size iomem 10

!

!

ip auth-proxy max-login-attempts 5

ip admission max-login-attempts 5

!

--More--

*Mar  2 04:24:46.107: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed s!        p

!

!

!

ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-K9 sn FCZ1635C3HC

!

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

no ip address

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

!

end

Rising star

Cisco 800 series router configuration for beginners

Hi Dubem

Yes, I saw that some routers was delivered with default configuration where DHCP server was configured, but as I can see your configuration is absolutely clear.

So here is step-by-step how to configure DHCP server on cisco router.

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/812-cisco-router-dhcp-config.html

Do not forget to configure IP address on interfaces of your router to allow DHCP to provide IP addreses to hosts on that segment.

Best Regards

Please rate helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
Beginner

Cisco 800 series router configuration for beginners

Thanks grana.

I was able to configure DHCP and LAN computers can receive IP. However, I have been unable to access the internet.

The internet cable is plugged into the FE WAN (4) port while the LAN is connected to FE LAN 0.

I used SETUP on console to assign 192.168.0.1 Ip to the router but i cannot still access the router through the web browser.

The SMNP did not configure successfully because I was required to use SNMPV3.

Please help me with support that can get me connected to the internet and allow me continue the router's configuration through a web browser.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards