cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1901
Views
5
Helpful
10
Replies

Cisco 819 Router with 3G connection issue

m1xed0s
Spotlight
Spotlight

Hi, Need help regarding getting the 819 router connecting to the ISP 3G network.  The configure is at the bottom.

I called ISP tech support but they told me the SIM is activated and should be good.

But everytime I "start-chat", I got connection timeout and remote host not responding... Any idea?


boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
clock timezone AST -4 0
clock summer-time ADT recurring
service-module wlan-ap 0 bootimage autonomous
!
ip dhcp excluded-address 10.10.10.1 10.10.10.100
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.128
default-router 10.10.10.1
dns-server 8.8.8.8
lease 0 2
!
!
!
no ip domain lookup
ip domain name onewindinc.com
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
chat-script hspa-R7 "" "ATDT*99*1#" TIMEOUT 30 "CONNECT"
!
cts logging verbose
license udi pid C819HGW+7-A-A-K9 sn FTX1930806P
!
controller Cellular 0
gsm sim max-retry 65535
gsm failovertimer 3
no cdp run
!
ip ssh version 2
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string hspa-R7
dialer-group 1
async mode interactive
routing dynamic
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Wlan-GigabitEthernet0
no ip address
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan1
!
interface Vlan1
description DefaultLAN
ip address 10.10.10.1 255.255.255.128
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list MyNAT interface Cellular0 overload
!
ip access-list standard MyNAT
permit any
!
dialer-list 1 protocol ip list 1
!
access-list 1 permit any
access-list 23 permit 10.10.10.0 0.0.0.127

!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
exec-timeout 0 0
script dialer hspa-R7
login
modem InOut
no exec
transport input all
line vty 0 4
access-class 23 in
privilege level 15
logging synchronous
login local
transport input ssh
line vty 5 15
access-class 23 in
privilege level 15
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp server 199.182.221.110
!
end

r01#sh cellular 0 profile 1
Profile password Encryption level: 7


Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = isp.telus.com
Authentication = None
Username:
Password: 08

* - Default profile

r01#sh cellular 0 network
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSPA (Attached)
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = CAN, Network = TELUS
Mobile Country Code (MCC) = 302
Mobile Network Code (MNC) = 220
Location Area Code (LAC) = 10800
Routing Area Code (RAC) = 184
Cell ID = 57810
Primary Scrambling Code = 97
PLMN Selection = Automatic
Registered PLMN = TELUS , Abbreviated =
Service Provider =

This is with Telus in Canada.

10 Replies 10

Philip D'Ath
VIP Alumni
VIP Alumni

I think your router has a 4G radio in it, and you are applying a 3G config.  Try something more like:

chat-script telus "" "AT!CALL" TIMEOUT 20 "OK"

interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer string telus
 dialer-group 1

line 3
script dialer telus
modem InOut

You also need:

ip route 0.0.0.0 0.0.0.0 Cellular0 permanent

This doesnot improve the cellullar connection though.

According to cisco data sheet, 819 only has gsm 3G modem I think.

Would the output of show inventory clarify which modem is installed?

HTH

Rick

HTH

Rick

NAME: "C819HGW+7-A-A-K9", DESCR: "C819HGW+7-A-A-K9 chassis, Hw Serial#: FTX1930806P, Hw Revision: 6.0"
PID: C819HGW+7-A-A-K9 , VID: V01 , SN: FTX1930806P

NAME: "C819HGW Mother board on Slot 0", DESCR: "C819HGW Mother board"
PID: C819HGW+7-A-A-K9 , VID: V01 , SN: FOC19252JD4

NAME: "Modem 0 on Cellular0", DESCR: "Sierra Wireless Mini Card MC8705 HSPA+R7-A modem"
PID: MC8705-A , VID: 1.0, SN: 357115042050752

Thanks for posting the output of show inventory. According to this link theSierra Wireless Mini Card MC8705 HSPA+R7 modem.  is indeed a 3G radio.

http://www.cisco.com/c/en/us/td/docs/routers/access/800/819/software/configuration/Guide/819_SCG/2wireless_overview.html

What do you get as output to the command show controllers cellular 0?

HTH

Rick

HTH

Rick

The issue I had was not able to get IP from ISP via the Cellular connection. 

m1xed0s
Spotlight
Spotlight

I think I have the "issue" fixed now. I had to factory-reset the router and re-do the configure as a persistent dial-up connection via cellular, which is not the one Cisco shares in the guide...Some relevant config below. However the issue now is the speed...maybe it is just the nature of 3G...

interface Cellular0
description PrimaryWAN
no ip address
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer pool-member 1
dialer-group 1
no peer default ip address
async mode interactive
!

interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string hspa-R7
dialer persistent
dialer-group 1

!

dialer-list 1 protocol ip permit

chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 30 "OK"

line 3
script dialer hspa-R7
modem InOut
no exec
transport input all
transport output all

The funny part I found: the chat-script doesnot matter...I can use the one come with the router OR "ATDT*99*1#" as telus tech mentioned, The dial-up interface will be up and getting IP address.

Thanks for posting back to the forum and letting us know that you have fixed the issue. Sometimes a reset and a fresh start on the config does resolve problems and I am glad that you were able to try a different approach in the config which does allow the router to get an IP address and to have connectivity.

HTH

Rick

HTH

Rick
Review Cisco Networking products for a $25 gift card