cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
226
Views
0
Helpful
15
Replies

Cisco 819g-4g not connect to service provider

tikshoret
Beginner
Beginner

Hi 

I have cisco 819g-4g when i install sim 4g and config the apn it didnt connect to the service provider 

If i take the same sim and config on asr1000 with the same configuration  its works 

What can be the problem?

The 819g come with modem sierra mc77100

Thanks

 

 

 

15 REPLIES 15

MHM Cisco World
Advisor
Advisor

can we see the config?

show ver
Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.3(3)M1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2013 by Cisco Systems, Inc.
Compiled Tue 22-Oct-13 05:46 by prod_rel_team

ROM: System Bootstrap, Version 15.2(2r)T, RELEASE SOFTWARE (fc1)

Router uptime is 56 minutes
System returned to ROM by power-on
System image file is "flash:c800-universalk9-mz.SPA.153-3.M1.bin"
Last reload type: Normal Reload
Last reload reason: power-on

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco C819G-4G-G-K9 (revision 6.0) with 883788K/33715K bytes of memory.
Processor board ID FCZ172594AG
4 FastEthernet interfaces
1 Gigabit Ethernet interface
1 Serial(sync/async) interface
2 terminal lines
1 Virtual Private Network (VPN) Module
1 Cellular interface
1 cisco Embedded AP (s)
DRAM configuration is 32 bits wide
255K bytes of non-volatile configuration memory.
999936K bytes of ATA System CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device# PID SN
------------------------------------------
*0 C819G-4G-G-K9 FCZ172594AG

 

License Information for 'c800'
License Level: advipservices Type: Permanent
Next reboot license Level: advipservices


Configuration register is 0x2102

Router# show run
Building configuration...
WLAN_AP_SM: Config command is not supported

Current configuration : 2126 bytes
!
! Last configuration change at 02:19:49 UTC Mon Aug 1 2022
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service password-recovery
!
hostname Router
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
!
!
!
!
!
license udi pid C819G-4G-G-K9 sn FCZ172594AG
!
!
vtp mode transparent
!
!
!
!
!
controller Cellular 0
!
vlan 20
name xxx
!
vlan 1000
name xxx
!
!
!
!
!
!
!
!
!
!
!
interface Cellular0
ip address negotiated
no ip unreachables
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer watch-group 1
dialer-group 1
async mode interactive
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0
ip nat inside
no autostate
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 101 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer watch-list 1 ip 192.168.1.254 0.0.0.255
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
dialer-list 1 protocol ip permit
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
script dialer lte
modem always-on
no exec
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

turn om debugging and post the output:

debug modem
debug dialer
debug cellular 0 messages call control

*Aug 1 02:36:04.283: CHAT3: Chat script lte started
Router#show deb
Router#show debugging
General OS:
Modem control/process activation debugging is on
Dial on demand:
Dial on demand events debugging is on
CELLULAR:
CALLCONTROL debugging is on

 


Router#
*Aug 1 02:36:16.015: TTY0: pause timer type 1 (OK)
*Aug 1 02:36:16.015: TTY0: resume timer type 1 (OK)ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Aug 1 02:36:24.155: TTY0: pause timer type 1 (OK)
*Aug 1 02:36:24.283: CHAT3: Chat script lte finished, status = Connection timed out; remote host not responding
*Aug 1 02:36:24.283: TTY3: Line reset by "Async dialer"
*Aug 1 02:36:24.283: Ce0 DDR: disconnecting call
*Aug 1 02:36:24.283: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:36:24.283: TTY3: no timer type 0 to destroy
*Aug 1 02:36:24.283: TTY3: no timer type 1 to destroy
*Aug 1 02:36:24.283: TTY3: no timer type 3 to destroy
*Aug 1 02:36:24.283: TTY3: no timer type 4 to destroy
*Aug 1 02:36:24.283: TTY3: no timer type 10 to destroy
*Aug 1 02:36:24.283: TTY3: no timer type 2 to destroy.
*Aug 1 02:36:24.819: TTY3: dropping DTR, hanging up
*Aug 1 02:36:24.819: tty3: Modem: HANGUP->IDLE..
*Aug 1 02:36:29.819: TTY3: restoring DTR
*Aug 1 02:36:30.819: TTY3: Always-on modem
*Aug 1 02:36:30.819: tty3: Modem: IDLE->READY..
Success rate is 0 percent (0/5)
Router#show in
*Aug 1 02:36:34.155: TTY0: resume timer type 1 (OK)t vl 1
Vlan1 is up, line protocol is up
Hardware is EtherSVI, address is 20bb.c041.85e0 (bia 20bb.c041.85e0)
Internet address is 192.168.1.254/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
4 packets output, 240 bytes, 0 underruns
0 output errors, 1 interface resets
0 unknown protocol
*Aug 1 02:36:36.799: TTY0: pause timer type 1 (OK)
*Aug 1 02:36:36.799: TTY0: resume timer type 1 (OK) drops
0 output buffer failures, 0 output buffers swapped out
Router#
*Aug 1 02:36:39.283: Ce0 DDR: re-enable timeout
*Aug 1 02:36:39.283: DDR: Dialer Watch: watch-group = 1
*Aug 1 02:36:39.283: DDR: network 192.168.1.254/0.0.0.255 DOWN,
*Aug 1 02:36:39.283: DDR: primary DOWN
*Aug 1 02:36:39.283: Ce0 DDR: Attempting to dial lte
*Aug 1 02:36:39.283: CHAT3: Attempting async line dialer script
*Aug 1 02:36:39.283: CHAT3: Dialing using Modem script: lte & System script: none
*Aug 1 02:36:39.283: CHAT3: process started
*Aug 1 02:36:39.283: CHAT3: Asserting DTR
*Aug 1 02:36:39.283: CHAT3: Chat script lte started
*Aug 1 02:36:53.363: CHAT3: Chat script lte finished, status = Carrier dropped
*Aug 1 02:36:53.363: TTY3: Line reset by "Async dialer"
*Aug 1 02:36:53.363: Ce0 DDR: disconnecting call
*Aug 1 02:36:53.363: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:36:53.363: TTY3: no timer type 0 to destroy
*Aug 1 02:36:53.363: TTY3: no timer type 1 to destroy
*Aug 1 02:36:53.363: TTY3: no timer type 3 to destroy
*Aug 1 02:36:53.363: TTY3: no timer type 4 to destroy
*Aug 1 02:36:53.363: TTY3: no timer type 10 to destroy
*Aug 1 02:36:53.363: TTY3: no timer type 2 to destroy
*Aug 1 02:36:53.819: TTY3: dropping DTR, hanging up
*Aug 1 02:36:53.819: tty3: Modem: HANGUP->IDLE
*Aug 1 02:36:58.819: TTY3: restoring DTR
*Aug 1 02:36:59.819: TTY3: Always-on modem
*Aug 1 02:36:59.819: tty3: Modem: IDLE->READY
*Aug 1 02:37:00.879: %CISCO800-6-SIM_STATUS: SIM in slot 1 is present
Router#
Router#
*Aug 1 02:37:08.363: Ce0 DDR: re-enable timeout
*Aug 1 02:37:08.363: DDR: Dialer Watch: watch-group = 1
*Aug 1 02:37:08.363: DDR: network 192.168.1.254/0.0.0.255 DOWN,
*Aug 1 02:37:08.363: DDR: primary DOWN
*Aug 1 02:37:08.363: Ce0 DDR: Attempting to dial lte
*Aug 1 02:37:08.363: CHAT3: Attempting async line dialer script
*Aug 1 02:37:08.363: CHAT3: Dialing using Modem script: lte & System script: none
*Aug 1 02:37:08.363: CHAT3: process started
*Aug 1 02:37:08.363: CHAT3: Asserting DTR
*Aug 1 02:37:08.363: CHAT3: Chat script lte started
*Aug 1 02:37:28.363: CHAT3: Chat script lte finished, status = Connection timed out; remote host not responding
*Aug 1 02:37:28.363: TTY3: Line reset by "Async dialer"
*Aug 1 02:37:28.363: Ce0 DDR: disconnecting call
*Aug 1 02:37:28.363: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:37:28.363: TTY3: no timer type 0 to destroy
*Aug 1 02:37:28.363: TTY3: no timer type 1 to destroy
*Aug 1 02:37:28.363: TTY3: no timer type 3 to destroy
*Aug 1 02:37:28.363: TTY3: no timer type 4 to destroy
*Aug 1 02:37:28.363: TTY3: no timer type 10 to destroy
*Aug 1 02:37:28.363: TTY3: no timer type 2 to destroy
*Aug 1 02:37:28.819: TTY3: dropping DTR, hanging up
*Aug 1 02:37:28.819: tty3: Modem: HANGUP->IDLE
*Aug 1 02:37:33.819: TTY3: restoring DTR
*Aug 1 02:37:34.819: TTY3: Always-on modem
*Aug 1 02:37:34.819: tty3: Modem: IDLE->READY
*Aug 1 02:37:36.759: %CISCO800-2-MODEM_UP: Cellular0 modem is now UP.
*Aug 1 02:37:37.035: %CISCO800-6-SIM_STATUS: SIM in slot 0 is not present
*Aug 1 02:37:38.139: %CISCO800-2-MODEM_DOWN: Cellular0 modem is now DOWN.
*Aug 1 02:37:43.363: Ce0 DDR: re-enable timeout
*Aug 1 02:37:43.363: DDR: Dialer Watch: watch-group = 1
*Aug 1 02:37:43.363: DDR: network 192.168.1.254/0.0.0.255 DOWN,
*Aug 1 02:37:43.363: DDR: primary DOWN
*Aug 1 02:37:43.363: Ce0 DDR: Attempting to dial lte
*Aug 1 02:37:43.363: CHAT3: Attempting async line dialer script
*Aug 1 02:37:43.363: CHAT3: Dialing using Modem script: lte & System script: none
*Aug 1 02:37:43.363: CHAT3: process started
*Aug 1 02:37:43.363: CHAT3: Asserting DTR
*Aug 1 02:37:43.363: CHAT3: Chat script lte started
*Aug 1 02:37:48.035: %CISCO800-6-SIM_ACTIVATION: SIM in slot 1 is being activated. Please wait for modem to come UP.
*Aug 1 02:38:03.363: CHAT3: Chat script lte finished, status = Connection timed out; remote host not responding
*Aug 1 02:38:03.363: TTY3: Line reset by "Async dialer"
*Aug 1 02:38:03.363: Ce0 DDR: disconnecting call
*Aug 1 02:38:03.363: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:38:03.363: TTY3: no timer type 0 to destroy
*Aug 1 02:38:03.363: TTY3: no timer type 1 to destroy
*Aug 1 02:38:03.363: TTY3: no timer type 3 to destroy
*Aug 1 02:38:03.363: TTY3: no timer type 4 to destroy
*Aug 1 02:38:03.363: TTY3: no timer type 10 to destroy
*Aug 1 02:38:03.363: TTY3: no timer type 2 to destroy
*Aug 1 02:38:03.819: TTY3: dropping DTR, hanging up
*Aug 1 02:38:03.819: tty3: Modem: HANGUP->IDLE
*Aug 1 02:38:08.819: TTY3: restoring DTR
*Aug 1 02:38:09.819: TTY3: Always-on modem
*Aug 1 02:38:09.819: tty3: Modem: IDLE->READY
*Aug 1 02:38:12.915: %CISCO800-2-MODEM_UP: Cellular0 modem is now UP.
*Aug 1 02:38:18.363: Ce0 DDR: re-enable timeout
*Aug 1 02:38:18.363: DDR: Dialer Watch: watch-group = 1
*Aug 1 02:38:18.363: DDR: network 192.168.1.254/0.0.0.255 DOWN,
*Aug 1 02:38:18.363: DDR: primary DOWN
*Aug 1 02:38:18.363: Ce0 DDR: Attempting to dial lte
*Aug 1 02:38:18.363: CHAT3: Attempting async line dialer script
*Aug 1 02:38:18.363: CHAT3: Dialing using Modem script: lte & System script: none
*Aug 1 02:38:18.363: CHAT3: process started
*Aug 1 02:38:18.363: CHAT3: Asserting DTR
*Aug 1 02:38:18.363: CHAT3: Chat script lte started
*Aug 1 02:38:38.363: CHAT3: Chat script lte finished, status = Connection timed out; remote host not responding
*Aug 1 02:38:38.363: TTY3: Line reset by "Async dialer"
*Aug 1 02:38:38.363: Ce0 DDR: disconnecting call
*Aug 1 02:38:38.363: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:38:38.363: TTY3: no timer type 0 to destroy
*Aug 1 02:38:38.363: TTY3: no timer type 1 to destroy
*Aug 1 02:38:38.363: TTY3: no timer type 3 to destroy
*Aug 1 02:38:38.363: TTY3: no timer type 4 to destroy
*Aug 1 02:38:38.363: TTY3: no timer type 10 to destroy
*Aug 1 02:38:38.363: TTY3: no timer type 2 to destroy
*Aug 1 02:38:38.819: TTY3: dropping DTR, hanging up
*Aug 1 02:38:38.819: tty3: Modem: HANGUP->IDLE
*Aug 1 02:38:43.819: TTY3: restoring DTR
*Aug 1 02:38:44.819: TTY3: Always-on modem
*Aug 1 02:38:44.819: tty3: Modem: IDLE->READY
*Aug 1 02:38:53.363: Ce0 DDR: re-enable timeout
*Aug 1 02:38:53.363: DDR: Dialer Watch: watch-group = 1
*Aug 1 02:38:53.363: DDR: network 192.168.1.254/0.0.0.255 DOWN,
*Aug 1 02:38:53.363: DDR: primary DOWN
*Aug 1 02:38:53.363: Ce0 DDR: Attempting to dial lte
*Aug 1 02:38:53.363: CHAT3: Attempting async line dialer script
*Aug 1 02:38:53.363: CHAT3: Dialing using Modem script: lte & System script: none
*Aug 1 02:38:53.363: CHAT3: process started
*Aug 1 02:38:53.363: CHAT3: Asserting DTR
*Aug 1 02:38:53.363: CHAT3: Chat script lte started
*Aug 1 02:39:13.363: CHAT3: Chat script lte finished, status = Connection timed out; remote host not responding
*Aug 1 02:39:13.363: TTY3: Line reset by "Async dialer"
*Aug 1 02:39:13.363: Ce0 DDR: disconnecting call
*Aug 1 02:39:13.363: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:39:13.363: TTY3: no timer type 0 to destroy
*Aug 1 02:39:13.363: TTY3: no timer type 1 to destroy
*Aug 1 02:39:13.363: TTY3: no timer type 3 to destroy
*Aug 1 02:39:13.363: TTY3: no timer type 4 to destroy
*Aug 1 02:39:13.363: TTY3: no timer type 10 to destroy
*Aug 1 02:39:13.363: TTY3: no timer type 2 to destroy
*Aug 1 02:39:13.823: TTY3: dropping DTR, hanging up
*Aug 1 02:39:13.823: tty3: Modem: HANGUP->IDLE
*Aug 1 02:39:18.823: TTY3: restoring DTR
*Aug 1 02:39:19.823: TTY3: Always-on modem
*Aug 1 02:39:19.823: tty3: Modem: IDLE->READY
*Aug 1 02:39:28.363: Ce0 DDR: re-enable timeout
*Aug 1 02:39:28.363: DDR: Dialer Watch: watch-group = 1
*Aug 1 02:39:28.363: DDR: network 192.168.1.254/0.0.0.255 DOWN,
*Aug 1 02:39:28.363: DDR: primary DOWN
*Aug 1 02:39:28.363: Ce0 DDR: Attempting to dial lte
*Aug 1 02:39:28.363: CHAT3: Attemptinync line dialer script
*Aug 1 02:39:28.363: CHAT3: Dialing using Modem script: lte & System script: none
*Aug 1 02:39:28.363: CHAT3: process started
*Aug 1 02:39:28.363: DTR
*Aug 1 02:39:28.363: CHAT3: Chat script lte started
Router#
Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Aug 1 02:39:37.471: TTY0: pause timer type 1 (OK).....
Success rate is 0 percent (0/5)
Router#
*Aug 1 02:39:47.471: TTY0: resume timer type 1 (OK)
*Aug 1 02:39:48.363: CHAT3: Chat script lte finished, status = Connection timed out; remote host not responding
*Aug 1 02:39:48.363: TTY3: Line reset by "Async dialer"
*Aug 1 02:39:48.363: Ce0 DDR: disconnecting call
*Aug 1 02:39:48.363: TTY3: Modem: (unknown)->HANGUP
*Aug 1 02:39:48.363: TTY3: no timer type 0 to destroy
*Aug 1 02:39:48.363: TTY3: no timer type 1 to destroy
*Aug 1 02:39:48.363: TTY3: no timer type 3 to destroy
*Aug 1 02:39:48.363: TTY3: no timer type 4 to destroy
*Aug 1 02:39:48.363: TTY3: no timer type 10 to destroy
*Aug 1 02:39:48.363: TTY3: no timer type 2 to destroy
*Aug 1 02:39:48.823: TTY3: dropping DTR, hanging up

Hello,

try and power cycle the modem:

Router#conf t
Router(config)#service internal
Router#test cellular 0 modem-power-cycle

this commands not support on this router

Hello,

'service internal' is a hidden command, just type it in config mode and press <ENTER>...

johnd2310
Collaborator
Collaborator

Hi,

I have seen issue with those routers where they do not connect when upgraded to newer ios. Try downgrading to 15.2

Thanks

John

**Please rate posts you find helpful**

still not working...i try another sim for diffrent service provider its work..

i try to contact my service provider not luck

MHM Cisco World
Advisor
Advisor

Check Cisco Recommend Config, 
>>>>chat-script lte<<<<< this important 
cisco tle.png

tikshoret
Beginner
Beginner

i think the problem that the modem mc7710 doest support the  frequencies of my service provider

do you  config the router as I suggest ?

Yes..its the same

share the config you run
share the 
show dialer 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: