cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

515
Views
0
Helpful
3
Replies
Beginner

Cisco 876 - WAN failover

Hi,

One of my branch offices is connected to an ADSL line as well as a VDSL line.

Since I really don't need the ADSL line I came up with the idea to use it as a backup line.

So I searched google and found this nice little article

http://www.monkeymac.com/knowledgebase/configuring-wan-interface-failover-in-cisco-ios/

I wonder if the router will switch back to the primary ISP if the primary line comes up again?

3 REPLIES 3

Re: Cisco 876 - WAN failover

Hi,

You need to config IPSLA in order to failover occur between your ISP's from yor router.

Please click on the correct answer on all posts if they answered your question.
Regards,
Naidu.

Highlighted
Beginner

Re: Cisco 876 - WAN failover

Thank you Latchum,

I understand I need to configure IPSLA, the link above describes how to do that.

What I don't understand is, in case ISP1 fails, will the router switch back to ISP1 as soon as ISP1 is back online? Or will it continue to use ISP2?

Re: Cisco 876 - WAN failover

Hi,

That is what actually IPSLA do.
You need to use metric for the both default routes you point to ISP1 and ISP2

See the below example config what I have at one of my site.


ip sla monitor 1
  type echo protocol ipIcmpEcho x.x.x.x isp 1 gateway
  threshold 3
  frequency 5
ip sla monitor schedule 1 life forever start-time now


ip sla monitor 2
  type echo protocol ipIcmpEcho x.x.x.x isp 2 gateway
  threshold 3
  frequency 5
ip sla monitor schedule 2 life forever start-time now


track 101 rtr 1 reachability
track 102 rtr 2 reachability


interface fa0/0
ip address x.x.x.x 255.255.255.252 isp1
full-duplex
no cdp enable

interface fa0/1
ip address x.x.x.x 255.255.255.252 isp2
no ip proxy-arp
ip virtual-reassembly
ip route-cache flow
no ip mroute-cache
half-duplex
no cdp enable

ip route 0.0.0.0 0.0.0.0 x.x.x.x track 101   isp1
ip route 0.0.0.0 0.0.0.0 x.x.x.x track 102   isp2


access-list 100 permit tcp any any eq 1720
access-list 150 permit ip x.x.x.x 0.0.0.7 any
access-list 150 permit ip x.x.x.x 0.0.0.3 any
access-list 150 permit ip x.x.x.x 0.0.0.3 any
access-list 150 permit ip x.x.x.x 0.0.0.15 any


route-map indiaisp1 permit 10
match ip address 150
match interface FastEthernet0/0

route-map indiaisp2 permit 10
match ip address 150
match interface FastEthernet0/1

Please click on the correct answer on all posts if they answered your question.
Regards,
Naidu.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here