Showing results for 
Search instead for 
Did you mean: 

Cisco 877 Max VLAN and QoS Bugs??


Hi All,

Sorry for the double post but I need to get this issue resolved ASAP.

I am currently configuring a Cisco 877 router and I believe that I have run into a software bug with the 877.

The unit shipped with IOS 124-4.T2, I was able to configure 4 additional VLANs to the default VLAN through the VLAN database as expected and everything was working fine until I tried to apply my QoS service-policy to the Dialer Interface. Unexpectedly the router suffered a software forced reload and dumped it's output to flash. When the unit came up again I tried to apply the service-policy, same story the unit crashed.

I then downloaded 124-6.T1 and proceeded to recreate my VLANS, the VLAN.dat file copied successfully back to flash but the VLANS were not visible? (yet another bug??) When trying to recreate my VLANS as I added the fifth VLAN the following error occured.

*****UKBURL877-001(vlan)#vlan 5 name Guest*****

*****Vlan can not be added. Maximum number of 4 vlan(s) in the database.*****

I have now just upgraded to 124-6.T2 (release date 18/05) and when adding in the fifth VLAN the same error as above occurs.

I didn't even bother trying to add the service-policy after the IOS upgrades as my project requires 5 VLANs in total.

Anbody else running into the same bug?????

When my Smartnet comes through i'm going to open up a TAC on this but until then I was hoping that somebody out there might have an answer. ; )



3 Replies 3

Rising star
Rising star

Dear Steve,

I found it for you

Q)How many 802.1q VLANs can be configured on the inbuilt 4 port switch (Fastethernet 0-3) ?

A. Maximum of 4 VLANs are supported on Cisco 870 series with the plus feature set(Advanced IP services/Advanced Enterprise Services). Cisco 850 series does not support 802.1q VLANs.

For more info refare to

Please rate helpful posts.

Best Regards,

Mounir Mohamed


With respect, I am fully aware that the 877 supports 4 802.1q VLANS in addition to the default VLAN, VLAN 1. When upgrading to the most current IOS (124-6.T2)the 877 now only supports 4 VLANS including the default VLAN.

Plus i'm guessing my QoS service-policy when applied to the dialer interface is still going to crash the router.



Just hit the same VLAN bug on an 878 with 12.4(6)T3. Same problem - only four VLANs *including* the default VLAN. Did you get a TAC up on this because if not I have one going in tomorrow?



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers