cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5499
Views
7
Helpful
7
Replies
Enthusiast

Cisco 881 3G won't work

Hi!

I'm trying to configure Cisco CISCO881G-K9 3G router to connect to mobile network without success. The cellular interface gets up but it doesn't receive IP address

It seems that profile isn't activated and it should've been. Am I right?

I've attached running config and some other information gathered from router.

Any idea?

Regards,

Jernej

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Cisco 881 3G won't work

Hello Jernej,

You need to use the dailer interface ( in your running config i was not able to see the dailer config section)  please use the below template to complete the config

multilink bundle-name authenticated
chat-script internet "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"

interface Cellular0
no ip address
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer pool-member 2
dialer-group 2
async mode interactive

!

interface Dialer2
ip address negotiated
encapsulation ppp
dialer pool 2
dialer idle-timeout 0
dialer string internet
dialer persistent
dialer-group 2
no cdp enable
ppp chap hostname dummy (just put one name)
ppp chap password 0 dummytest (just put something)
ppp ipcp dns request

!

line con 0
login local
no modem enable
line aux 0
line 3
script dialer internet
no exec
rxspeed 7200000
txspeed 2000000
line 4
exec-timeout 0 0
timeout login response 0
privilege level 0
modem answer-timeout 0
modem dtr-delay 0
activation-character 0
exec-character-bits 8
special-character-bits 8
no exec
length 0
width 0
no history
no editing
transport preferred none
transport input none
transport output none
escape-character soft 0
escape-character 0
no ip tcp input-coalesce-threshold
callback forced-wait 0
callback nodsr-wait 0
stopbits 1
speed 115000

Try these and update.. Thanks |  Sudheesh  ( Rate me if this useful)

7 REPLIES 7
Participant

Re: Cisco 881 3G won't work

Hi Jernej,

You need to change the PDP Type under the profile, from PPP to IPv4.

See this doc for reference:

https://supportforums.cisco.com/docs/DOC-14786

Cheers

Marco

* If this was useful, please rate *

Enthusiast

Re: Cisco 881 3G won't work

Hi!

Thanks for the tip.

I've changes the PDP Type as suggested but it didn't resolve the problem:

sh cellular 0 all shows now:

Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = internet
Authentication = CHAP
Username: mobitel, Password: internet

sh interface cellular 0

Cellular0 is up (spoofing), line protocol is up (spoofing)
  Hardware is 3G Modem-HSPA/UMTS/EDGE/GPRS-850/900/1800/1900/2100MHz / Global
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 5760 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set

debug cellular messages all shows only these repeating events, nothing else:
*Jan 28 19:56:27.183: [Cellular0]:MGMT RX (HEARTBEAT) (14 bytes):
00 0A 6B 03 00 00 07 00 00 00 00 00 00 00

*Jan 28 19:56:28.127: [Cellular0]:MGMT RX (RSCP_ECIO) (24 bytes):

- debug chat
- debug dialer
- debug ppp negotiation

doesn't show any activity at all..

Any idea?

Participant

Re: Cisco 881 3G won't work

Hi Jernej,

If you don't see any debug, it means that the communication between IOS and modem is not happening.

I see that the line configuration has some missing parts, e.g. "modem inout", which allows IOS and modem to talk each other.

Can you please test this configuration?

line 3

exec-timeout 0 0

script dialer internet

login

modem InOut

no exec

transport preferred all

transport input all

transport output all

Let me know if this works.

Cheers

Marco

Enthusiast

Re: Cisco 881 3G won't work

Hi Marco!

I tested your configuration but it didn't help - nothing changed.

There are two things I would like to mention:

- "transport preferred" only supports "ssh" and "telnet" but not "all"

- I had to set up line password before I could run "login" command

I've attached more detailed information if you have any clue what else could be the problem.

Thank you for all your help!

Jernej

Participant

Re: Cisco 881 3G won't work

Hi Jernej,

still not coming up, this is disappointing

Instead of debug cellular, can you enable only:

- debug chat

- debug dialer

- debug ppp nego

Then start a ping that triggers the cellular interface.

One question: I see that the output of "show cellular all" is truncated, there is a long part missing. Did you cut it by mistake, or is the full output so short?

The parts about network and radio signal are missing. Can you try to collect it again?

Cheers

Marco

Beginner

Re: Cisco 881 3G won't work

Hello Jernej,

You need to use the dailer interface ( in your running config i was not able to see the dailer config section)  please use the below template to complete the config

multilink bundle-name authenticated
chat-script internet "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"

interface Cellular0
no ip address
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer pool-member 2
dialer-group 2
async mode interactive

!

interface Dialer2
ip address negotiated
encapsulation ppp
dialer pool 2
dialer idle-timeout 0
dialer string internet
dialer persistent
dialer-group 2
no cdp enable
ppp chap hostname dummy (just put one name)
ppp chap password 0 dummytest (just put something)
ppp ipcp dns request

!

line con 0
login local
no modem enable
line aux 0
line 3
script dialer internet
no exec
rxspeed 7200000
txspeed 2000000
line 4
exec-timeout 0 0
timeout login response 0
privilege level 0
modem answer-timeout 0
modem dtr-delay 0
activation-character 0
exec-character-bits 8
special-character-bits 8
no exec
length 0
width 0
no history
no editing
transport preferred none
transport input none
transport output none
escape-character soft 0
escape-character 0
no ip tcp input-coalesce-threshold
callback forced-wait 0
callback nodsr-wait 0
stopbits 1
speed 115000

Try these and update.. Thanks |  Sudheesh  ( Rate me if this useful)

Enthusiast

Re: Cisco 881 3G won't work

It works now.

Thank you very much Marco and Sudheesh for all your help!

Jernej

This is my working configuration (the problematic part):

interface Cellular0
no ip address
  ip nat outside
  ip virtual-reassembly
encapsulation ppp
  dialer in-band
  dialer pool-member 1
  dialer-group 1
  async mode interactive
!
interface Dialer1
  ip address negotiated
ip nat outside
  ip virtual-reassembly
encapsulation ppp
  dialer pool 1
  dialer idle-timeout 0
dialer string internet
  dialer persistent
  dialer-group 1
  ppp chap hostname dummy
ppp chap password 0 dummytest
ppp ipcp dns request
  no cdp enable

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards