cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
443
Views
15
Helpful
20
Replies
Highlighted
Beginner

Cisco 881 with dynamic isp config troubles

Hello everyone, im a bit new to cisco configuration but i have big wish to learn. I have a situation here. Been trying to configure cisco 881 router tru ios for internet access, i have dynamic isp, ive been playing with this thing for a while now, and cant find a solution of what is wrong with my config. I assign vlan1 to my int fa0 still no results, no internet access, cant even ping now.... I would really need sone help...

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Hello,

 

did your ISP give you a username and password ?

 

Try and change the configuration as below:

 

interface FastEthernet4
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1

interface Dialer1
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1460
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1420
dialer pool 1
dialer-group 1
no cdp enable

View solution in original post

20 REPLIES 20
Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

15844354545556523786953761904511.jpg

 

Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

1584435535704201657181943551043.jpg

 

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Hello,

 

you are at the very least missing a static route pointing to the outging WAN (ip nat outside) interface. Also, the IP address pool looks like it does not contain valid public IP addresses. The fastest way to help you is for you to post the running configuration here (show run)...

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Make the following changes to your configuration:

 

--> no ip nat pool data
--> no ip nat inside source list 1 pool data
--> ip nat inside source list 1 interface FastEthernet4 overload
--> ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Also, change the access list:

 

--> no access-list 1

--> access-list 1 permit 10.0.1.0 0.0.0.255

Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

Thank you very mutch for a reply Sir, ive made those changes but still no access to the internet. Its becouse of my bad routing for fa4? 

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Post the running configuration (show run), you might have missed something...

Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

15844415922186904333383115585304.jpg

 

15844416251172835540316626202497.jpg

 

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Hello,

 

the DHCP pool is wrong. Delete it and create it again as below:

 

--> no ip dhcp pool data

 

ip dhcp pool data
network 10.0.1.0 255.255.255.0
default-router 10.0.1.1
dns-server 8.8.8.8

Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

Ive made the changes, my running cfg looks like this now. So i itill have no internet access becouse of my static route problems?15844425133276918425637195249684.jpg

 

15844425470639141973900151154364.jpg

 

15844425855655811952772717600700.jpg

 

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Hello,

 

does your interface FastEthernet4 get an IP address at all ? Post the output of 'show ip int brief'.

 

Also, on FastEthernet4, remove:

 

interface FastEthernet4

--> no ip nat enable

Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

Ohh, my fa4 does not get ip address.... 15844431380843161491402784998821.jpg

 

Highlighted
VIP Mentor

Re: Cisco 881 with dynamic isp config troubles

Hello,

 

what is the interface, FastEthernet4, connected to ? Can you ping 8.8.8.8 from the router ? Post the output of:

 

show interfaces FastEthernet4

Highlighted
Beginner

Re: Cisco 881 with dynamic isp config troubles

15844485607272762181784428095947.jpg

Cant ping :(.. i have: Isp -> fastethernet4