cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
953
Views
0
Helpful
3
Replies

Cisco 886 pppoe with bridged modem

ganick
Level 1
Level 1

Hi, 

Need some help on setting up a remote site which used to be like below (an ISDN line plugged directly into Cisco 886):

Existing Topology
LAN(VLAN1) <---> (VLAN1)(FE0) Cisco 886 (ATM0) <---> OTE (ISP)

and it will be migrated to this (a VoBB line plugged into ISPs bridged router and connected to Cisco 886 FE):

New Topology
LAN(VLAN1) <---> (VLAN1)(FE0) Cisco 886 (FE1)(VLAN2) <---> OTE Router (Bridge Mode) <---> OTE (ISP)

 

First things first, the Cisco 886 has an old IoS v12.4, how can I check that the new topology is even possible

(PPPoE over FE interface) ?

 

I'll post the old (working) and the new (proposed) config for the Cisco, please advise! 

 

Thx in advance,

 

Nikos

 

The old config is this:

Remote Site
Existing Topology
LAN(VLAN1) <---> (VLAN1)(FE0) Cisco 886 (ATM0) <---> OTE (ISP)

Config
===============================================================

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname dad-po
!
boot-start-marker
boot system flash c880data-universalk9-mz.124-22.YB6.bin
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
memory-size iomem 10
!
!
ip source-route
!
!
ip dhcp excluded-address 192.168.4.1 192.168.4.33
!
ip dhcp pool opap-pool
network 192.168.4.0 255.255.255.0
dns-server 195.170.0.1 195.170.2.2
default-router 192.168.4.1
lease 2
!
!
ip cef
ip domain name dad.local
ip name-server 195.170.0.1
ip name-server 195.170.2.2
ip name-server 192.168.1.26
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
username admin privilege 15 password xxxxx
!
!
crypto isakmp policy 1
authentication pre-share
crypto isakmp key ******** address 79.129.55.1
crypto isakmp key ******** address 79.129.19.97
!
!
crypto ipsec transform-set dad esp-des esp-md5-hmac
!
crypto map vpn1 10 ipsec-isakmp
set peer 79.129.19.97
set transform-set dad
match address 131
!
archive
log config
hidekeys
!
!
!
!
!
interface Tunnel0
ip address 192.168.222.2 255.255.255.0
ip mtu 1476
tunnel source Dialer0
tunnel destination 79.129.19.97
tunnel key 1324
crypto map vpn1
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
no ip route-cache
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.4.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxx@otenet.gr
ppp chap password xxxxxx
ppp pap sent-username xxxxxx@otenet.gr password xxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.1.0 255.255.255.0 192.168.222.1
no ip http server
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer0 overload
!
access-list 23 permit 79.129.7.156
access-list 23 permit 195.97.104.72
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit 192.168.4.0 0.0.0.255
access-list 23 permit 192.168.222.0 0.0.0.255
access-list 100 permit ip 192.168.4.0 0.0.0.255 any
access-list 130 permit gre host 79.129.46.143 host 79.129.55.1
access-list 131 permit gre host 79.129.46.143 host 79.129.19.97
snmp-server community private RW
snmp-server community public RO
!
!
!
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
login local
!
scheduler max-task-time 5000
end

New Topology
LAN(VLAN1) <---> (VLAN1)(FE0) Cisco 886 (FE1)(VLAN2) <---> OTE Router (Bridge Mode) <---> OTE (ISP)

Config
===============================================================
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname dad-po-c886
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 64000
logging rate-limit 20
logging console informational
enable secret 5 $1$GyvL$3/N07Kd1aBF8SfT.Gub6W0
!
no aaa new-model
memory-size iomem 10
clock timezone UTC 3
!
!
ip source-route
!
!
ip dhcp excluded-address 192.168.4.1 192.168.4.33
!
ip dhcp pool opap-pool
network 192.168.4.0 255.255.255.0
dns-server 195.170.0.1 195.170.2.2
default-router 192.168.4.1
lease 2
!
!
ip cef
no ip domain lookup
ip domain name dad.local
ip name-server 195.170.0.1
ip name-server 195.170.2.2
ip name-server 192.168.1.26
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
username admin privilege 15 secret 5 $1$WTJA$z2u0ss2aBi2Ex8N/BP57M0
username officeln privilege 15 secret 5 $1$W181$ykyTqBrVmYoiRa.Z/Lfqz/
!
!
crypto isakmp policy 1
authentication pre-share
crypto isakmp key ******** address 79.129.55.1
crypto isakmp key ******** address 79.129.19.97
!
!
crypto ipsec transform-set dad esp-des esp-md5-hmac
!
crypto map vpn1 10 ipsec-isakmp
set peer 79.129.19.97
set transform-set dad
match address 131
!
archive
log config
hidekeys
!
!
!
!
!
interface Tunnel0
ip address 192.168.222.2 255.255.255.0
ip mtu 1476
tunnel source Dialer0
tunnel destination 79.129.19.97
tunnel key 1324
crypto map vpn1
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
!
interface FastEthernet1
description === WAN OTE ===
switchport access vlan 2
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description === Connected to LAN ===
ip address 192.168.4.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan2
description === WAN xDSL OTE1 ====
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxx@otenet.gr
ppp chap password xxxxxx
ppp pap sent-username xxxxxx@otenet.gr password xxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.1.0 255.255.255.0 192.168.222.1
no ip http server
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer0 overload
!
access-list 23 permit 79.107.178.160
access-list 23 permit 79.129.7.156
access-list 23 permit 195.97.104.72
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 23 permit 192.168.4.0 0.0.0.255
access-list 23 permit 192.168.222.0 0.0.0.255
access-list 100 permit ip 192.168.4.0 0.0.0.255 any
access-list 130 permit gre host 79.129.46.143 host 79.129.55.1
access-list 131 permit gre host 79.129.46.143 host 79.129.19.97
snmp-server community private RW
snmp-server community public RO
!
!
!
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
logging synchronous
login local
transport input telnet ssh
!
scheduler max-task-time 5000
ntp server 194.116.168.40
end

3 Replies 3

Hello,

 

I don't think you can use any of the FE interfaces on the 886 for PPPoE, the 886 is ADSL/VDSL only. These are layer 2 switchports only.

In interface configuration mode, check if anything starting with 'pppoe' is available at all, I don't believe it is...

What are my alternatives ?... Which Cisco routers for Small Business support the new topology ?

Hello,

 

any of the 800 series with Ethernet in the First Mile (EFM) support will do e.g. the 888E):

 

https://www.cisco.com/c/en/us/products/collateral/routers/887-integrated-services-router-isr/data_sheet_c78_459542.html

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card