cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

216
Views
0
Helpful
9
Replies
Beginner

Cisco 887W ADSL over PPPoE Config?

Hi,

 

I'm trying to replace my ISP's router with my Cisco 887W and firstly want to make sure that this is physically possible with this router?

 

I've spent the last few evenings trying various configs on differing interfaces but still no joy.

 

I currently have the ATM and dialler 0 interfaces set as NAT outside as different configs showed both as being outside for different set ups, not sure if they are conflicting with each other or not for this though?

 

I'm plugging directly from my BT master socket into the RJ11 port of the Cisco router.

 

Current ISP router is set up for PPPoE but is out of the equation for this.

 

CISCO887W-GN-E-K9

 

Any help would be greatly appreciated.

 

CCNA certified back in 2013 but expired now and not kept the skills up to date.

 

Wlan-AP not set up, just IP address at the moment.

 

Current config below:

 

----------------------------------------------------------------------------

 

Building configuration...

Current configuration : 2542 bytes
!
! Last configuration change at 04:09:15 UTC Sun Jan 7 1900 by
! NVRAM config last updated at 04:09:16 UTC Sun Jan 7 1900 by
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxxx
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 10
!
!
ip source-route
!
!
ip dhcp excluded-address 10.10.10.1 10.10.10.150
ip dhcp excluded-address 10.10.10.251 10.10.10.254
!
ip dhcp pool Home
network 10.10.10.0 255.255.255.0
default-router 10.10.10.254
dns-server 10.10.10.254
domain-name xxxxxxxx
lease 7
!
!
ip cef
no ipv6 cef
!
!
vpdn enable
!
vpdn-group 1
!
license udi pid CISCO887W-GN-E-K9 sn 
!
!
username
!
!
!
!
!
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 0/38
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip address 10.10.11.50 255.255.255.0
arp timeout 0
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 10.10.10.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp chap hostname xxxxxxx
ppp chap password xxxxxxx
ppp pap sent-username xxxxxxxxx password xxxxxxx
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 10.10.10.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
logging synchronous
login local
line 2
logging synchronous
login local
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
logging synchronous
login local
!
scheduler max-task-time 5000
end

Everyone's tags (4)
9 REPLIES 9
VIP Mentor

Re: Cisco 887W ADSL over PPPoE Config?

Hello,

 

typically, under the ATM interface, you would need some sort of encapsulation:

 

interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 0/38

encapsulation aal5mux ppp dialer
pppoe-client dial-pool-number 1

Beginner

Re: Cisco 887W ADSL over PPPoE Config?

Hi Greg,

 

That was one if the different configurations I'd seen and tried.

 

When you say typically, is this the specific encapsulation that is needed for the link I am trying to establish?

VIP Advisor

Re: Cisco 887W ADSL over PPPoE Config?

Hello

Are you trying to establish connection or querying the ppoe client configuration for this router, if the latter then posble append the following for client connectivity.

 

vpdn-group ppoe
request-dialin
protocol ppoe

int atm0
desl operating-mode auto



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Cisco 887W ADSL over PPPoE Config?

Hi Paul,

That command for request-dialin, is actually what led me to these forums.

 

I do not have the option of pppoe as a protocol for dialin, only l2tp.

 

The post I found on this stated that this protocol pppoe under the vpdn was an old method and no longer a configurable option on newer devices?

 

Also the second part you mention, dsl operating-mode auto, is the default for the ATM interface hence not shown in my config, and it would only appear if one of the specific modes were entered.

Beginner

Re: Cisco 887W ADSL over PPPoE Config?

Hi Paul,

 

Just seen I'd not answered your initial question.

 

I'm trying to configure an ISP facing interface to establish a PPPoE connection on my phone line.

 

This seems like a common task but appears not to be from the lack of configuration examples on this.

 

Cisco software guide for this router shows config examples for PPPoA using an ATM interface and PPPoE using a fast ethernet interface but not PPPoE on the ATM interface.

Highlighted
VIP Mentor

Re: Cisco 887W ADSL over PPPoE Config?

Hello,

 

there used to be (a long time ago admittedly) the 'encapsulation aal5autoppp' under the pvc:

 

interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
no atm ilmi-keepalive
pvc 0/38

--> encapsulation aal5autoppp
pppoe-client dial-pool-number 1

 

That said, I am not sure you can physically accomplish what you are trying to do. There is I think no layer 3 FastEthernet port on that model ?

Beginner

Re: Cisco 887W ADSL over PPPoE Config?

Hi Georg,

 

Thank you. That isn’t available on my router, the commands available under encapsulation on the pvc are as follows;

 

aal5ciscoppp

Cisco PPP over AAL5 Encapsulation


aal5mux

AAL5+MUX Encapsulation


aal5nlpid

AAL5+NLPID Encapsulation

 

aal5snap

AAL5+LLC/SNAP Encapsulation

VIP Mentor

Re: Cisco 887W ADSL over PPPoE Config?

Hello,

 

what is the LED status of the interface on the router ? I am afraid PPPoE on the ATM interface might not be supported at all on this model...:(

Beginner

Re: Cisco 887W ADSL over PPPoE Config?

Hi Georg,

 

I'll have to check this evening.

 

If this model does not support this, what do I need to look for in the datasheet of a router to know that it is supported?

 

I've spoke to a friend that mentions this can be done on the ethernet interface (which I don't have) and that this interface can be added by firmware?

 

Is that something you are aware of?

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here