cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
803
Views
0
Helpful
3
Replies
MatthewHeyman
Beginner

Cisco 891W and PPPOE

I've got a Cisco 891 and I'm trying to configure the thing to connect to a 4x1 fiber connection.  I don't know much about PPPOE.

 

Following this guide, http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/pppoenat.html

 

But my router decides it doesn't like that command.   Apparently, selecting protocol pppoe is not an option.   

 

Router(config-vpdn-req-in)#protocol ?

l2tp  Use L2TP

 

Which based on the input from the previous line, it doesn't look like router supports pppoe.   

 

I'm using C890-UNIVERSALK9-M, version 15.2(2)T

 

Any ideas why the command won't work?   

3 REPLIES 3
MatthewHeyman
Beginner

After about 2 hours, myself and another technician got it working.  The document works, I was just following the wrong portion of it.   

 

Jump to the section "configure fast ethernet wan interfaces" and "configure the dialer interface"

chap hostname also turned out to be what the vendor called "user name".

 

Also, don't forget to move any ACLs, vpn maps, and anything else you may normally configure to the dialer interface as opposed to the normal wan interface.

 

Also, don't forget to make sure NAT overload is moved to the dialer interface as well.   

Do your router able to ping to internet address like 8.8.8.8? Mine unable. Please help me with your full configuration please, I also have trouble about selecting protocol pppoe is not an option

There are a number of reasons a router can't ping 8.8.8.8.   It depends on whether you have ACLs set up, NAT correctly configured, PPOE running properly, and a number of other issues. 

 

With the setup I have, yes I'm capable of pinging 8.8.8.8. 

 

Within my inbound acl I have a

permit icmp any any echo-reply   

And that allows ping responses. 

 

Once again, follow the Cisco tech document and skip down to "Configure Fast Ethernet WAN interfaces" and all should be good. 

 

I did have to add

ip mtu 1454

ip tcp adjust-mss 1452

to the dialer interface to get https sites to work, but that might not be required in your situation.

 

The second part of that is that PPPOE is just a slightly different version of PPPOE.  So you don't select PPPOE, you select PPP by using

encapsulation ppp

on the dialer interface you set up.