cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
499
Views
20
Helpful
8
Replies
Highlighted
Beginner

Cisco C881 Router, ping but does not connect internet vlan1 fa0 fa1 fa2 and fa3, WAN is fa4

 


!
!
!
ip dhcp excluded-address 192.168.0.1 192.168.0.10
!
ip dhcp pool LAN FAB1 DHCP
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 1.1.1.1 1.0.0.1
lease 7
!
!
!
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
!
license udi pid CISCO881-K9 sn FCZ173691FR
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description TVBACO FIBRA 20M
ip address 192.168.100.77 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
description LAN FAB1
ip address 192.168.0.1 255.255.255.0
ip nat inside
--More--
*Feb 25 08:33:37.527: %LINK-3-UPDOWN: Interface FastEthernet3, changed state to up
*Feb 25 08:33:38.527: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern et3, changed s ip virtual-reassembly in
--More--
*Feb 25 08:34:06.547: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, cha nged s ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip nat inside source list 1 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 192.168.100.1
!
access-list 1 permit 0.0.0.0 255.255.255.0
access-list 23 permit 10.10.10.0 0.0.0.7
no cdp run
!
snmp-server community public RO
!

......................

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
VIP Mentor

Hello,

 

your access list 1 doesn't look right. Delete access list 1 and recreate is as below:

 

--> no access-list 1

--> access-list 1 permit 192.168.0.0 0.0.0.255

View solution in original post

Highlighted

Richard,

 

I was trying to figure out how the 'weird' access list got in there, your suggestion made me enter:

 

access-list 1 permit 192.168.1.0 255.255.255.0

 

and voila, the running config displays this as:


access-list 1 permit 0.0.0.0 255.255.255.0

 

Thanks for the hint !

View solution in original post

Highlighted
VIP Mentor

Hello

Just like to add regards the port mode for the FA interfaces - 
Its possible they could default to dynamic auto (dtp) if thats the case then suggest manually put them in access mode.

 

example:

int fa0
switchport 
switchport mode access
spanning-tree portfast



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

8 REPLIES 8
Highlighted
VIP Mentor

Hello,

 

your access list 1 doesn't look right. Delete access list 1 and recreate is as below:

 

--> no access-list 1

--> access-list 1 permit 192.168.0.0 0.0.0.255

View solution in original post

Highlighted

worked thank you very much for the help ,,,
Highlighted
VIP Advocate

Hi,

There is a wrong IP access list 1 assigned:

Changes as below:

 

config t

!

no access-list 1 permit 0.0.0.0 255.255.255.0 

!

access-list 1 permit 192.168.0.0 255.255.255.0 

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted

The mask of 255.255.255.0 is probably how the original poster created the problem. This is appropriate for a subnet mask. But IOS ACL uses wildcard mask. In the wildcard mask 255 means match any value. You are trying to get a match on 192.168.0 but since the mask says match anything IOS will put the address in the config as 0.0.0. 

 

The version suggested by Georg is correct.

 

HTH

 

Rick

HTH

Rick
Highlighted

Richard,

 

I was trying to figure out how the 'weird' access list got in there, your suggestion made me enter:

 

access-list 1 permit 192.168.1.0 255.255.255.0

 

and voila, the running config displays this as:


access-list 1 permit 0.0.0.0 255.255.255.0

 

Thanks for the hint !

View solution in original post

Highlighted

A melhor solução
Highlighted
VIP Mentor

Hello

Just like to add regards the port mode for the FA interfaces - 
Its possible they could default to dynamic auto (dtp) if thats the case then suggest manually put them in access mode.

 

example:

int fa0
switchport 
switchport mode access
spanning-tree portfast



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Highlighted

worked thank you very much for the help ,,,