cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

854
Views
0
Helpful
12
Replies
Highlighted
Beginner

Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

I'm new to Cisco Edge Router configuration and I am working on connecting the IR829 router to cell data via a Verizon SIM card. Auto-sim should be enabled but all cellular profiles stay INACTIVE. 

 

  1. Physical Observations
    • Verizon SIM card is plugged in Slot 1, SIM card status is green
    • The antenna is plugged in Cellular 1 
    • RSSI signal strength is at level 2 (2 LEDs)
  2. Terminal Process
    • controller cellular 1
    • lte firmware auto-sim 
    • show ip int brief. (cellular 1/0 has an unassigned IP-address and status up) 
    • show cellular 1/0 profile 
      • shows 6 inactive profiles

Is there a way to manually activate a profile? Is the profile critical to activating the cell data network?

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hi Georg, I ended up reaching out to Cisco Tech Support and searching for some related conversation in the community.

I ended up doing the following:
1. Created a dialer interface and bridged that to the cellular 1/0 interface
2. Configured the Gateway because the Gateway of last resort was not set
3. Set the data profile to 3

Thanks for your help!

View solution in original post

12 REPLIES 12
VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello,

 

post the full config, you might be missing something...

Beginner

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hi Georg, attached is my config and below are my cellular profiles:

 

I2V-OBE#show cellular 1/0 profile

Profile 1 = INACTIVE * **
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwims
Authentication = None

Profile 2 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwadmin
Authentication = None

Profile 3 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = VZWINTERNET
Authentication = None

Profile 4 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwapp
Authentication = None

Profile 5 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzw800
Authentication = None

Profile 6 = INACTIVE
--------
PDP Type = IPv4v6
Access Point Name (APN) = vzwclass6
Authentication = None

* - Default profile
** - LTE attach profile

 

 

Please let me know if you need more info

VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello,

 

is this the full config ? I don't see a chat script. Either way, I made some changes to your config (marked in bold). I don't know which profile you are actually using, so make sure the line 'lte sim data-profile 1 attach-profile 1' under controller 1 actually matches the profile you are using.

That said, your configuration has a lot of redundant lines that don't make sense, so the below changes might not be enough. Give it a try and check if at least your cellular interface gets an IP address, and your LAN clients can get out to the Internet. After you made the changes, post the full running config again so I can recheck everything:

 

chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"

!

controller Cellular 0
lte modem link-recovery disable
!
controller Cellular 1
lte sim data-profile 1 attach-profile 1
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
no lte gps enable
lte modem link-recovery disable
!
interface Loopback0
ip address 172.29.1.255 255.255.255.255
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0
no ip address
shutdown
!
interface GigabitEthernet1
description Connection to Cohda-obu
switchport access vlan 100
switchport mode access
no ip address
spanning-tree portfast
!
interface GigabitEthernet2
switchport access vlan 100
switchport mode access
no ip address
spanning-tree portfast
!
interface GigabitEthernet3
switchport access vlan 100
switchport mode access
no ip address
spanning-tree portfast
!
interface GigabitEthernet4
switchport access vlan 100
switchport mode access
no ip address
no cdp enable
!
interface Wlan-GigabitEthernet0
description L2 Trunk Port to Embedded AP
switchport mode trunk
no ip address
!
interface GigabitEthernet5
description IoX Interface
mtu 1420
ip address 192.168.200.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1380
duplex auto
speed auto
ipv6 address autoconfig
!
interface Cellular0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
shutdown
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer watch-group 1
dialer-group 1
ipv6 address autoconfig
async mode interactive
!
interface Cellular1/0
ip address negotiated
--> ip nat outside
--> ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
--> no peer default address
--> async mode interactive
--> routing dynamic
ipv6 address autoconfig
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Loopback0
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 192.168.100.1 255.255.255.0

--> ip nat inside
!
interface Async0
no ip address
encapsulation relay-line
!
interface Async1
no ip address
encapsulation relay-line
!
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip tftp blocksize 8192
ip dns server
--> no ip nat inside source static tcp 192.168.200.11 22 interface Vlan30 2222
--> no ip nat inside source static tcp 192.168.200.11 8080 interface Vlan30 8080
ip nat inside source list NAT_ACL interface Cellular1/0 overload
--> no ip nat inside source static tcp 192.168.200.11 8443 interface Vlan30 8443
--> no ip nat inside source static tcp 192.168.200.11 8085 interface Vlan30 8085
--> no ip nat inside source static tcp 192.168.200.11 5001 interface Cellular0/0 5001
--> no ip nat inside source static tcp 192.168.200.11 8484 interface Vlan30 8484
--> no ip nat inside source static tcp 192.168.200.11 8081 interface Vlan30 8081
--> no ip nat inside source static udp 192.168.200.11 44444 interface Vlan30 44444
--> no ip nat inside source static tcp 192.168.11.120 80 interface Vlan30 8123
--> ip route 0.0.0.0 0.0.0.0 Cellular1/0 overload
--> no ip route 0.0.0.0 0.0.0.0 dhcp
ip ssh rekey time 60
ip ssh rekey volume 1048576
ip scp server enable
!
ip access-list standard NAT_ACL
permit 192.168.0.0 0.0.255.255
permit 172.20.1.0 0.0.0.255
permit 172.29.1.0 0.0.0.255
!
--> no dialer watch-list 1 ip 5.6.7.8 0.0.0.0
--> no dialer watch-list 1 delay route-check initial 60
--> no dialer watch-list 1 delay connect 1
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
!
!
!
!
control-plane
!
!
!
vstack
!
line con 0
logging synchronous
length 40
stopbits 1
line 1 2
exec-timeout 0 0
no exec
transport preferred none
transport input all
transport output all
stopbits 1
speed 115200
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 9
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 15
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3
transport preferred none
transport output none
stopbits 1
line 1/4
transport preferred none
transport input all
transport output none
stopbits 1
line 1/5
transport preferred none
transport input all
transport output all
stopbits 1
speed 115200
line 1/6
transport preferred none
transport input all
transport output all
stopbits 1
line vty 0 4
transport input all
line vty 5 15
transport input all
line vty 16
transport input none
!
no scheduler max-task-time
relay line 1 1/5 propagation
relay line 2 1/6 propagation
ntp master
ntp update-calendar
ntp peer 129.6.15.28 prefer
no iox hdm-enable
iox client enable interface GigabitEthernet5
no iox recovery-enable

Beginner

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Thanks for your continued support. 

 

I'm not sure what a chat-script is. To get the config, I ran show running-config on the router.  Is that the right command to get the file?

 

Regards to the profiles, Profile 1 should data and Profile 3 should the attach-profile, I think. According to: 

 

 

https://www.cisco.com/c/en/us/td/docs/routers/access/800/829/software/configuration/guide/b_IR800config/b_cellular.html

VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello,

 

a chat script is required for communication with the modem. The command 'show run' is indeed the correct command. Did you implement the changes I indicated ?

Beginner

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

I had trouble implementing the following changes: 

 

ip dns server
--> no ip nat inside source static tcp 192.168.200.11 22 interface Vlan30 2222
--> no ip nat inside source static tcp 192.168.200.11 8080 interface Vlan30 8080
ip nat inside source list NAT_ACL interface Cellular1/0 overload
--> no ip nat inside source static tcp 192.168.200.11 8443 interface Vlan30 8443
--> no ip nat inside source static tcp 192.168.200.11 8085 interface Vlan30 8085
--> no ip nat inside source static tcp 192.168.200.11 5001 interface Cellular0/0 5001
--> no ip nat inside source static tcp 192.168.200.11 8484 interface Vlan30 8484
--> no ip nat inside source static tcp 192.168.200.11 8081 interface Vlan30 8081
--> no ip nat inside source static udp 192.168.200.11 44444 interface Vlan30 44444
--> no ip nat inside source static tcp 192.168.11.120 80 interface Vlan30 8123
--> ip route 0.0.0.0 0.0.0.0 Cellular1/0 overload
--> no ip route 0.0.0.0 0.0.0.0 dhcp
ip ssh rekey time 60
ip ssh rekey volume 1048576
ip scp server enable
!
ip access-list standard NAT_ACL
permit 192.168.0.0 0.0.255.255
permit 172.20.1.0 0.0.0.255
permit 172.29.1.0 0.0.0.255
!
--> no dialer watch-list 1 ip 5.6.7.8 0.0.0.0
--> no dialer watch-list 1 delay route-check initial 60
--> no dialer watch-list 1 delay connect 1
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp

 

How would you make those changes in the terminal?

 

I made the other changes, saved config using do wr, then I re-ran show ip interface brief and no ip address was assigned to Cellular 1/0

VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello,

 

in config mode, just copy and paste the below. So, go to the prompt, type"

 

829#conf t

829(config)#

 

and the paste the below.

 

no ip nat inside source static tcp 192.168.200.11 22 interface Vlan30 2222
no ip nat inside source static tcp 192.168.200.11 8080 interface Vlan30 8080
ip nat inside source list NAT_ACL interface Cellular1/0 overload
no ip nat inside source static tcp 192.168.200.11 8443 interface Vlan30 8443
no ip nat inside source static tcp 192.168.200.11 8085 interface Vlan30 8085
no ip nat inside source static tcp 192.168.200.11 5001 interface Cellular0/0 5001
no ip nat inside source static tcp 192.168.200.11 8484 interface Vlan30 8484
no ip nat inside source static tcp 192.168.200.11 8081 interface Vlan30 8081
no ip nat inside source static udp 192.168.200.11 44444 interface Vlan30 44444
no ip nat inside source static tcp 192.168.11.120 80 interface Vlan30 8123
ip route 0.0.0.0 0.0.0.0 Cellular1/0 overload
no ip route 0.0.0.0 0.0.0.0 dhcp

no dialer watch-list 1 ip 5.6.7.8 0.0.0.0
no dialer watch-list 1 delay route-check initial 60
no dialer watch-list 1 delay connect 1

Beginner

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Ok. Thank you. I got an invalid input detected. I'm to run the show running-config to see what changes took

I2V-OBE(config)#
I2V-OBE(config)#$ce static tcp 192.168.200.11 22 interface Vlan30 2222
I2V-OBE(config)#$ce static tcp 192.168.200.11 8080 interface Vlan30 8080
I2V-OBE(config)#$de source list NAT_ACL interface Cellular1/0 overload
I2V-OBE(config)#$ce static tcp 192.168.200.11 8443 interface Vlan30 8443
I2V-OBE(config)#$ce static tcp 192.168.200.11 8085 interface Vlan30 8085
I2V-OBE(config)#$ce static tcp 192.168.200.11 5001 interface Cellular0/0 5001
I2V-OBE(config)#$ce static tcp 192.168.200.11 8484 interface Vlan30 8484
I2V-OBE(config)#$ce static tcp 192.168.200.11 8081 interface Vlan30 8081
I2V-OBE(config)#$ce static udp 192.168.200.11 44444 interface Vlan30 44444
I2V-OBE(config)#$ce static tcp 192.168.11.120 80 interface Vlan30 8123
I2V-OBE(config)#ip route 0.0.0.0 0.0.0.0 Cellular1/0 overload
^
% Invalid input detected at '^' marker.

I2V-OBE(config)#no ip route 0.0.0.0 0.0.0.0 dhcp
I2V-OBE(config)#
I2V-OBE(config)#no dialer watch-list 1 ip 5.6.7.8 0.0.0.0
^
% Invalid input detected at '^' marker.

I2V-OBE(config)#no dialer watch-list 1 delay route-check initial 60
VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello,

 

manually check what lines are left and then remove those with the 'no' followed by the line. You might have to manually type it out...

VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello.

 

are you making progress ? If you cannot get it done, 'write erase' the entire configuration and start from scratch...

Beginner

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hi Georg, I ended up reaching out to Cisco Tech Support and searching for some related conversation in the community.

I ended up doing the following:
1. Created a dialer interface and bridged that to the cellular 1/0 interface
2. Configured the Gateway because the Gateway of last resort was not set
3. Set the data profile to 3

Thanks for your help!

View solution in original post

VIP Mentor

Re: Cisco IR829 Router - Activate SIM card (data plan): When SIM card is plugged in all profiles remain inactive

Hello,

 

glad that you got it working !

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here