cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

264
Views
0
Helpful
0
Replies
Highlighted
Beginner

Cisco ISR4331 | KVM VM | Hanging on "connected to appliance" then eventually going back to the router prompt

Hello there, the company I work for have been trying to get an Ubuntu 18 Server iso on a Cisco ISR4331 Router, having viewed this tutorial:

 

https://www.youtube.com/watch?v=wCRlPzWfwhk&

 

And then from that, finding this guide:

 

http://files.technologyordie.com/Service-Containers-Tutorial.pdf

 

We began work.

 

I got a bog standard Ubuntu 18 Server iso, installed it via Virtual Machine Manager, added the users I wanted, installed the applications I wanted.

 

I have ensured the grub menu is booting into TTYS0 as the guide shows to use upstart but Ubuntu 18 doesn't use upstart, so I added it to the grubmenu and actually created a service to start at boot as well, and I can verify it like so:

1234.PNG

I then can use:

virsh ubuntu18 console

 

to connect to the server via my test environment and this works fine.

 

I then followed the ova creation tool in that guide which created me a ubuntu18.mf file as well as an ova, I used the templates and ova creation tool found here:

 

https://github.com/shabaz123/ServiceContainers/raw/master/templates.tar 

 

I have tried using the qcow2 disk that Virtual Machine Manager spits out, and I have also tried converting it like so:

 

 

qemu-img convert -p -c -f raw -o compat=0.10 -O qcow2 /var/lib/libvirt/images/ubuntu18.qcow2 ubuntu18.qcow2

 

And then the command to generate the ova.

./create_ova.sh -mts 200000 -mfs 100000 ubuntu18

The VM installs on the router fine and activates fine, however when I try to connect using:

virtual-server connect name ubuntu18 console

I am faced with text that says "Connected to appliance" then after 5-10 seconds I am taking back to the default router prompt.

 

I am really stuck here now and would appreciate any input on how to get this working.

 

Thank you.