Showing results for 
Search instead for 
Did you mean: 

CISCO887VAG+7-K9 no longer able to establish a 3G connection (previously working)

I have a CISCO887VAG+7-K9 router which has been set-up so that the 3G will kick in if the ADSL fails.  This was all set-up and working nicely until the other day when the ADSL failed and 3G didn't kick in.  Luckily, the ADSL came up again a short time later but I still don't seem to be able to establish a 3G connection any more.   I logged with our mobile provider but they tell me there are no problems in the area and that coverage is good so, as far as they are concerned, I should be able to get a connection.

On the router, I have turned on:

debug chat

debug dialer

And I notice the following message in the dialer debug:

Aug 15 11:27:08.645: Ce0 DDR: has 1 ongoing call(s), maximum allowed call(s) 1 on pool 1, exceeded max

I have tried rebooting the router, shutting/no shutting the dialer and cellular interface, power cycling the modem etc but to no avail - it still won't establish a connection and pick up an IP address.

Show dialer gives:

Ce0 - dialer type = IN-BAND ASYNC NO-PARITY

Dialer pool 1, priority 0

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Di1 - dialer type = DIALER PROFILE

Idle timer (never), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is idle

Number of active calls = 0

Dial String      Successes   Failures    Last DNIS   Last status

INTERNET                 0          0    10:49:50           failed   Default

Show Cell 0 radio shows:

Radio power mode = ON

Current Band = WCDMA 2100, Channel Number = 10564

Current RSSI = -54 dBm

Band Selected = Auto

Number of nearby cells = 1

Cell 1

        Primary Scrambling Code = 0xB6

        RSCP = -54 dBm, ECIO = -4 dBm

Show cell 0 network shows:

Current Service Status = Normal, Service Error = None

Current Service = Combined

Packet Service = HSPA (Attached)

Packet Session Status = Inactive

Current Roaming Status = Home

Network Selection Mode = Automatic

Country = GBR, Network = 3 UK

Mobile Country Code (MCC) = 234

Mobile Network Code (MNC) = 20

Location Area Code (LAC) = 51

Routing Area Code (RAC) = 51

Cell ID = 7669

Primary Scrambling Code = 182

PLMN Selection = Automatic

Registered PLMN =   , Abbreviated =

Service Provider =

The cellular interface remains down/down:

Cellular0                  unassigned      YES NVRAM  down                  down

Can anyone suggest what might be wrong and/or how I can troubleshoot further to find the cause and resolve this?



Well, removing the dialer profile and re-applying it seemed to sort this out and I was able to re-establish 3G connectivity again.  However, I'm not sure why that should be (and I'm not even 100% certain if that's definitely what fixed it or if that was just a fluke!)

My concern is that if this happens again - and we have a genuine ADSL fault - then we won't be able to access the router remotely to sort out the 3G and an engineer site visit would be required (which would defeat the purpose of us having 3G as backup!)

Does anyone have any similar experience or suggestions on what the problem could be here and whether there is either a) a way I can prevent it happening again or b) if it does happen, some way to fix it that doesn't involve any config changes because we would lose access to the router if the ADSL goes down and the 3G doesn't kick in.

Any thoughts would be appreciated.  Thanks.


Update IOS and check again.


Well, here's the interesting thing and, sorry, I should have specified this on my original question details.  I have actually seen this happen a couple of times now but with different IOS versions (as an IOS issue was one of the first thoughts that sprang to mind for me too!)

So - problem above was with IOS version 15.2(4)M3

BUT I have also seen it on IOS version 15.1(4)M4

I'm always reluctant to change IOS unless all other avenues are exhausted as I have been bitten in the past with IOS upgrades which have actually caused additional issues rather than resolving the problem I hoped it would (I don't have the luxury of a test unit to work with at the moment unfortunately so can't test the IOS in advance of deployment).  So, while I know exactly where you're coming from by suggesting an IOS upgrade, unless I'm hitting a known bug that is fixed in a later release, I'd rather leave that as a last resort.... 


You can follow reasonable suggestions, go to the TAC, or stay with the current situation. Your choice really.


I'm well aware of that, hence why I posted the question on the forum.  It's useful for me to hear not only whether other users have experienced this particular issue but also their thoughts on how they might troubleshoot it and it may also hopefully be helpful to others who come across the same/similar problem in future.  I find the forums can be mutually beneficial in this way rather than always going direct to TAC.

I appreciate your input (and that of anyone else who takes time to read of the problem and contribute)