cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
357
Views
15
Helpful
8
Replies

Communication between Rip v1 and Rip v2

Will they ping (image is attached). 

In my case it's not pinging.

And if pinging, how?

Ps : Using C7200(router) ios image in GNS3

Everyone's tags (1)
3 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Expert

Re: Communication between Rip v1 and Rip v2

Hello Yaman,

by default Cisco routers can run both versions of RIP v1 and v2.

 

So it depends on how you configure the routers.

if your configuration is

 

R1:

router rip

version 1

network 1.0.0.0

network 192.168.1.0

!

 

R2

router rip

version 2

network 2.0.0.0

network 192.168.1.0

!

 

This can lead to interoperability issues.

You can check the state of RIP communication by

show ip route rip

 

if this show output is empty the two routers are not considering each other RIP neighbors

 

Likely R1 does not accept the version 2 update sent by R2, R2 can accept R1's update.

R2 version 2 updates are sent to IPv4 multicast address 224.0.0.9 R1 version 1 update are sent to 255.255.255.255 broadcast address.

 

Hope to help

Giuseppe

 

Advocate

Re: Communication between Rip v1 and Rip v2

Hi @YamanBelwal0505 ,

 

Try this:

 

Router RIPv1

Router#show ip protocols

Default version control: send version 1, receive any version

Interface            Send Recv Triggered RIP Key-chain

Loopback1         1       2 1

FastEthernet0/0  1      2 1

 

Router RIPv2

Router#show ip protocols

Default version control: send version 2, receive 2

Interface             Send Recv Triggered RIP Key-chain

Loopback2          2      2

FastEthernet0/0  2       2

 

If you see these results, the RIPv1 router is receiving updates from both versions, but, the RIPv2 router is only receiving updates from version 2.

 

Maybe it will be solved with this command:

 

On router RIPv2

Router(config)# interface g0/0

Router(config-if)# ip rip receive version 1 2

 

Then, check again with the show ip protocols command.

 

I hope that helps you.

 

Regards

Hall of Fame Expert

Re: Communication between Rip v1 and Rip v2

Hello Yaman,

RIP both versions is legacy for its very slow convergence and the limited scalability caused by the limited metric (up to 15 router hops allowed).

some use cases are for :

interaction with devices with limited routing capabilites to give them a dynamic routing protocol default route

providing a default route to some Unix workstations that has the RIP daemon running on it.

 

So RIP usage is limited to special cases and only to some access sections of the network.  RIP is used as an edge protocol.

The core routing protocol now can be OSPF, EIGRP (that has became public it is not Cisco proprietary anymore) and IS-IS (less frequent in enterprise environment but it is becoming more popular for dual stack IPv4/IPv6 environments)

 

Hope to help

Giuseppe

 

 

8 REPLIES 8
Hall of Fame Expert

Re: Communication between Rip v1 and Rip v2

Hello Yaman,

by default Cisco routers can run both versions of RIP v1 and v2.

 

So it depends on how you configure the routers.

if your configuration is

 

R1:

router rip

version 1

network 1.0.0.0

network 192.168.1.0

!

 

R2

router rip

version 2

network 2.0.0.0

network 192.168.1.0

!

 

This can lead to interoperability issues.

You can check the state of RIP communication by

show ip route rip

 

if this show output is empty the two routers are not considering each other RIP neighbors

 

Likely R1 does not accept the version 2 update sent by R2, R2 can accept R1's update.

R2 version 2 updates are sent to IPv4 multicast address 224.0.0.9 R1 version 1 update are sent to 255.255.255.255 broadcast address.

 

Hope to help

Giuseppe

 

Re: Communication between Rip v1 and Rip v2

Sir, @Giuseppe Larosa 

You are saying one way communication will happen?

And here both are pinging? 

Hall of Fame Expert

Re: Communication between Rip v1 and Rip v2

Hello Yaman,

the router configured for RIP version 2 R2 by listening to R1 version 1 updates will fallback to version 1 RIP updates.

This explains why both routers are able to ping the other router's loopback.

In show ip route rip you should have one entry for the classful network 1.0.0.0/8 or 2.0.0.0/8 on each router.

 

Edit:

as explained by Luis a Cisco router running RIP can be listening to both versions of RIP.

RIP has not neighbor state machine concept compared to more modern and complex protocols like EIGRP and OSPF so it is able to work in a mixed version 1 / version 2 scenario like yours.

 

Hope to help

Giuseppe

 

Advocate

Re: Communication between Rip v1 and Rip v2

Hi @YamanBelwal0505 ,

 

Try this:

 

Router RIPv1

Router#show ip protocols

Default version control: send version 1, receive any version

Interface            Send Recv Triggered RIP Key-chain

Loopback1         1       2 1

FastEthernet0/0  1      2 1

 

Router RIPv2

Router#show ip protocols

Default version control: send version 2, receive 2

Interface             Send Recv Triggered RIP Key-chain

Loopback2          2      2

FastEthernet0/0  2       2

 

If you see these results, the RIPv1 router is receiving updates from both versions, but, the RIPv2 router is only receiving updates from version 2.

 

Maybe it will be solved with this command:

 

On router RIPv2

Router(config)# interface g0/0

Router(config-if)# ip rip receive version 1 2

 

Then, check again with the show ip protocols command.

 

I hope that helps you.

 

Regards

Re: Communication between Rip v1 and Rip v2

So, in short Rip v1 and Rip v2 communicates? Is this type of topologies (using rip v1 and Rip v2 to communicate) is used? Any major uses of it?
Hall of Fame Expert

Re: Communication between Rip v1 and Rip v2

Hello Yaman,

RIP both versions is legacy for its very slow convergence and the limited scalability caused by the limited metric (up to 15 router hops allowed).

some use cases are for :

interaction with devices with limited routing capabilites to give them a dynamic routing protocol default route

providing a default route to some Unix workstations that has the RIP daemon running on it.

 

So RIP usage is limited to special cases and only to some access sections of the network.  RIP is used as an edge protocol.

The core routing protocol now can be OSPF, EIGRP (that has became public it is not Cisco proprietary anymore) and IS-IS (less frequent in enterprise environment but it is becoming more popular for dual stack IPv4/IPv6 environments)

 

Hope to help

Giuseppe

 

 

Re: Communication between Rip v1 and Rip v2

I got it Thanks A lot Sir

Re: Communication between Rip v1 and Rip v2

Thanks a lot, Sir..! I got it
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards