cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7042
Views
0
Helpful
3
Replies
n.bokhar1
Beginner

configuring pppoe on cisco isr 4331

i have a 4331 on my network and i want to connect to the internet via PPPoE over ethernet how can i achieve that?

i tried connecting using vpdn but in vpdn-group i cannot request dialout 

1 ACCEPTED SOLUTION

Accepted Solutions

These are the commands you will want to use to configure PPPoE

 

Commands:

interface <WAN interface here>
pppoe enable
pppoe-client dial-pool-number 1
no shut

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username <username ISP gave you here> password <password ISP gave you here>
ppp chap hostname <username ISP gave you here>
ppp chap password <password ISP gave you here>
no shut

View solution in original post

3 REPLIES 3
n.bokhar1
Beginner

also i have found on interface config there is a command that is pppoe enable or even more commands can i use any of them

These are the commands you will want to use to configure PPPoE

 

Commands:

interface <WAN interface here>
pppoe enable
pppoe-client dial-pool-number 1
no shut

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp pap sent-username <username ISP gave you here> password <password ISP gave you here>
ppp chap hostname <username ISP gave you here>
ppp chap password <password ISP gave you here>
no shut

thanks it worked just fine