cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
418
Views
0
Helpful
2
Replies

Configuring QOS

peter.saldanha
Level 1
Level 1

Hi

I have configured QOS in Cisco 1841 router. I want to prioritisation of traffic such as voice and other data traffic such as vpn, citrix, mail, web etc. I will send you my router configuration below. I want to establish QOS so that each traffic should get allocated bandwidth during peak but suppose one of the traffic is not utilised particular time, that bandwidth should be automatically allocated to other traffic. Also Voice traffic should be given high priority. I have 2 serial interfaces with 2MB each. I have bundled the lines so that I will get 4MB, Multilink.

My router configuration is as follows.

!

hostname router

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 debugging

!

username cisco privilege 15 secret xxxx

clock timezone Muscat 4

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

ip domain name yourdomain.com

no ftp-server write-enable

!

!

!

class-map match-all EF

match access-group 100

class-map match-all mail

match access-group 103

class-map match-all citrix

match access-group 101

class-map match-all best-effort

match access-group 107

class-map match-all other-traffic

match access-group 107

class-map match-all vpn

match access-group 105

class-map match-all web

match access-group 106

class-map match-all voice

match ip dscp ef

!

!

policy-map VOIP

class voice

priority 1000

class citrix

bandwidth percent 20

class web

bandwidth percent 20

random-detect

class vpn

bandwidth percent 10

random-detect

class mail

bandwidth percent 20

class other-traffic

!

!

!

interface Multilink2

ip address 192.169.1.1 255.255.255.0

service-policy output VOIP

ppp multilink

ppp multilink group 2

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.125.1 255.255.255.0

ip nbar protocol-discovery

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

bandwidth 2000000

ip address 192.169.1.1 255.255.255.0

encapsulation ppp

pulse-time 1

ppp multilink

ppp multilink group 2

!

interface Serial0/0/1

bandwidth 2000000

no ip address

encapsulation ppp

pulse-time 1

ppp multilink

ppp multilink group 2

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.169.1.2

ip http server

ip http authentication local

!

!

access-list 100 permit udp any any range 16384 32000

access-list 100 permit tcp any any eq 1720

access-list 101 permit tcp any any eq 1494

access-list 101 permit tcp any any eq 3389

access-list 103 permit tcp any any eq smtp

access-list 105 permit ip 0.0.0.0 255.255.255.0 0.0.0.0 255.255.254.0

access-list 105 permit ip 192.168.125.0 0.0.0.255 10.44.10.0 0.0.0.255

access-list 106 permit tcp any any eq www

access-list 107 permit ip any any

!

control-plane

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

_____________________________________________________

2 Replies 2

thisisshanky
Level 11
Level 11

Peter, QOS policies kick in only when there is congestion. When a particular traffic is not passing through the interface, all bandwidth is available to the rest of the traffic passing through, until congestion happens and the respective traffic (that you have classified) will be guaranteed the configured bandwidth.

Also try not to exceed alloacating more than 75 percent of the available bandwidth to traffic, as router generated traffic such as routing protocol updates will not have sufficient bandwidth to pass.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Hi

Is my configuration is correct?. I have maximum 32 voice sessions going out, so I have given a priority of 1000. I have given for the rest of the traffic QOS based on bandwidth, is it correct?.

Will the bandwidth be available if not used by any service?

Please see my interface status for your info

Serial0/0/0 is up, line protocol is up

Hardware is GT96K Serial

Internet address is 192.169.1.1/24

MTU 1500 bytes, BW 2000000 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open, multilink Open

Link is a member of Multilink bundle Multilink2, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Last input 00:00:00, output 00:00:25, output hang never

Last clearing of "show interface" counters 3d08h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 44

Queueing strategy: weighted fair [suspended, using FIFO]

FIFO output queue 0/40, 44 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

6891575 packets input, 35859250 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

497 input errors, 497 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

2908523 packets output, 275856172 bytes, 0 underruns

0 output errors, 0 collisions, 8 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Serial0/0/1 is up, line protocol is up

Hardware is GT96K Serial

MTU 1500 bytes, BW 2000000 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open, multilink Open

Link is a member of Multilink bundle Multilink2, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Last input 00:00:00, output 00:00:25, output hang never

Last clearing of "show interface" counters 3d08h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

Queueing strategy: weighted fair [suspended, using FIFO]

FIFO output queue 0/40, 1 drops

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

6965017 packets input, 127991617 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

2953866 packets output, 279301215 bytes, 0 underruns

0 output errors, 0 collisions, 4 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

Multilink2 is up, line protocol is up

Hardware is multilink group interface

Internet address is 192.169.1.1/24

MTU 1500 bytes, BW 4000000 Kbit, DLY 100000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open, multilink Open

Open: CDPCP, IPCP, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 2 seconds on reset

Last input 00:00:01, output never, output hang never

Last clearing of "show interface" counters 3d08h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/2/256 (active/max active/max total)

Reserved Conversations 11/11 (allocated/max allocated)

Available Bandwidth 199000 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

7577445 packets input, 68301426 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

5085380 packets output, 508372838 bytes, 0 underruns

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card