cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
593
Views
5
Helpful
5
Replies

CSC, MPLS, and EBGP LU routing failure

tomc.pnnl
Level 1
Level 1

Good day,

 

I'm configuring CSC using EBGP labeled unicast and having problem with the CEs resolving routes. The minimal working example is:

 

192.168.1.1/32                                                                                                                 192.168.1.2/32

|                                                                                                                                        |

loop0                                                                                                                                loop0

|                                                                                                                                        |

CE1 192.168.1.1/30 -- 192.168.1.2/30 PE1 -- PE2 192.168.1.6/30 -- 192.168.1.5/30 CE2

 

CE1's global routing table appears to be correct:


L 127.0.0.0/8 [0/0] via 0.0.0.0, 01:22:49
L 192.168.1.1/32 is directly connected, 01:22:40, Loopback0
B 192.168.1.2/32 [20/0] via 192.168.128.1, 00:17:52
C 192.168.128.0/30 is directly connected, 01:22:40, GigabitEthernet0/0/0/1
L 192.168.128.2/32 is directly connected, 01:22:40, GigabitEthernet0/0/0/1

When I trace ipv4 192.168.1.2 source 192.168.1.1

1 192.168.128.2 !N * !N

 

I run into a local problem (192.168.128.2 is the address of CE1 interface)

Can I anyone shed some light? Configurations for CE1 and PE2 follow:

 

CE1

interface Loopback0
ipv4 address 192.168.1.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
shutdown
!
interface GigabitEthernet0/0/0/1
description PE1
mtu 6144
ipv4 address 192.168.128.2 255.255.255.252
!

route-policy ACCEPT_ALL
pass
end-policy
!
router bgp 100
bgp router-id 192.168.1.1
bgp log neighbor changes detail
address-family ipv4 unicast
network 192.168.1.1/32
allocate-label all
!
neighbor 192.168.128.1
remote-as 1
address-family ipv4 labeled-unicast
route-policy ACCEPT_ALL in
route-policy ACCEPT_ALL out
!
!
mpls oam
!

sh route

L 127.0.0.0/8 [0/0] via 0.0.0.0, 01:35:25
L 192.168.1.1/32 is directly connected, 01:35:16, Loopback0
B 192.168.1.2/32 [20/0] via 192.168.128.1, 00:30:28
C 192.168.128.0/30 is directly connected, 01:35:16, GigabitEthernet0/0/0/1
L 192.168.128.2/32 is directly connected, 01:35:16, GigabitEthernet0/0/0/1

 

sh mpls forwarding
Wed Mar 24 18:50:22.630 UTC
Local Outgoing Prefix Outgoing Next Hop Bytes
Label Label or ID Interface Switched
------ ----------- ------------------ ------------ --------------- ------------
24000 Aggregate 192.168.128.0/30 default 0
24001 Pop 192.168.128.2/32 192.168.128.2 0
24002 24004 192.168.1.2/32 192.168.128.1 0

 

 

 

PE

vrf vpnA
address-family ipv4 unicast
import route-target
100:0
!
export route-target
100:0
!
!
!

interface Loopback0
ipv4 address 192.168.255.1 255.255.255.255
!
interface GigabitEthernet0/0/0/0
description PE2
mtu 6144
ipv4 point-to-point
ipv4 unnumbered Loopback0
!
interface GigabitEthernet0/0/0/1
description CE1
mtu 6144
vrf vpnA
ipv4 address 192.168.128.1 255.255.255.252
!

route-policy ACCEPT_ALL
pass
end-policy
!
router isis 1
net 49.0001.1921.6825.5001.00
lsp-password hmac-md5 encrypted 073F007F7D3E363733
address-family ipv4 unicast
metric-style wide
mpls traffic-eng level-1
mpls traffic-eng router-id Loopback0
segment-routing mpls
!
interface Loopback0
passive
address-family ipv4 unicast
prefix-sid index 101
!
!

interface GigabitEthernet0/0/0/0
suppressed
circuit-type level-1
point-to-point
address-family ipv4 unicast
!
!

!

router bgp 1
bgp router-id 192.168.255.1
bgp log neighbor changes detail
address-family vpnv4 unicast
!
neighbor 192.168.255.2
remote-as 1
address-family vpnv4 unicast
!
!
vrf vpnA
rd auto
address-family ipv4 unicast
allocate-label all
!
neighbor 192.168.128.2
remote-as 100
update-source GigabitEthernet0/0/0/1
address-family ipv4 labeled-unicast
route-policy ACCEPT_ALL in
route-policy ACCEPT_ALL out
as-override
!
!
!
!
mpls oam
!
mpls traffic-eng
!
segment-routing

 

sh route vrf vpnA

...

B 192.168.1.1/32 [20/0] via 192.168.128.2, 01:30:24
B 192.168.1.2/32 [200/0] via 192.168.255.2 (nexthop in vrf default), 00:29:27
C 192.168.128.0/30 is directly connected, 01:34:23, GigabitEthernet0/0/0/1
L 192.168.128.1/32 is directly connected, 01:34:23, GigabitEthernet0/0/0/1

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi,

 

There are a few elements missing.

 

1. IOS-XR requires a static routes between 2 eBGP LU neighbors as discussed in the following document:

https://www.cisco.com/c/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/200523-Configuration-and-Verification-of-Layer.html

 

"For Cisco IOS-XR over Inter-AS link, there is a different logic as compared to that of Cisco IOS. It is required to configure a static /32 route to ASBR1's interface, so that MPLS label is bound for a /32 prefix. If this is not done then the control plane will come up, but the traffic will not be forwarded."

 

on CE1:

router static
address-family ipv4 unicast
192.168.128.1/32 GigabitEthernet0/0/0/0
 on PE1:

router static
vrf vpnA
address-family ipv4 unicast
192.168.128.2/32 GigabitEthernet0/0/0/0

Make sure you replicate between PE2 and CE2 as well. 

 

2. You need to configure the update-source for the iBGP session between PE1 and PE2.

on PE1:

neighbor 192.168.255.2
remote-as 1
update-source Loopback0
address-family vpnv4 unicast
!

on PE2:

neighbor 192.168.255.1
remote-as 1
update-source Loopback0
address-family vpnv4 unicast
!

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

5 Replies 5

between CE and PE there is eBGP?
so why the neighbor and remote as is different?

I've corrected the post to reflect the correct ASN. It was error introduced when writing the post.

please note that the MPLS TE is unidirectional so in other side are you config also MPLS TE or not?

Harold Ritter
Cisco Employee
Cisco Employee

Hi,

 

There are a few elements missing.

 

1. IOS-XR requires a static routes between 2 eBGP LU neighbors as discussed in the following document:

https://www.cisco.com/c/en/us/support/docs/multiprotocol-label-switching-mpls/mpls/200523-Configuration-and-Verification-of-Layer.html

 

"For Cisco IOS-XR over Inter-AS link, there is a different logic as compared to that of Cisco IOS. It is required to configure a static /32 route to ASBR1's interface, so that MPLS label is bound for a /32 prefix. If this is not done then the control plane will come up, but the traffic will not be forwarded."

 

on CE1:

router static
address-family ipv4 unicast
192.168.128.1/32 GigabitEthernet0/0/0/0
 on PE1:

router static
vrf vpnA
address-family ipv4 unicast
192.168.128.2/32 GigabitEthernet0/0/0/0

Make sure you replicate between PE2 and CE2 as well. 

 

2. You need to configure the update-source for the iBGP session between PE1 and PE2.

on PE1:

neighbor 192.168.255.2
remote-as 1
update-source Loopback0
address-family vpnv4 unicast
!

on PE2:

neighbor 192.168.255.1
remote-as 1
update-source Loopback0
address-family vpnv4 unicast
!

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thank you!

Review Cisco Networking products for a $25 gift card